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GETTING	STARTED

INSTALLATION

INSTALL	ON	WINDOWS
Install
Start	MuseScore

Uninstall
Troubleshooting
External	links

INSTALL	ON	MACOS
Install
Uninstall
Install	with	Apple	Remote	Desktop
External	links

INSTALL	ON	LINUX
AppImage
Step	1	-	Download
Step	2	-	Give	execute	permission
Step	3	-	Run	it!
Installing	the	AppImage	(optional)
Using	command	line	options

Distribution	Packages
Fedora

External	links

INSTALL	ON	CHROMEBOOK
External	links

CREATE	NEW	SCORE
Start	center
Create	new	score
Title,	composer	and	other	information
Select	template
Choose	instruments	or	voice	parts
Add	staff
Add	Linked	Staff

Select	key	signature	and	tempo
Time	signature,	pickup	measure	(anacrusis),	and	number	of	measures
Adjustments	to	score	after	creation
Add/Delete	Measures
Add/Edit	text
Change	Instrument	set-up

Templates
User	template	folder
System	template	folder

See	also
External	links

LANGUAGE	SETTINGS	AND	TRANSLATION	UPDATES
Change	language
Update	translation
See	also
External	links

CHECKING	FOR	UPDATES
Automated	update	check
Check	for	update
See	also

BASICS
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NOTE	INPUT
Basic	note	entry
Step	1:	Starting	position
Step	2:	Note	input	mode
Step	3:	Duration	of	the	note	(or	rest)
Step	4:	Enter	pitch	(or	rest)
Other	shortcuts

MIDI	keyboard
Coloring	of	notes	out	of	an	instrument's	range
Small	notes/small	noteheads
Change	notes	already	entered
Change	duration
Change	pitch
Change	rest	to	note	and	vice	versa

Note	properties
See	also
External	links

CONCERT	PITCH
See	also
External	links

COPY	AND	PASTE
Notes
Copy	or	cut
Paste

Other	elements
Copy	or	cut
Paste

Quick	repeat
Duplicate
Selection	filter
See	also
External	links

EDIT	MODE
Text
Lines
Notes
Offsetting	notes

See	also

INSPECTOR	AND	OBJECT	PROPERTIES
Inspector
Inspector	categories
Element
Element	Group
Segment
Chord
Note
Select

Properties	dialogs
Articulation	properties
Fretboard	diagram	properties
Line	properties
Measure	properties
Staff	properties
Text	properties
Time	signature	properties

See	also

MEASURE	OPERATIONS
Append
Append	an	empty	measure	to	the	end	of	a	score
Append	multiple	measures	to	the	end	of	a	score

Insert
Insert	an	empty	measure	into	the	score
Insert	multiple	measures

Delete
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Delete	a	single	measure
Delete	a	range	of	measures
Delete	from	a	selected	measure	to	the	end	of	the	score
Delete	from	the	start	of	the	score	to	a	selected	measure

Properties
Staves
Measure	duration
Other

Numbering
Split	and	join
See	also

PALETTES	AND	WORKSPACES
Workspaces
Single	Palette	Mode
Docking/undocking
Custom	workspace

Palettes
Applying	symbols	from	a	palette
Preset	palettes	(Advanced	workspace)
Custom	palettes
Palette	menu

Master	palette
Behavior	of	applied	text	and	lines
See	also

SAVE/EXPORT/PRINT
Save
Export
Print
See	also

SELECTION	MODES
Selection	of	a	single	object
Selection	of	a	single	note	or	chord
Range	selection
List	selection
Select	all	similar
What	selections	are	useful	for
See	also

UNDO	AND	REDO

VIEWING	AND	NAVIGATION
View	menu
Show	sidebars/panels
Zoom	in/out
Show	Status	bar
Split	display
Visibility	options
Full	screen

Page/Continuous	View
Page	View
Continuous	View

Navigator
Toolbars
Side	panels
Find
See	also

SHARE	SCORES	ONLINE
Create	an	account
Share	a	score	directly	from	MuseScore
Upload	a	score	on	MuseScore.com
Edit	a	score	on	MuseScore.com
See	also
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NOTATION

ACCIDENTALS
Add	accidental
Change	enharmonic	spelling
Respell	pitches
See	also
External	links

ARPEGGIOS	AND	GLISSANDI
Arpeggios
Glissandi	(slides)
Other	slides
External	links

ARTICULATIONS	AND	ORNAMENTS
Articulations
Ornaments
Add	articulation/ornament
Add	accidental	to	an	articulation
Add	fermata	to	a	barline
Keyboard	shortcuts

Adjust	position
Articulation	properties
See	also
External	links

BENDS
Apply	a	bend
Adjust	height
Adjust	position
Custom	bends

BARLINES
Change	barline	type
Connect	barlines
See	also

BEAMS
See	also

BRACKETS
Add
Delete
Change
Edit
Style

BREATHS	AND	PAUSES

CLEFS
Add	a	clef
Add	clef	to	beginning	of	measure
Add	mid-measure	clef

Courtesy	clefs
Remove	a	clef
Hide	clefs

DRUM	NOTATION
Drum	input	palette
Note	input	methods
MIDI	keyboard
Piano	keyboard
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Computer	keyboard
Mouse

Edit	Drumset
Roll
External	links

GRACE	NOTES
Create	grace	notes
Change	duration
Manual	adjustment
External	links

HAIRPINS
Add	a	hairpin
Edit	a	hairpin
Cresc.	and	dim.	lines
Hairpin	playback

KEY	SIGNATURES
Add	a	new	key	signature
Add	new	key	signature	to	all	staves
Add	new	key	signature	to	one	staff	only

Replace	an	existing	key	signature
Replace	key	signature	for	all	staves
Replace	key	signature	for	one	staff	only

Remove	a	key	signature
Courtesy	key	signature
Naturals	on	key	signature	changes
Key	signature	and	multimeasure	rest
Courtesy	key	signatures	and	section	breaks
Custom	key	signatures

LINES
Applying	lines	to	the	score
Change	length
Custom	lines	and	line	properties
Copying	lines
Extended	ornament	lines
External	links

MEASURE	RESTS
Full	measure	rest
Multimeasure	rest
Instructions
Limitations

Break	multimeasure	rest

OCTAVE	LINES
Apply	an	octave	line
Change	length
Custom	lines
External	links

REPEATS	AND	JUMPS
Playback
Repeat	symbols	and	text
Jumps
Markers
Examples
See	also
External	links

SLURS
First	method
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Second	method
Third	method
Adjustments
Dotted	slurs
See	also

TABLATURE
Edit	tablature	properties
Create	a	new	tablature	staff
With	the	New	Score	wizard
With	the	Instruments	dialog
By	changing	staff	type

Change	string	tuning
Combine	pitched	staff	with	tablature
Create	a	staff/tablature	pair	with	the	New	Score	wizard
Create	a	staff/tablature	pair	from	an	existing	staff
Change	a	linked	staff/tablature	pair	to	unlinked	(or	vice-versa)

Inputting	new	notes
Keyboard
Mouse
Selecting	note	duration

Editing	existing	notes
Summary	of	keys
Note	input	mode
Normal	mode

External	links

TIES
Tie	notes	together
Tie	chords	together

Add	tied	notes	in	note	input	mode
Add	a	tied	chord	in	note	input	mode

Tied	unison	notes
Flip	a	tie
See	also
External	links

TIME	SIGNATURES
Add	a	time	signature	to	a	score
Delete	a	time	signature
Create	your	own	time	signature
Additive	(composite)	meters
Change	default	beaming
Different	duration	from	time	signature:	Pickup	measures	(Anacrusis)	and	Cadenzas
Local	time	signatures
Time	signature	changes	and	breaks
See	also
External	links

TRANSPOSITION
Chromatic	transposition,	by	key
Chromatic	transposition,	by	interval
Diatonic	transposition
Transposition	shortcuts
Transposing	instruments
Change	staff	transposition

External	links

TREMOLO

TUPLETS
Create	a	tuplet
Create	a	triplet	in	normal	mode
Create	a	triplet	in	note	input	mode
Create	other	tuplets
Custom	tuplets

Delete	a	tuplet
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Settings
Inspector
Style

See	also
External	links

VOICES
When	to	use	voices
How	to	enter	notes	in	different	voices
Hidden	spacer	rests
Exchange	voices	of	notes
Move	notes	to	another	voice	(without	swapping)
See	also
External	links

VOLTAS
Text
Playback
External	links

SOUND	AND	PLAYBACK

MIDI	IMPORT
Available	operations

MID-STAFF	INSTRUMENT	CHANGES
Add	an	instrument	change
See	also

MIXER
Mute	and	Solo
Dials
Sound
Mid-staff	sound	change	(pizz.,	con	sordino,	etc.)
See	also

PLAY	MODE
Play	panel
Count	in
Metronome	playback
Loop

SOUNDFONTS
Overview
Install	a	SoundFont
Uninstall

Synthesizer
List	of	SoundFonts
Specialized	SoundFonts

Troubleshooting
See	also
External	links

SWING
Set	up	swing
Return	to	straight	rhythm
Swing	settings
Swing	text	settings
Global	swing	settings

SYNTHESIZER
Overview
Synthesizer	settings
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131
131
132
132
132
132
132
133

SoundFont
Volume
Effects
Zita	1	reverb
SC4	compressor

Tuning
Change	master	tuning
Set	default	tuning
Change	tuning	for	an	individual	score

See	also

TEMPO
Tempo	text
Ritardando	and	accelerando
Fermatas

Play	panel
See	also

DYNAMICS
Add	a	dynamic
Adjusting	playback	volume	for	a	dynamic
Adjusting	range	for	a	dynamic
List	of	dynamics	in	palettes
Edit	a	dynamic
See	also
External	links

TEXT

TEXT	BASICS
Add	text
Format	text
Text	Style
Text	Properties
Text	editing

Adjust	position	of	text	objects

TEXT	EDITING
Text	edit	mode
Editing	commands	and	keyboard	shortcuts
Special	character	shortcuts

Symbols	and	special	characters
See	also

TEXT	STYLES	AND	PROPERTIES
Text	styles	and	text	properties
Text	types
Create	a	new	text	style
Apply	options
Reset	text	to	style
Save	and	load	text	styles
See	also

STAFF	AND	SYSTEM	TEXT
Staff	text
System	text

CHORD	SYMBOLS
Enter	a	chord	symbol
Keyboard	Commands
Edit	a	chord	symbol

Chord	symbol	syntax
Chord	symbol	text
Chord	symbol	style
Style
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Note	spelling
Positioning
Capo

FINGERING

LYRICS
Enter	lyrics	in	a	score
Example
Melisma
Elision	/	Synalepha	/	Lyric	Slur

Special	characters
Adjusting	individual	lyric	lines
Copy	lyrics	to	clipboard
Paste	lyrics	from	clipboard
See	also
External	links

REHEARSAL	MARKS
Add	a	rehearsal	mark
Manual	Placement
Automatic	placement

Automatically	resequence	rehearsal	marks
Search	for	a	rehearsal	mark
Text	style
See	also

FORMATTING

LAYOUT	AND	FORMATTING
Ways	to	affect	layout
Layout	→	Page	Settings...
Layout	→	Increase	Stretch,	Decrease	Stretch
Style	→	General...	→	Score
Style	→	General...	→	Page
Distance	to	page	margins
Distance	between	staves
Distance	between	systems
Lyrics	Margins
Vertical	frame	margins
Last	system	fill	threshold

Style	→	General...	→	Header,	Footer,	Numbers
Style	→	General...	→	System
Style	→	General...	→	Measure
Style	→	General...	→	Barlines
Palette	→	Breaks	&	Spacers
Style	→	General...	→	Notes
Style	→	General...	→	Clefs
Style	→	General...	→	Arpeggios
Style	→	General...	→	Beams
Style	→	General...	→	Slurs/Ties
Style	→	General...	→	Sizes
Style	→	General...	→	Hairpins,	Volta,	Ottava
Style	→	General...	→	Pedal,	Trill
Style	→	General...	→	Chord	Symbols,	Fretboard	Diagrams
Style	→	General...	→	Figured	Bass
Style	→	General...	→	Articulations,	Ornaments
Style	→	General...	→	Accidentals
Style	→	General...	→	Tuplets
Apply	and	OK	buttons
Apply	to	all	parts	in	one	go
Save/Load	style
See	also
External	links
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172
172

GENERAL	STYLE:	MEASURE
Options

PAGE	SETTINGS
Page	size
Page	margins
Staff	space/scaling
Miscellaneous

BREAKS	AND	SPACERS
Adding	a	break	or	spacer
Adjusting	a	spacer
Deleting	a	break	or	spacer
Section	break
See	also

FRAMES
Horizontal	frame
Vertical	frame
Text	frame
Create	a	frame
Delete	a	frame
Apply	a	break
See	also
External	links

IMAGE	CAPTURE
See	also

IMAGES
See	also
External	links

ALIGN	ELEMENTS
Snap	to	grid

ADVANCED	TOPICS

ACCESSIBILITY
Introduction
Initial	setup
Finding	your	way	around
The	score	window
Score	reading
Moving	forwards	or	backwards	in	time
Moving	between	notes	at	a	given	point	in	time
Filtering	score	reading

Score	playback
Score	editing
Customization

ALBUMS
Create	album
Load	album
Print	album
Join	scores
Save	album

CROSS-STAFF	NOTATION
See	also
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EARLY	MUSIC	FEATURES
Unbarred	notation
Mensurstrich
Ambitus
Mensural	time	signatures
See	also

FIGURED	BASS
Adding	a	new	figured	bass	indication
Text	format
Digits
Accidentals
Combined	shapes
Parentheses
Continuation	lines
Duration

Editing	existing	figured	basses
Style
Proper	syntax
Summary	of	keys

FILE	FORMATS
MuseScore	native	format
MuseScore	format	(*.mscz)
Uncompressed	MuseScore	format	(*.mscx)
MuseScore	backup	file	(.*.mscz,)	or	(.*.mscx,)

Graphics—view	and	print	(export	only)
PDF	(*.pdf)
PNG	(*.png)
SVG	(*.svg)

Audio—listen	(export	only)
WAV	audio	(*.wav)
FLAC	audio	(*.flac)
Ogg	Vorbis	(*.ogg)
MP3	(*.mp3)

Share	with	other	music	software
MusicXML	(*.xml)
Compressed	MusicXML	(*.mxl)
MIDI	(*.mid,	*.midi,	*.kar)
MuseData	(*.md)	(import	only)
Capella	(*.cap,	*.capx)	(import	only)
Bagpipe	Music	Writer	(*.bww)	(import	only)
BB	(*.mgu,	*.MGU,	*.sgu,	*.SGU)	(import	only)
Overture	(*.ove)	(import	only)
Guitar	Pro	(*.GTP,	*.GP3,	*.GP4,	*.GP5,	*.GPX)	(import	only)

See	also
External	links	{external-links}

FRETBOARD	DIAGRAMS
Add	a	fretboard	diagram
Edit	fretboard	(chord)	diagram
Adjust	position,	size,	color
Fretboard	diagram	style

MASTER	PALETTE
Symbols
Find	a	symbol
Apply	a	symbol
Connect	symbols

See	also

NOTEHEADS
Notehead	groups
Change	notehead	group
Change	notehead	type
Shared	noteheads
Change	offset	noteheads	to	shared
Remove	duplicate	fret	marks
Examples	of	notehead	sharing

External	links
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203
203
204
204
204
205

206
206
207
207
210
210
210
211
212

PART	EXTRACTION
Set	up	all	parts	at	once
Define	specific	parts
Exporting	the	parts
Saving

PLUGINS
Overview
Installation
Windows
macOS
Linux

Enable/disable	plugins
Create/edit/run	plugins
Plugins	installed	by	default
ABC	Import
Break	Every	X	Measures
Notes	→	Color	Notes
Create	Score
helloQml
Notes	→	Note	Names
Panel
random
random2
run
scorelist
ScoreView
Walk

See	also

PREFERENCES
General
Canvas
Note	input
Score
I/O
Import
Export
Shortcuts
Update
See	also

RECOVERED	FILES
Behavior	of	saving	after	session	recovery
Finding	recovered	files
See	also
External	links

REPLACE	PITCHES	WITHOUT	CHANGING	RHYTHMS
See	also

SCORE	PROPERTIES
Preexisting	meta	tags
Modify	a	meta	tag
Add	a	new	meta	tag
Header/Footer
See	also

STAFF	PROPERTIES
Common	Staff	Properties	options
Plucked-string	Staff	Properties:	specific	options
Advanced	style	properties
Standard	and	Percussion	staff	specific	items
Tablature	staff	specific	items
Fret	marks
Note	values
Preview
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217
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218
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220

220
220
220
220
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221

221

221
221
222
222
222
222
222
222
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223

Change	instrument
See	also

TOOLS
Add	/	Remove	line	breaks
Explode
Implode
Apply	implode	to	multiple	staves
Apply	implode	to	a	single	staff

Fill	with	slashes
Toggle	rhythmic	slash	notation
Resequence	rehearsal	marks
Copy	lyrics	to	clipboard
See	also

NEW	FEATURES	IN	MUSESCORE	2

SEE	ALSO

UPGRADING	FROM	MUSESCORE	1.X
How	to	upgrade	MuseScore
Opening	1.x	scores	in	MuseScore	2
Local	relayout
Getting	the	sound	from	MuseScore	1.x

SUPPORT

HELPING	IMPROVE	TRANSLATIONS
Software	translation
Website	and	handbook	translation
See	also

HOW	TO	ASK	FOR	SUPPORT	OR	FILE	BUG	REPORTS
See	also

REVERT	TO	FACTORY	SETTINGS
MuseScore	2.0.3	and	above
MuseScore	2.0	through	2.0.2
Instructions	for	Windows
Instructions	for	MacOS
Instructions	for	Linux

See	also

KNOWN	INCOMPATIBILITIES
Hardware	incompatibilities
Software	incompatibilities
AVG	Internet	Security	hangs	MuseScore
Font	problem	on	macOS
Font	problem	on	Linux
Save	As	dialog	empty	on	Linux

APPENDIX

KEYBOARD	SHORTCUTS
Navigation
Note	input
Duration
Voices
Pitch
Interval

Layout
Articulations
Text	entry
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224
224
224
224
224
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224

224
225
226
226

226
229

Lyrics	entry
Display
Miscellaneous

See	also

KNOWN	LIMITATIONS	OF	MUSESCORE	2.0
Basics
Save	Selection
Local	Time	Signatures

Note	input
Tablature	staff	linked	with	Standard	staff

Sound	and	playback
Instrument	change
Mixer

Layout
Header	&	Footer

COMMAND	LINE	OPTIONS
Qt	Toolkit	Options
See	also
External	links

GLOSSARY
External	links
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Published on MuseScore (https://musescore.org)

This handbook is for MuseScore version 2.0 and above. It is maintained and translated by the
MuseScore community. Find out how you can help.

In case of doubt, consult the English online version of the handbook here.

Getting started
This chapter helps you to install and run MuseScore for the first time. The chapter will also show you
how to create a new score.

Installation
MuseScore works on many different computer systems including Windows, macOS, and Linux.

Install on Windows

Install

You can get the Windows installer from the download page of the MuseScore website. Click on the
link to start the download. Your Internet browser will ask you to confirm that you want to download this
file. Click Save File.

When the download finishes, double-click on the file to start the installation. Windows may prompt you
with a security window to confirm this before running the software. Click Run to continue, you'll then
briefly see

followed by
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In case you don't see this installer window but something else, it's possible that the .msi extension is
not associated with msiexec.exe. Either you can fix the association, or download and use the portable
version of MuseScore instead.

Continuing you'll see

If you click Cancel, here or later, you'll see:

If instead you click Next to continue, the setup wizard displays the terms of the free software license.
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Read the terms of the license, make sure the box next to I accept the terms in the License
Agreement is checked, and click Next to continue. Next the installer will ask you to confirm the location
in which to install MuseScore.

If you are installing a newer version of MuseScore but still want to keep the old version on your
computer, then you should change the folder (note that MuseScore 2 can coexist with MuseScore 1
with no changes needed). Otherwise click Next to continue.
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Click Install to continue.

Give the setup wizard a few minutes to install the necessary files and configurations. You'll see

and finally
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Click Finish to exit the installer. You may delete the installer file you downloaded.

Start MuseScore

To start MuseScore choose Start → All Programs → MuseScore 2 → MuseScore 2.

Uninstall

You can uninstall on 32-bit Windows with

    cd C:\Program Files\MuseScore
    Uninstall.exe /S

and on 64-bit Windows with

    cd C:\Program Files (x86)\MuseScore
    Uninstall.exe /S

Troubleshooting

On Windows XP and Vista, the installer might be blocked by the system. If you don't manage to install
MuseScore, right click the downloaded file and click Properties. If there is a message "This file came
from another computer and might be blocked to help protect this computer", click on "Unblock", "OK"
and double click on the downloaded file again.

External links

How to install MuseScore on Windows without administrator rights
How to run MuseScore as Administrator on Windows
How to change the language in MuseScore

Do you have an unanswered question? Post it in the forum.

Install on macOS

Install

You will find the DMG (disk image) file on the download page of the MuseScore website. Click on the
macOS link to start the download. When the download is complete, double-click the DMG file to
mount the disk image.
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Drag and drop the MuseScore icon to the Applications folder icon.

If you are not logged in as administrator, macOS may ask for a password: click Authenticate and
enter your password to proceed.

When the application has finished copying, eject the disk image. You can now launch MuseScore from
the Applications folder, Spotlight, or Launchpad.

Uninstall

Simply delete MuseScore from Applications folder.

Install with Apple Remote Desktop

You can copy the DMG on all computers with the "Copy" feature of ARD. Then, install MuseScore with
a couple Unix commands sent from the "Unix" feature of ARD.

hdiutil mount <Path to where you copied .dmg>/MuseScore-2.0.3.dmg
cp "/Volumes/MuseScore-2.0.3/MuseScore 2.app" /Applications
hdiutil unmount /Volumes/MuseScore-2.0.3
rm -rf <Path to where you copied .dmg>/MuseScore-2.0.3.dmg

If you want to deploy a PKG, you can make one with pkgbuild or with
https://github.com/scriptingosx/quickpkg.
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External links

How to change the language in MuseScore

Do you have an unanswered question? Post it in the forum.

Install on Linux
With MuseScore 2.0.3 you can, for the first time, get hold of a copy for Linux straight from the
Downloads page, just like Windows and Mac users. This is possible thanks to the AppImage
packaging format, which runs on pretty much all Linux distributions. If you prefer, there is still the
option to get it the traditional way via your distribution's package manager (but you may have to wait
for it to get packaged by the relevant maintainer). Of course, you can always build from source.

AppImage

The AppImage format is a new way of packaging Linux applications. AppImages are portable - they
don't have to be installed - and they run on pretty much any Linux distribution. Dependencies are
included in the one AppImage file.

Step 1 - Download

Before you download an AppImage, you need to know your processor's architecture. These terminal
commands will show it:

arch

or

uname -m

The output will be something like "i686", "x86_64" or "armv7":

i686 (or similar) - 32 bit Intel/AMD processor. (Found on older machines.)
x86_64 (or similar) - 64 bit Intel/AMD processor. (Modern laptop and desktop computers, most
Chromebooks.)
armv7 (or later) - ARM processor. (Phones & tablets, Raspberry Pi 2/3 running Ubuntu Mate,
some Chromebooks. Usually 32 bit at present.)

Now you can head over to the Download page and find the AppImage that best matches your
architecture. Once downloaded, the file will be named "MuseScore-X.Y.Z-$(arch).AppImage".

Step 2 - Give execute permission

Before you can use the AppImage you need to give permission for it to be run as a program.

From the Terminal:

This command gives the user (u) permission to execute (x) the AppImage. It works on all Linux
systems.

cd ~/Downloads
chmod u+x MuseScore*.AppImage

Note: Use the "cd" command to change directory to wherever you saved the AppImage.

From a File Manager:

If you prefer to avoid the command line, there is usually a way give execute permission from inside a
File Manager.

In GNOME Files (Nautilus), simply:

1. Right-click on the AppImage and select "Properties".
2. Open the "Permissions" tab.
3. Enable the option labelled "Allow executing file as a program".
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The process may be slightly different in other file managers.

Step 3 - Run it!

Now you should be able to run the program simply by double-clicking on it!

When you downloaded the AppImage it was probably saved in your Downloads folder, but you can
move somewhere else it at any time (e.g. you could put it on your desktop for easy access). If you
ever want to remove it then simply delete it.

Installing the AppImage (optional)

You can run the AppImage without installing it, but you must install it if you want it to be completely
integrated with your desktop environment. This has the following benefits:

Adds the AppImage to your Applications Menu or Launcher
Sets the correct icons for MuseScore's files (MSCZ, MSCX) and for MusicXML files (MXL, XML)
Makes the AppImage available via your File Manager's right-click "Open with..." menu

To install it, run the AppImage from the Terminal with the "install" option (see immediately below).
This copies a desktop file and various icons to your computer. If you want to remove them you will
need to run the "remove" option before you delete the AppImage. This does not affect any scores
created with any version of MuseScore.

Using command line options

Running the AppImage from the Terminal allows you to use various command line options. The
AppImage has some special options in addition to MuseScore's normal command line options.

You will need to change directory (cd) to wherever the AppImage is saved your system, for example:

cd ~/Desktop
./MuseScore*.AppImage *option*

Or give the path to the AppImage:

~/desktop/MuseScore*.AppImage *option*

Use the "--help" and "man" options to get more information about the available command line options:

./MuseScore*.AppImage --help   # displays a complete list of command line options

./MuseScore*.AppImage man      # displays the manual page (explains what the options do)

Distribution Packages

Fedora

1. Import the GPG key:

su
rpm --import http://prereleases.musescore.org/linux/Fedora/RPM-GPG-KEY-Seve

2. Go to the download page of the MuseScore website. Click on the link for the stable Fedora
download and choose the correct rpm package for your architecture.

3. Depending on your architecture, use one of the two sets of commands to install MuseScore

for arch i386

su
yum localinstall musescore-X.Y-1.fc10.i386.rpm

for arch x86_64

su
yum localinstall musescore-X.Y-1.fc10.x86_64.rpm

If you have difficulty with sound, see Fedora 11 and sound
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External links

How to run the MuseScore AppImage on Linux - video
How to change the language in MuseScore

Do you have an unanswered question? Post it in the forum.

Install on Chromebook
MuseScore will not work natively on Chrome OS but there are some workaround solutions.

1. Via Crouton: Involves installing a Linux based operating system which runs in parallel with
Chrome OS, and then installing MuseScore on Linux.

2. Via software-on-demand service such as Rollapp: By just visiting this website, you can run
MuseScore in the browser, but you can only start scores from scratch and only save them to
your online MuseScore account through the menu File → Save Online..., and sound and
playback does not work.

External links

How to run MuseScore on a Chromebook
Check the installation procedure from the comments in this thread
How to change the language in MuseScore

Do you have an unanswered question? Post it in the forum.

Create new score
The New Score Wizard helps you to set up a new score. To open the New Score Wizard directly, see
Create new score (below). You can also get to the New Score Wizard via the Start Center.

Start center
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This is the window that displays when you first open MuseScore. Alternately you can open it by
selecting it from View → Start Center... (keyboard shortcut, F4).

Here, you can choose between options such as

Create a new score (by clicking on the icon with the plus sign)
Open a previously opened score
If opening MuseScore for the first time, open the "Getting Started" tutorial score
Open an existing score from your computer's file system
See the "In the spotlight" score of the day
Search sheet music on musecore.com
Link to mobile apps
Link to follow MuseScore on social networks

Create new score

To open the New Score Wizard when the Start Center is not open, use one of the following options:

Click on the New Score icon in the toolbar on the top left of the window;
Use keyboard shortcut Ctrl+N (Mac: Cmd+N);
Select File → New....

Title, composer and other information

Enter the title, composer, or any other information as shown above, then click on Next >. This step is
optional: you can also add this information after the score is created (see Vertical frame).

Select template
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Here, you can choose from a range of solo, ensemble and orchestral templates (discussed in more
detail below). If you wish to choose exactly what instruments should be in your score then click on the
"Choose Instruments" template (under "General").

Choose instruments or voice parts

If you can't find an appropriate template, then click "Choose Instruments".
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The Chose Instruments window is divided into two columns:

The left column contains a list of instruments, or voice parts to choose from. This list is
categorized into instrument families, and clicking a category shows the full list of instruments in
each family.

The default entry is "Common instruments" but you can choose from others, including "Jazz
instruments" and "Early music". There is a search box at the bottom of the instrument window:
typing the name of an instrument there will search for it in "All instruments".

The right column starts off empty, but will eventually contain a list of instruments for your new
score, in the order that they will appear.

The most widely used staff is the standard type (five lines), but percussion and tablature
staves are also provided. You can use the drop-down list under Staff type to make preliminary
adjustments to staves: for example, to change a standard staff to tablature or vice versa, or to
change the appearance of a tablature or percussion staff.

To add instruments to your score use any of the following options:

Select one or more instruments in the left column and click Add.
Double-click an instrument in the left column.

The instrument names, and their associated staff lines, now appear in the instrument list in the right
column. You can add more instruments or voice parts, as needed. Each instrument added in this way
is allocated its own Mixer channel.

To change the order of instruments/staves, click either an instrument name or a staff and use the Up
or Down buttons to move it higher/lower.

To delete an instrument, or staff line, from your score:

Select an instrument, or a staff line, in the right column and click Remove.

Add staff

This method is used to add another staff to an existing instrument in your instrument list:
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1. Select a staff in the instrument list on the right-hand side (e.g. see "Staff 1" in the image below).
Click Add Staff.

2. Adjust the Staff type, if applicable.

Each instrument staff can be edited independently of the other(s). All staves share the same
instrument name and Mixer channel.

You can use Add Staff to create an unlinked staff/tablature system for the guitar or other plucked-
string instrument (see Combine pitched staff with tablature).

Add Linked Staff

This method is used to add a linked staff to an existing instrument in your instrument list:

1. Select an instrument staff in your instrument list (e.g., "Staff 1"; see image above) and click Add
Linked Staff.

2. Use the Staff type column to change the new staff as required.

Any changes to the notation in one staff will automatically be translated to the other. All staves share
the same instrument name and Mixer channel.

You can use theAdd Linked Staff button to create a linked staff/tablature system for the guitar or
other plucked-string instrument (see Combine pitched staff with tablature).

Note: To adjust the distance between staves within a single instrument (created with the Add Staff or
Add Linked Staff buttons), use the Grand Staff Distance setting.

Select key signature and tempo
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The wizard asks for two things: The initial key signature and tempo of the score. Select any of the
former and click Next > to continue. An initial tempo can be set here too.

Time signature, pickup measure (anacrusis), and number of measures

You can set your initial time signature here. If the score starts with a pickup, then mark the Pickup
measure checkbox and adjust the time signature (a setting known in the context menu 'Measure
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Properties' as actual duration).

Measures is set to 32 by default: you can change the number here, or add/remove measures later
from the score.

Click Finish to create your new score.

Adjustments to score after creation

Any settings you make in the New Score Wizard can always be changed when you start work on the
score itself:

Add/Delete Measures

To add/delete measures or create a pickup, see Measure operations

Add/Edit text

To change any text, see Text editing. To add a missing Title (or other text item), use the menu Add →
Text → Title (or other text item)

Change Instrument set-up

To add, delete, or change the order of instruments, use the menu Edit → Instruments... or press I.
This opens the Instruments dialog which is virtually identical to the Chose Instruments dialog in the
New Score Wizard (see above).

See also Change instrument (Staff properties).

Templates

The second screen of the new score wizard allows you to choose a template to create a new score
from (see above for details). To create a score using this method, click on a template instead of the
"Choose Instruments" option. Continue and finish the new score wizard as usual.

Template files are normal MuseScore files, stored in a template folder. There are two template folders
created by default: the system template folder that contains the templates installed with MuseScore
and should not be modified, and a private user template folder to add your own templates to. You
can create a custom template that will show in the new score wizard by simply saving a score into that
folder.

User template folder

You can configure the location of your private templates folder in Edit → Preferences... → General,
but MuseScore does create a folder for this purpose.

On Windows, the user template folder is located at %HOMEPATH%\Documents\MuseScore2\Templates.

On macOS and Linux, the user template folder is located at ~/Documents/MuseScore2/Templates.

The new score wizard will show templates from both the system and the user template folder.

System template folder

The content of this folder should not be modified.

On Windows, the system template folder is usually located at C:\Program Files\MuseScore
2\templates or in the 64-bit versions at C:\Program Files (x86)\MuseScore 2\templates.

On Linux, look under /usr/share/mscore-xxx if you installed from the package manager. If you
compiled MuseScore on Linux yourself, then look under /usr/local/share/mscore-xxx (with xxx being
the version you are using).

On macOS, look under /Applications/MuseScore 2.app/Contents/Resources/templates.
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See also

Key signature
Time signature
Clef
Tempo
Staff properties

External links

Video tutorial: MuseScore in Minutes: Lesson 1 - Score Setup

Do you have an unanswered question? Post it in the forum.

Language settings and translation updates
MuseScore will be installed and work with your "System" language (the one used for most programs,
and generally depending on your country and the language settings of the PC, or account).

Change language

1. Go to Edit → Preferences... (Mac: MuseScore → Preferences...)

2. In the General tab, there is a Language section:

You can change it and also update the translation with the Update Translations button. A new window
will appear, showing your language at the top - see below.

As then indicated, you will have to exit and reopen MuseScore for changes and updates to take effect.

Update translation

You can update the translation as explained above, via the preferences settings, but there is another
method:
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1. Go to Help → Resource Manager

2. Click on the Update button

Here too you will have to exit and reopen MuseScore for the update to take effect.

See also

Helping and improve translation

External links

How to change the language in MuseScore

Do you have an unanswered question? Post it in the forum.

Checking for updates
There are two ways to check for updates.

Automated update check

1. Go to Edit → Preferences... (Mac: MuseScore → Preferences...)
2. Select the Update tab

3. Check for update...

32

https://musescore.org/en/handbook/helping-improve-translations
https://musescore.org/en/node/12678
https://musescore.org/en/forum


Now MuseScore will check for updates on every start and notify you, if need be.

Check for update

1. Select Help → Check for Update

2. A dialog will appear with the update status: either "No Update Available" or "An update for
MuseScore is available:" followed by a link to download it.

Note: This menu option is only available in the Mac and Windows versions of MuseScore, as those
can be updated directly from MuseScore.org. Linux distributions have different mechanisms to make
updates available.

See also

Preferences: Updates

Do you have an unanswered question? Post it in the forum.
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Basics
The previous "Getting started" chapter guides you through the installation and process for creating a
new score. The "Basics" chapter gives an overview of MuseScore and describes the general methods
for interacting with the score.

Note input

Basic note entry

Adding notes and rests to a staff requires the following basic steps:

1. Select your starting position for note input
2. Enter note input mode
3. Select the duration of the note (or rest) you want to enter
4. Enter the pitch (or rest) using keyboard shortcut, mouse, or a MIDI keyboard

You may skip step 2 when entering pitches (or rests) using keyboard shortcuts. Using these shortcuts
automatically enables note input mode.

To add overlapping notes that start/end at different times (polyphony), see Voices. For chords,
continue reading here.

Step 1: Starting position

First, select a note or rest on the score as your starting position for note input. If you don't select a
starting point, the cursor will be at the beginning of the score when you begin note input (see below).
Note input in MuseScore replaces the existing rests or notes in a measure with your new notes (i.e.
overwrites, rather than inserts). However, you can insert new measures at any point (see Measure
operations: Insert), or use copy and paste to move a passage of notes.

Step 2: Note input mode

The "N" button at the left on the Note Input toolbar indicates whether you are in note input mode. To
enter or leave note input mode, you can click on the button, or you can use the shortcut N. To leave
note input mode, you can also hit Esc.

Step 3: Duration of the note (or rest)

After entering note input mode, select the duration you need from the Note input toolbar, or use the
corresponding shortcut.

Note that if you have an irregular rhythm division (such as three eighth notes in the time of two), see
Tuplet

The shortcuts for selecting the duration are as follows:

1: 64th (hemidemisemiquaver)
2: 32nd (demisemiquaver)
3: 16th (semiquaver)
4: Eighth (quaver)
5: Quarter (crotchet)
6: Half (minim)
7: Whole (semibreve)
8: Double whole (breve)
9: Longa
.: A period (dot) changes the selected duration into a dotted note/rest

Step 4: Enter pitch (or rest)

For all instruments (except unpitched percussion), you can add note pitches using the mouse by
clicking directly on the staff. (For instructions specific to percussion see Drum notation). However, you
may find it quicker to use a MIDI keyboard (see below), or your alphabetical computer keyboard. The
following examples use the latter method.
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Enter pitches by typing the corresponding letter on your keyboard: C D E F G A B C

0 (Zero) creates a rest: for example, typing C D 0 E gives the result shown below. Notice that the
duration you select for the notes (quarter/crotchet notes in this example) also determines the duration
of the rest (quarter/crotchet rest).

During note input, the cursor automatically advances in the score. If you want to add a chord note to
your previous entry, hold Shift and enter a note name: C D Shift+F Shift+A E F

To create chords with notes of different durations, see Voices.

If you want to create a dotted note, press . after selecting the parent note (or duration shortcut). For
example, 5 . C 4 D E F G A gives the following:

When you type a note on the keyboard, MuseScore places it closest to the previous note entered
(above or below). When entering chords, though, the new notes are added above the current note
(bottom-up).
If either of these leads to a note ending up in the wrong octave, move it up or down by using the
following shortcuts:

Ctrl+↑ (Mac: ⌘+↑): Increase the pitch of a note by one octave.
Ctrl+↓ (Mac: ⌘+↓): Decrease the pitch of a note by one octave.

Other shortcuts

Other useful editing shortcuts available in note input mode:

↑ (Up): Increase the pitch of a note by a semitone (uses ♯).
↓ (Down): Decrease the pitch of a note by a semitone (uses ♭).
Alt+1-9: Add interval (unison to ninth) above current note
J: Change note up to enharmonic note (e.g., E# to F)
Shift+J: Change note down to enharmonic note (e.g., F to E#)
Alt+Shift+↑: Increase the pitch of a note using key signature
Alt+Shift+↓: Decrease the pitch of a note using key signature
R: Repeat the last entered note
Q: Halve the duration of the last entered note
W: Double the duration of the last entered note
Backspace: Undo last entered note
Shift+←: Exchange last entered note with the note before it (repeat to keep moving note earlier)
Shift+→: Exchange note moved with Shift+← with the note that follows it
X: Flip direction of note stem (can be reset to Auto position in Inspector)
Shift+X: Move note head to opposite side of stem (can be reset to Auto position in Inspector)

MIDI keyboard

You can also insert pitches using a MIDI keyboard.
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1. Connect your MIDI keyboard to the computer and switch the former on
2. Start MuseScore (this must be done after the keyboard is switched on)
3. Create a new score
4. Click the rest (selecting it) in measure 1 to indicate where you want note input to begin
5. Press N to enter note input mode
6. Select a note duration such as 5 for quarter notes (crotchets), as described above
7. Press a note on your MIDI keyboard

The pitch should be added to your score.

Note: The MIDI keyboard enters one note or chord at a time. This mode of note input (often called
"step-time entry") is fast and reliable. Some notation software try to interpret "real-time entry", in which
the musician plays a passage and the software tries to produce notation. However, such results are
generally unreliable. MuseScore focuses on more reliable forms of note input.

If you have multiple MIDI devices connected to your computer, you may need to inform MuseScore
which is the MIDI keyboard. Go to Edit → Preferences... (Mac: MuseScore → Preferences...). In the
preferences dialog, click on the I/O tab and select your device under the section labeled "PortAudio".

Coloring of notes out of an instrument's range

Notes within the playable range of an instrument or voice part appear black, while those extending
beyond the normal range of an instrument are marked red. For some instruments, the range depends
on the skill of the musician. For these instruments, notes outside the range of an early amateur
appear dark yellow, and notes outside the typical range of a professional appear red.

The colors are informational and appear on the computer screen, but not on printed copies. To disable
note colors, choose Edit → Preferences... (Mac: MuseScore → Preferences...), click on the Note
Input tab, and unmark "Color notes outside of usable pitch range".

Small notes/small noteheads

1. Select the note(s) you want in small size.
2. Check the "Small" checkbox in the Inspector. The one in the Note section is used to only change

the size of the individual notehead; the one in the Chord section will change the note head, stem,
beam, and flag sizes all together.

By default, the small size is 70% of the normal size. You can change that setting in Style → General →
Sizes.

Change notes already entered

Change duration

To change the length of a single note or rest:

1. Make sure you are not in note input mode (press Esc to exit) and have no other notes selected.
2. Click on the note or rest and use the duration shortcuts listed above, or the duration icons in the

toolbar, to change it to the duration of your choice.

Increasing the duration will overwrite the notes or rests that follow it; decreasing the duration will add
rests between it and the notes or rests following.

For example, to change three sixteenth rests into a single dotted eighth rest:

1. Click on the first sixteenth rest.
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2. Hit 4 to turn it into an eighth rest.
3. Hit . to turn it into a dotted eighth rest.

As the duration increases, it overwrites the other two sixteenth rests following it.

Change pitch

To change the pitch of a single note, first press Esc to make sure that you're not in note input mode
and that you have no other notes selected; then either drag the notehead up or down with the mouse,
or else select it and use the ↑ (Up) or ↓ (Down) keys to change its pitch. You can also type the letter
name of the note you want to change it to, and use Ctrl+↓ or Ctrl+↑ to correct the octave, if necessary
(Mac: Cmd+↓ or Cmd+↑).

To change the enharmonic spelling of a note, select it and use the J command. For more information,
see Accidentals.

To change the pitches of a passage of music by a constant interval, you can use Transposition.

To change the pitches of a passage of music to a different melody, while keeping the rhythm
unchanged, use Re-pitch mode.

If your score contains a lot of misspelled accidentals, you might try the Respell Pitches command (see
Accidentals: Respell pitches).

Change rest to note and vice versa

To change a rest to a note of the same duration:

1. Make sure you are not in note input mode (press Esc to exit).
2. Select the rest.
3. Enter the desired pitch by entering a note letter, A–G.

To change a note to a rest of the same duration:

1. Make sure you are not in note input mode (press Esc to exit).
2. Select the note.
3. Press 0 (Zero).

Note properties

To adjust the horizontal position of a note/chord: see Offsetting notes.
To edit note properties in general (spacing, offset, size, color, notehead direction, playback etc.):
see Inspector and object properties.
To adjust the layout of all notes in the score: see Layout and formatting, especially the sections
about notes, accidentals and tuplets.

See also

Drum notation
Tablature
Tuplet
Voices
Shared noteheads
Preferences

External links

How to enter a chord
How to enter a rest
How to span a stem over two staves
Video tutorial: MuseScore in Minutes: Lesson 3 - Note input
Video tutorial: MuseScore in Minutes: Lesson 4 - MIDI Keyboard Input
Video tutorial: MuseScore in Minutes: Lesson 5 - More Input Ideas

Do you have an unanswered question? Post it in the forum.
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Concert pitch
For transposing instruments, music is notated at a different pitch and in a different key from how it
actually sounds. If you prefer to work in concert pitch, however, the Concert Pitch button—located in
the top-right of the toolbar area—will switch the display to concert pitch and display the music for all
the instruments, transposing and non-transposing, as it sounds.

Before printing the score or exporting it to PDF, you should ensure that the Concert Pitch button is
off, and that the individual parts are correctly transposed.

See also

Transposition: Transposing instruments
Accidental: Respell pitches

External links

Concert pitch (Wikipedia article)
Transposing Instrument (Wikipedia article)
Concert pitch or not?? (MuseScore forum discussion)

Do you have an unanswered question? Post it in the forum.

Copy and paste
MuseScore supports the standard clipboard commands: copy, cut and paste. These can be applied
to a range of:

Musical notes: e.g. to repeat a section of music, or shift a passage by a beat or a measure.
Other elements in the score, such as articulations, staff text, dynamics, fingering etc.

Note: Lines cannot be copied, but they can be duplicated (see →below).

Before clicking on the score to select anything to copy, cut or paste, press Esc to make sure you are
not in note input mode.

Notes

You can cut, copy or paste a passage of music or a single chord as follows:

Copy or cut

To copy/cut a single chord

1. Hold down Shift and click on a note in the chord.
2. Chose an option:

Copy. Select Edit → Copy; or press Ctrl+C (Mac: ⌘+C).
Cut. Select Edit → Cut; or press Ctrl+X (Mac: ⌘+X).

To copy/cut a range of chords

1. Click on the first note or measure that you want to select.
2. Shift+Click on the last note or measure that you want to select. A blue rectangle highlights the

region you selected.
3. Chose an option:

Copy. Select Edit → Copy; or press Ctrl+C (Mac: ⌘+C).
Cut. Select Edit → Cut; or press Ctrl+X (Mac: ⌘+X).

Paste

1. Click on the note or measure where you want your pasted selection to begin.
2. From the menu, choose Edit → Paste or press Ctrl+V (Mac: ⌘+V).

Note: It is possible to copy and paste the pitch of a note only (and no other properties), by clicking on
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the notehead and applying the standard copy and paste procedure. The pitch of the destination note
changes to match that of the copied note but the duration remains the same.

Other elements

Other score elements—such as staff text, dynamics, fingering, chord diagrams etc.—can be cut,
copied and pasted one at a time. Articulations (sforzato, staccatto etc.), in addition, allow multiple
selection.

Copy or cut

1. Select the element (or elements).
2. Chose an option:

Copy. Select Edit → Copy; or press Ctrl+C (Mac: ⌘+C).
Cut. Select Edit → Cut; or press Ctrl+X (Mac: ⌘+X).

Paste

1. Click on the note where you want your pasted selection to begin.
2. From the menu, choose Edit → Paste or press Ctrl+V (Mac: ⌘+V).

In the case of articulations, they are pasted to the destination notes in exactly the same order
(continuous or intermittent) as they were in the initial selection.

Quick repeat

To quickly copy and paste a note, measure, or passage:

1. Select a chord, measure, or passage as described above.
2. Press R .

Musescore copies and pastes the selected notation to a point immediately after the last note in the
selection. Any existing music in the destination range is replaced.

Duplicate

To instantaneously copy and paste a text element, line, or other object:

1. Hold down Ctrl+Shift (Mac: ⌘+Shift), click on the element and drag it anywhere in the score.
2. Release the mouse button, and the selected element is cloned to the new location.

Selection filter

It is possible to use a filter before copying a selection, to choose exactly what is going to be copied
and then pasted.

1. Enable the Selection Filter with F6 (Mac: fn+F6) or View → Selection Filter

The Selection Filter will appear by default below the Palettes. It can be undocked and made into a
floating window, and if that window is dragged directly onto the Palettes, or the Inspector, then both
will be accessible in the same space via a tab at the bottom.

1. Uncheck the boxes in the Selection Filter for things you don't want copied
Example: Articulations and Slurs are unchecked.
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2. Copy and paste as before
(in the example, copy measure 4 and 5 and paste into measure 12 and 13)

3. See the result—slurs haven't been copied:

See also

If you want to change notes without altering the rhythm, you may combine transposition or re-pitch
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mode with copy and paste.

External links

Video tutorial: Lyrics, copying & dynamics

Do you have an unanswered question? Post it in the forum.

Edit mode
Edit mode is used to edit elements that have been added to a score. Most types of elements can be
edited in one way or another in edit mode.

To enter edit mode use any of these methods:

Double-click any element
Right-click on it and choose Edit Element
Click on it once and use the shortcut Ctrl+E (Mac: Cmd+E).

To leave edit mode, hit Esc.

Text

For text edit mode, see Text editing.

Lines

Lines and similar elements, such as slurs, hairpins, arpeggios, and brackets, display square handles in
edit mode (which turn blue when selected). A slur, for example, looks like this:

To alter the shape of a line, click on a handle and either drag it or, for finer control, use the arrow keys.
The following keyboard commands can be used to adjust the position of the currently selected handle:

←: Move handle left 0.1 staff space (one staff space is the distance between two staff lines, as
set in Page Settings)
→: Move handle right 0.1 staff space
↑: Move handle up 0.1 staff space
↓: Move handle down 0.1 staff space
Ctrl+← (Mac: ⌘+←): Move handle left one staff space
Ctrl+→ (Mac: ⌘+→): Move handle right one staff space
Ctrl+↑ (Mac: ⌘+↑): Move handle up one staff space
Ctrl+↓ (Mac: ⌘+↓): Moves handle down one staff space
Alt+←: Move handle left 0.01 staff space
Alt+→: Move handle right 0.01 staff space
Alt+↑: Move handle up 0.01 staff space
Alt+↓: Move handle down 0.01 staff space
Shift+←: Move handle's anchor (the note or measure to which it is attached) left
Shift+→: Move handle's anchor right
Tab: Go to next handle

When an endpoint handle is selected, an anchor—a dotted line showing what part of the score the line
is connected to—may appear. To move an anchor, use Shift+→ or Shift+←.

Notes

Offsetting notes

To move a single note to the right or left (e.g. to avoid a collision with another element or to override
notehead sharing), select the notehead and change the chord horizontal offset in the Inspector.
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Alternatively, you can do the same thing in note edit mode as follows:

1. Enter note edit mode by (i) double-clicking a notehead OR (ii) right-clicking a notehead and
selecting "Edit Element", OR (iii) selecting a notehead and pressing Ctrl + E.

2. Press the arrow key in the direction (left or right) that you wish to nudge the note (or use Ctrl+←
or Ctrl+→ for larger adjustments).

3. Press the Esc key. This will allow the note stem to be redrawn.

Note: Edit mode for a note stem allows you to change the length of the stem, not move it horizontally.
To reposition a note stem, click on it and adjust horizontal offset in the Inspector.

See also

Text editing
Slur
Bracket
Line
Beam
Hairpin

Do you have an unanswered question? Post it in the forum.

Inspector and object properties
Most score elements have properties that can be edited in one of two ways:

Click on any element, and many of its properties can be viewed and changed from the Inspector
panel on the right-hand side of your screen.

Right-click on an element and select an option with the word Properties in it. This option opens
a dialog with advanced properties, only available for certain types of elements.

Inspector

The Inspector is shown by default on the right of your screen. To show or hide it, open the View menu
and check/uncheck Inspector, or use the shortcut F8 (Mac: fn+F8).

In the Inspector, the properties of any selected object are displayed and can be edited. This applies
to virtually every single element in the score window—notes, text, barlines, articulations etc. Multiple
elements can also be selected and edited simultaneously, as long as they are of the same type.
However, if the selected objects are of different types, then the Inspector restricts you to editing color
and visibility only.

The Inspector panel can be un-docked to become a floating panel by clicking the double-chevron
symbol or double-clicking the top bar of the panel.

To re-attach the panel double-click on the top bar again. See also: Side panels.

Inspector categories

When you select one or more elements of a specific type, the properties which can be edited are
conveniently divided into categories in the Inspector. Categories can be identified by their bold,
centred lettering. For example, if you select a barline, you will see the following displayed at the top of
the Inspector:
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For details about how to adjust the properties of various score elements, refer to the relevant sections
in the handbook. However, a few general points will be covered here:

Element

All score elements, except frames, display this category in the Inspector when selected. It allows you
to set visibility, color, and adjust the position using vertical offset and horizontal offset values.
Snap to grid buttons are also provided. The various options are as follows:

Visible: Unchecking this box makes selected elements invisible. Invisible elements do not
appear in the music when printed out or exported as a PDF or image. They will turn gray in the
display to show that they are invisible (if you want invisible elements to be completely invisible
on the screen as well as in the output, select View → Show Invisible). You can also use the
keyboard shortcut V to toggle the visibility of selected elements (i.e., switch between visible and
invisible).

Color: Clicking on the rectangle opens a "Color Select" dialog which allows you to adjust the
color and opacity of selected elements.

Horizontal offset and Vertical offset: Allow you to fine-tune the placement of an individual
element by inputting exact values for its offset from the default position.

Element Group

This category is displayed only when you have selected a mixture of different types of elements, and
allows editing of color and visibility only.

Segment

This category is used to increase or decrease the space before/after an element in a music staff.
Adjusting leading/trailing space here also affects any associated lyric syllables.

Chord

This category is displayed only if notes are selected. Any change to a notehead property under Chord
affects the whole chord (i.e all the notes in one voice) at that location—and not just the selected note.
If you want to make changes to the position of just one note in a chord, then use the Element category
(above).

Note

This category allows you to make changes to selected notes (but for note position—see Element). It
contains the following properties:

Small: Make notehead smaller (you can specify the relative size of all small notes in Style →
General… → Sizes…).
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Head group: See Notehead groups.
Head type: See Notehead types.
Mirror head: Position notehead to the left or right of the stem (default is "Auto").
Tuning: Adjust tuning of note to the nearest cent.
Play: Unticking this box silences the note.
Velocity type: Chose one of two values:

Offset: Make the value shown in "Velocity" relative to the default of 80.
User: Make the value shown in "Velocity" absolute (0 to 127).

Velocity: Adjust MIDI velocity of the note according to the setting chosen in "Velocity type."
Fix to line: When ticked, the note is fixed to the top line of the standard 5-line staff.
Line: A positive number moves the "fixed" note down; a negative number moves it upwards.

Select

This category is only displayed when you select a note, and allows you to easily switch the selection
to the stem, beam, hook, duration dot (or dots) or tuplet number associated with the notehead (see
image below).

Properties dialogs

Properties of some objects are accessed by right-clicking on the object and choosing a "Properties"
option from the context menu: these are in addition to the object's properties displayed in the
Inspector.

(Note: Properties should not be confused with Styles. Changes to properties only affect the single
element selected; all style controls apply to the entire score.)

Articulation properties

Right-click on an articulation and select Articulation Properties... See Articulations and ornaments.

Fretboard diagram properties

Right-click on a fretboard diagram and select Fertboard Diagram Properties... Allows you to create
custom fretboard diagrams. See Edit fretboard diagram.

Line properties

Right-click on a line and select Line Properties... There are settings for the beginning, end, or
continuation of the line. You can add or remove text, adjust the text's placement, and set the length
and angle of optional hooks. Click the ... button to access text properties for text included in the line.
See Custom lines and line properties.

Measure properties

Right-click on an empty part of the measure and select Measure Properties... Adjust visibility, bar
duration, repeats, stretch and numbering. See Measure properties.

Staff properties

Right-click either an empty part of a measure or the name of an instrument and select Staff
Properties... This dialog allows you to adjust attributes of both the single staff and the instrument it is
a part of. See Staff properties.

Text properties

Right click on a text-based element and select Text Properties... See Text styles and properties. If
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the element is a line with text in it, see → above.

Time signature properties

Right-click on a time signature and select Time Signature Properties... Used to adjust appearance
of time sig. and beam properties of notes. See Time signatures.

See also

Measure operations
Note input
Layout and formatting
Staff properties
Part extraction

Do you have an unanswered question? Post it in the forum.

Measure operations

Append

Append an empty measure to the end of a score

Press Ctrl+B (Mac: ⌘+B).

Or select the menu item: Add → Measures → Append One Measure.

Append multiple measures to the end of a score

Press Alt+Shift+B (Mac: Option+Shift+B); fill in the "Number of measures to append" field and
press OK.

Or select the menu item: Add → Measures → Append Measures...; fill in the "Number of measures
to append" field and press OK.

Insert

Insert an empty measure into the score

Select a measure, then press Ins (no shortcut on Mac).

Or select a measure and use the menu item: Add → Measures → Insert Measure.

Insert multiple measures

Select a measure and press Ctrl+Ins (no shortcut on Mac); fill in the "Number of measures to
insert" field and press OK

Or use the menu item: Add → Measures → Insert Measures...; fill in the "Number of measures to
insert" field and press OK.

Delete

Delete a single measure

Click on the measure, then press Ctrl+Del (Mac: Cmd+Del).

Delete a range of measures

1. Click on the first measure in the range, pressShift and click on the last measure in the range;
release the Shiftkey.

2. Press Ctrl+Del (Mac: Cmd+Del).
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Delete from a selected measure to the end of the score

1. Click on the first measure in the range, press Ctrl+Shift+End (Mac: Cmd+Shift+End); release the
keys.

2. Press Ctrl+Del (Mac: Cmd+Del).

Delete from the start of the score to a selected measure

1. Click on the last measure in the range, press Ctrl+Shift+Home (Mac: Cmd+Shift+Home); release
the keys.

2. Press Ctrl+Del (Mac: Cmd+Del).

Note: In multi-staff scores, measure deletion also removes all corresponding measures in the other
staves of the system, even if these don't appear to be selected.

If you wish to delete only the elements (notes, symbols, text) and not the measure itself, then select a
measure or range of measures and click Del. The selected measures are filled with whole measure
rests.

Properties

To edit the properties of a measure, right-click an empty part of the measure and select Measure
Properties...:

From within an open Measure Properties window, you can move to edit the previous or next measure
via these buttons, at the bottom left of the window:  (note that while the window changes,
the measure shown as selected in your score does not. Be careful).

Staves

The visible property allows you to show/hide the notes and staff lines for the current measure.
The stemless property allows you to show/hide all note stems for the current measure. Notes
that normally have a stem such as half notes (minims) and quarter notes (crotchets) only show
the note head when marked as stemless.

Measure duration
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This section allows you to make the actual duration of a measure shorter or longer than that indicated
by the visible (nominal) time signature. Use it to create a pickup measure (anacrusis) at the beginning
of a section, incomplete measures in the score, cadenzas, ad lib passages etc.

The Nominal duration of the measure is the same as the time signature displayed in the score,
and cannot be edited.
The Actual duration of a measure can be set to anything you like regardless of the time signature
displayed on the score.

In the figure below, for example, the quarter note pickup measure has a nominal measure duration of
4/4, but an actual duration of 1/4. The measures in the middle have both nominal and actual durations
of 4/4. The complementary measure with only a dotted half note at the end has an actual duration of
3/4:

Other

Exclude from measure count 
Use "Exclude from measure count" for "irregular" measures, i.e. ones that should not get
counted in the measure numbering. Normally, a pickup measure is marked as "Exclude from
measure count".

Add to measure number 
You can also use the "Add to measure number" option to influence the measure numbering. You
can enter positive or negative numbers here. Please note that this affects all subsequent
measures. A value of "-1" has the same effect as marking a measure to be excluded from
measure count.

Layout stretch 
You can increase or decrease horizontal space between score elements (notes, rests, etc.) with
this option. This provides a more precise control over the exact same measure spacing property
as the menu commands or keyboard shortcuts for Increase/Decrease Stretch ({ and }), which
are accessed outside of the Measure Properties dialog while a measure is selected.

Repeat count 
If the measure is the last of a repeat, you can define how often it is played.

Break multimeasure rests 
This property will separate a multimeasure rest at the start of the selected measure. This option
should be checked before you turn on the "Create multimeasure rests" option in Style →
General..., in the "Score" tab.

Multimeasure rests are automatically broken at important breaks, such as rehearsal marks, time
signature changes, double barlines, irregular measures, etc. The default for scores is off, for
parts is on.

Numbering

MuseScore automatically numbers the first measure of each System (except for the first system,
actually except for a measure with the number 1), but more numbering options are possible. From the
main menu, choose Style → General..., in the left pane, choose the "Header, Footer, Numbers"
tab. At the bottom of the right pane is the "Measure Numbers" ("Bar Numbers") section.

Mark the checkbox next to the "Measure Numbers" ("Bar Numbers") to turn on automatic measure
numbers.

Mark "Show first" if you want the first measure numbered.

Mark "All staves" if you want numbers on all staves. Otherwise, only the top staff of each system
shows measure numbers.

Choose to show numbers on "Every system" which numbers the first measure of each line, or show
numbers by "Interval" and specify the size of the interval. For example, an interval of 1 numbers every
measure; an interval of 5 numbers every fifth measure.
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Split and join

You may want have to have a longer or shorter measure without changing the time signature. You can
change a measure's duration in Measure Properties, but there is now a new option to split or join
measures. (Beams may be automatically modified.)

Join

1. Select the measures you want to join
2. Edit → Measure → Join Selected Measures

Note: If you select measures on only one staff in a score with multiple staves, the same measures will
be joined in each staff of the system.

Split

1. Select a note (or chord)
2. Edit → Measure → Split Measure Before Selected Note

Note: If you select only one note from one staff, each staff of the system will be split at the same
place.

See also

How to delete measures
How to span a measure over multiple systems
How to get scores without time signature (and clef)

Do you have an unanswered question? Post it in the forum.

Palettes and workspaces
A palette is a storage space containing a group of related musical symbols. A workspace is a
collection of palettes and is docked, by default, on the left-hand side of the program window.

Display of the palettes can be toggled on or off with the menu option View → Palettes, or by using the
shortcut F9 (Mac: fn+F9).

Workspaces

A Workspaces is a set of palettes. MuseScore provides two preset workspaces: Basic (the default
option) and Advanced (a version with more palettes and symbols). You can switch between the two
by using the drop-down menu at the bottom of the workspace panel.

The names of palettes within a workspace are clearly listed under the word "Palettes." To open or
close any palette, simply click on its name or the accompanying side-arrow.
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Palettes in the preset workspaces cannot be added to or edited. To do this you first have to create a
custom workspace (see below).

Single Palette Mode

If you only want to allow one palette to open at a time, right click at the top of the workspace and
check the "Single palette" box.

Docking/undocking

To undock or redock a workspace, see Side panels.

Custom workspace

A custom workspace is created by duplicating an existing workspace and renaming it. The palettes
then become available for editing:

Chose a workspace to duplicate. Use the drop-down list at the bottom of the workspace panel if
needed.
Click the + button, enter a name for the new workspace and press OK. The new workspace is
added to the panel.

Alternatively you can use the menu option:

Select Edit → Workspaces, and chose a workspace.
Select New. Fill in the new workspace name and click OK.

Palettes

Applying symbols from a palette

To view the contents of a palette, click on the palette title. A palette symbol may be applied to the
score using one of the following methods:
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⦁ Select one or more score elements and double click the palette symbol.
⦁ Drag and drop the symbol onto the desired score element in the staff.

For example, to add tenuto marks (—) to a selection of notes:

1. Select the desired notes.
2. In the Articulations & Ornaments palette, double-click on the tenuto symbol

Once added to the score, objects can be copied, pasted, and duplicated—see Copy and paste.

Palettes in the preset workspaces cannot be edited. To do this you have to create a custom
workspace first.

Preset palettes (Advanced workspace)

The more fully-featured Advanced workspace contains the following palettes:

Grace Notes
Clefs
Key Signatures
Time Signatures
Barlines
Lines
Arpeggios and Glissandi
Breaths and pauses
Brackets
Articulations and Ornaments
Accidentals
Dynamics
Fingering
Note Heads
Tremolo
Repeats and Jumps
Tempo
Text
Breaks and Spacers
Bagpipe Embellishments
Beam Properties
Frames and Measures
Fretboard Diagrams

Custom palettes

Once you have created a custom workspace (see above), and providing editing is enabled (see
Palette menu below), you can customise the palettes within it to your own requirements. Palettes can
be created, deleted, renamed and reordered. New symbols can be added to them and existing
symbols deleted.

To add an existing score element (such as a line, text, dynamic, fretboard diagram etc.) to a custom
palette, press and hold Ctrl+Shift, then drag the symbol onto the palette. Symbols from the Master
palette can also be added to a custom palette.

Palette menu

Right-clicking on the name of a palette in a custom workspace brings up a menu with a range of
options:

Palette Properties...: This allows you to make adjustments to the appearance of the open
palette:
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Name
Cell Size: Width, Height
Element Offset: Adjusts the vertical offset of all elements in the palette.
Scale: Makes all palette elements appear larger or smaller.
Show grid: Tick this box to visually divide the palette into cells, one for each element.
Show ‘More Elements…’: Tick this box to create a cell which opens the Master Palette.

Insert New Palette: Creates a new empty palette.
Move Palette Up / Move Palette Down: Allows you to reorder the palettes.
Enable Editing: Tick this option if you want to be able to edit a palette.
Save Palette: Save as an .mpal file.
Load Palette: Load an .mpal file.
Delete Palette

Right-clicking on an element within a palette (if editing of the palette is enabled) brings up a menu with
the following options:

Clear: Removes the element from the palette
Properties...: Opens the Palette Cell Properties dialogue:

Name: The tooltip that appears when you mouse over the element.
Content offset (X, Y): Adjust the position of the element in the palette.
Content scale: Make the element appear larger or smaller in the palette.
Draw staff: Draws the five lines of a musical staff behind the palette element.

More Elements: Opens the relevant Master Palette section.

Note: Changing values in "Palette Cell Properties" only affects the appearance of elements in the
palette. It does not change their sizes or offsets on the score page.

Master palette

Music symbols not part of the palettes in the Advanced workspace can be found in the Master palette
by pressing Z or Shift+F9 (Mac: fn+Shift+F9).

Behavior of applied text and lines

If the symbol you are adding to the score from a palette contains a text element (e.g. staff text,
dynamic, fingering, volta etc.), then properties such as font-type, font-size, text color, and alignment
will adapt according to the following rules:

1. Text properties which have not been altered by the user will adopt the relevant, prevailing text
styles.

2. Custom text-properties—i.e. those changed by the user before saving the symbol to a custom
palette—remain as customized.

When adding a line, line properties always remain unchanged (i.e. as set by the user before saving to
a custom workspace, or as predefined in the Basic/Advanced workspaces).

See also

Custom palettes
Master palette

Do you have an unanswered question? Post it in the forum.
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Save/Export/Print
Under the File menu in MuseScore, you can find options such as Save..., Save As..., Save a
Copy..., Save Selection..., Save Online..., Export..., Export Parts... and Print....

Save

Save..., Save As..., Save a Copy..., and Save Selection... allow you to save native MuseScore files
(.mscz and .mscx).

Save...: Save current score to file.
Save As...: Save current score to new file.
Save a Copy...: Save current score to new file, but continue to edit original file.
Save Selection...: Save selected measures to new file. In order to ensure that the file is saved
correctly, the time signature needs to be displayed in the first measure of the selected passage,
unless it is 4/4.
Save Online...: Save current score to MuseScore.com (see Share scores online).

Export

Export... and Export Parts... allow you to create non-MuseScore files, such as PDF, MusicXML,
MIDI, and various audio and image formats.

In the Export dialog, you can choose which format to export to:
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Export...: Export current score to format of your choice.
Export Parts...: Export current score and all linked parts to separate files in format of your
choice.

MuseScore remembers which format you picked the last time and makes that the default for the next
time.
There is a know issue with Windows XP and Vista, there you'd have to manually (un)set the filename's
extension, when chosing a different format than last time.

Note: Uncompressed MuseScore format (MSCX) is available in both 'Save' and 'Export'.

Print

Print... allows to print your MuseScore file directly to a printer from MuseScore. Depending on your
printer you will have different options, but generally you can define the page range, number of copies
and collation.

If you have a PDF printer installed, you could also "export" to PDF using that, although this is not
recommended.
For this to work properly with Adobe PDF, make sure to untick Rely on systemfonts only, do not use
document fonts in Printer properties.

See also

File format
Part extraction

Do you have an unanswered question? Post it in the forum.

Selection modes
There are different selection modes (ways to select objects).

Selection of a single object

Just click on any object.

Selection of a single note or chord

To select all the notes in a chord:

Make sure you are not in note input mode
Press and hold Shift, then click on a note in the chord.

Note: Selecting a single note, then copying and pasting it, will only copy and paste the pitch—not
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duration or other properties (such as stemless). To copy the entire note, including all properties, you
need to hold down Shift, the same as highlighting a whole chord.

Range selection

There are several ways to select a continuous range of notes, chords or measures:

1. Shift selection

a) Make sure you are not in note entry mode
b) Click on the first note/chord/rest or measure in the range. You can extend the selection up or
down to adjacent staves, if needed, using Shift + ↑ or ↓.
c) Then chose one of the following options:

To advance the selection one chord at a time to the right: Press Shift + →.
To advance the selection one chord at a time to the left: Press Shift + ←.
To advance the selection one bar at a time to the right: Press Shift + Ctrl + → (Mac: Shift
+ Cmd + →).
To advance the selection one bar at a time to the left: Press Shift + Ctrl + ← (Mac: Shift
+ Cmd + ←).
To advance the selection to the beginning of the line: Press Shift + Home (Mac: Shift + Fn
+ ←).
To advance the selection to the end of the line: Press Shift + End (Mac: Shift + Fn + →).
To extend the selection to the beginning of the score: Press Shift + Ctrl + Home (Mac:
Shift + Cmd + Fn + ←).
To extend the selection to the end of the score: Press Shift + Ctrl + End (Mac: (Mac: Shift
+ Cmd + Fn + →).

2. Shift + Click selection (notes/rests only)

a) Make sure you are not in note entry mode
b) Click on the first note/rest in the range
c) Press and hold Shift
d) Click on the last desired note/rest.

The final selected element can be in the same staff or in staffs above or below the initial
note/rest. All selected elements will be enclosed in a blue rectangle, including associated lines
and articulations (but not voltas). You can repeat the operation to extend the selected range as
required.

Measure selection: You can also select a range of whole measures by clicking on a blank
space in the first desired measure, pressing shift, then clicking on a space in the last measure of
the range. As with selecting notes, the range can be vertical as well as horizontal.

3. Drag selection (all elements)

Press and hold Shift and drag the cursor across the desired range. This method can be used to
select notes/rests OR independently to select non-note symbols (e.g. staccato dots, lyrics etc.).

4. Select All (notes/rests and elements attached to notes/rests)

Press Ctrl+A (Mac: Cmd+A) to select every music staff in the score. Or use the menu, Edit →
Select All.

5. Select section

In order to select a section (a region of the score starting and/or ending with a section break),
click on an empty space in a measure in the section and select Edit → Select Section.

Note: See Copy and paste: Selection filter to disable certain types of elements from being selected in
a range selection.

List selection

To select multiple individual elements (as opposed to a continuous range):

1. Select (click on) the first element
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2. Press Ctrl (Mac: Cmd)
3. Select (click on) additional elements while holding the Ctrl (Mac: Cmd) key.

Select all similar

To select all elements of a specific type (e.g., all barlines, all text elements, all staccato markings):

1. Select an element
2. Right click → Select

3. Several options are available:

All Similar Elements: in the whole score
All Similar Elements in Same Staff: only in the same staff
All Similar Elements in Range Selection: only if a →range selection is active, selects
similar elements only inside that selection
More... : opens a dialog that lets you fine-tune more options.

Example: A flat (accidental) selected

You can choose from the following selections:

Same subtype: in this example only flats will be selected (not sharps nor naturals); some
elements have a subtype (e.g. articulations, accidentals ...)
Same staff: only elements in the same staff
Same voice: only elements in the same voice
Same system: only elements in the same system
Same selection: if a selection is active, only elements in that selection

Depending on what you had selected before you opened the Select → More... dialog, you may
wish to now instead have all of your specified type of elements selected (the default, "Replace");
keep everything you had selected before still selected, and simply add all of your chosen type of
element ("Add"); or keep everything you had selected before still selected, except without your
specified type of element ("Subtract").

What selections are useful for

Copy and paste
Edit mode
Inspector and object properties
Tools

See also

Basics chapter, esp. Note input
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Notation chapter, esp. Accidental
Text chapter, esp. Text editing and Grid-based movement of symbols and staff text

Do you have an unanswered question? Post it in the forum.

Undo and redo
MuseScore remembers an unlimited number of undo/redo actions.

The standard shortcuts are:

Undo Ctrl+Z (Mac: ⌘+Z)
Redo Ctrl+Shift+Z or Ctrl+Y (Mac: ⌘+Shift+Z)

Or use the toolbar buttons:

Do you have an unanswered question? Post it in the forum.

Viewing and navigation
Viewing options for the score can be found in the View Menu, and also in the Zoom and Page
View/Continuous view menus located in the toolbar above the score.

View menu

Show sidebars/panels

Start center: F4
Palettes: F9
Inspector: F8
Play Panel: F11
Navigator: F12
Mixer: F10
Synthesizer: F7
Selection filter: F6
Piano keyboard: P

Zoom in/out

Zoom In: Ctrl++ (Mac: Cmd ++)
Zoom Out: Ctrl +- (Mac: Cmd +-)

To set a specific zoom, use the dropdown menu in the standard toolbar to set the view magnification
of the score (25–1600 %) or display it using the options "Page Width", "Whole Page", and "Two
Pages" (scales related to the size of the window).

To return to 100% zoom use the shortcut Ctrl+0 (Mac: Cmd+0).

You can also zoom in and out by scrolling up or down while holding down the Ctrl (Mac: Cmd) key.
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Show Status bar

The Status bar, at the bottom of the screen, gives information about selected score elements.
Tick/untick this option to display or hide.

Split display

It is possible to split the document display so as to view two documents at once, or to view two
different parts of the same document. Tabs allow you to chose which document to display in each
view. You can drag the barrier separating the two scores to adjust the amount of space in the window
devoted to each:

Documents Side by Side: Divides the window vertically into two score views.

Documents Stacked: Divides the window horizontally into two score views, one above the
other.

57

https://musescore.org/sites/musescore.org/files/Documents side by side_3.png


Visibility options

This section allows you to display or hide various non-printing elements:

Show Invisible: View/hide elements that have been made invisible for printing.
Show Unprintable: View/hide breaks and spacer symbols.
Show Frames: View/hide the dotted outlines of frames.
Show Page Margins: View/hide Page Margins.

Full screen

Full Screen mode expands MuseScore to fill your screen so more content is visible.
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Page/Continuous View

In Page View, you can see your sheet music formatted as it will appear when printed or exported as a
PDF or image file. In Continuous View, the score will be shown as one unbreaking system.

Note that when switching between Page View and Continuous View, the score is reformatted for the
new view and manual adjustments may require reviewing.

You can switch viewing modes here:

Page View

In Page View, the score is shown as one or more pages of a specific size with margins, and you can
see all lines and page breaks, including those added manually and those automatically calculated by
the software. (Manual page breaks can be helpful to have well-placed page turns in orchestral parts,
for example.)

Continuous View

In Continuous View, the score will be shown as one unbreaking system. If the starting point is not in
view, then a substitute form of measure numbers, instrument names, clefs, time and key signatures
will be displayed.
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Before printing a score or uploading it to MuseScore.com, switch to Page View to check line/page
breaks.

Note: Because the layout is simpler, MuseScore may perform faster in Continuous View than Page
View.

Navigator

The Navigator is an optional panel which allows you to navigate a long score more easily, or go to
specific pages. To view/hide, go to the View menu and select Navigator, or use the shortcut F12 (Mac:
fn+F12). It appears at the bottom of the document window if scrolling pages horizontally, or on the
right-hand side of the document window if scrolling pages vertically (see Preferences: Canvas).

The blue box represents the area of the score that is currently visible in the main window. You can
drag either the blue box or the scroll bar, or click on an area to immediately go to it.

Toolbars

The Toolbar area is located between the Menu bar and document window. It contains symbols
which allow you to perform certain operations. It can be divided into the following toolbars:

File Operations: New score, Load score, Save, Print, Undo, Redo.
Zoom/Page View.
Transport tools: Enable MIDI, Rewind, Play/Stop, Loop, Play Repeats, Metronome.
Concert Pitch: Displays score in written or concert (sounding) pitch.
Image Capture: Allows you to take a snapshot of part of the score.
Note Input: Note entry mode, Duration, Tie, Rest, Accidentals, Flip stem direction, Voice (1, 2,
3, 4).

To chose which toolbars to display, right-click on an empty space in the toolbar area and, from the
menu, check or uncheck the required options. This menu also allows you to view or hide the Piano
keyboard, Selection sidebar, Text tools, Palettes, and the Inspector.

Side panels

The workspaces, Inspector and Selection filter are conveniently displayed as side panels to the
left and right of the score window. To undock a side panel use one of the following methods:

Drag the panel;
Click on the double chevron at the top of the panel;
Double click in the title area at the top of the panel.

To redock a panel use one of the following procedures:

Drag the panel to the top/bottom of an existing side panel and it will stack vertically above/below
that panel.
Drag the panel to the middle of an existing side panel and it will overlay that panel. Both panels
can then be accessed by tabs.

Alternatively, double-clicking the title bar of the panel will restore it to its previously docked position.
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Find

The Find function allows you to speedily navigate to a specific measure, rehearsal mark or page
number in the score:

1. Press Ctrl+F (Mac: Cmd+F), or select Edit → Find. This opens the Find (or Go to) bar at the
bottom of the workspace.

2. Use one of the following options:
To go to a measure, enter the measure number (counting every measure starting with 1,
irrespective of pickup measures, section breaks or manual changes to measure number
offsets).
To go to a rehearsal mark, enter its name (the first character must be a letter for it to be
"found", but subsequent text can be letters or numbers; the search is case insensitive).
To go to a page, enter the page number using the format pXX (where XX is the page
number; this also means that you won't find a rehearsal mark that starts with "P" and
continues with a number).

See also

Keyboard shortcuts, Navigation
Save/Export/Print
File format
Layout and formatting

Do you have an unanswered question? Post it in the forum.

Share scores online
Go to musescore.com/sheetmusic to view other scores from MuseScore.

You can save and share your scores online at MuseScore.com. You can choose to save a score
privately for personal access from any computer, or share it publicly. MuseScore.com enables the
viewing and playback of scores in your web browser - an additional feature entitled VideoScores allows
synchronization between the score and a YouTube video. For use outside of a web browser, you can
download the score in a variety of formats (including PDF, MIDI, MP3, MusicXML, and the original
MuseScore file).

Create an account

1. Visit MuseScore.com and click on "Create new account". Pick a username and enter a valid
email and press "Create New Account".

2. Wait a few minutes for an email from MuseScore.com support. If no email arrives, check your
spam folder.

3. Click the link in the email and visit your user profile to change your password.

Share a score directly from MuseScore

You can directly save a score online from File → Save Online....
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If you don't have a MuseScore account yet, create one first by clicking on the Create an account link.
That will open your browser app and bring you to https://musescore.com/user/register

Next, enter your email address or MuseScore username, and password. Upon successfully logging in,
you'll be able to enter your score information.
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1. The title is the title of the score.
2. The description will appear next to it.
3. Privacy can be set to Public (visible to everyone), or Private (only visible to you or those you

share a "secret link" with).
4. Choose a license. By using a Creative Commons license, you allow people to use your scores

under certain restrictions.
5. You can add tags to help identify scores on MuseScore.com. Use commas to separate multiple

tags.
6. In case you already saved the score online earlier, it will automatically update the existing one.

Uncheck Update the existing score to save online as a new score.

Upload a score on MuseScore.com

You can also upload a score directly on MuseScore.com.

1. Click the Upload link on MuseScore.com.
2. You have the same options as with the Save Online menu.
3. You have also access to more information, such as Genre.

Note: Should you reach the five score upload limit, you can still upload scores directly from
MuseScore, but only the last five are visible. If you wish more than this amount, upgrade to a Pro
Account first.
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Edit a score on MuseScore.com

If you want to make changes to one of your scores on MuseScore.com, edit the MuseScore file on
your own computer and follow the steps below.

1. Go to the score page on MuseScore.com.
2. Click the Edit this score link on the right.
3. In the form, you can upload a replacement score file as well as change the accompanying

information and privacy settings.

See also

How to delete a score saved on MuseScore.com

Do you have an unanswered question? Post it in the forum.

Notation
In the previous "Basics" chapter you learn how to enter notes and interact with the palettes. The
"Notation" chapter describes the different types of notation in more detail, including more advanced
music notation.

See also "Advanced topics"

Accidentals
The most common types of accidentals are provided in the Accidentals toolbar above the score and
in the Accidentals palette in the basic workspace. A more comprehensive range can be found in the
Accidentals palette in the advanced workspace.

Accidentals palette (Basic workspace)

Add accidental

Accidentals are automatically added to a note, as appropriate, when you increase or decrease its
pitch:

↑: Increase the pitch of a note by one semitone (favors sharps).
↓: Decrease the pitch of a note by one semitone (favors flats).

There are other methods of creating accidentals in the score, which also allow you to add a double flat
or double sharp, courtesy (also called cautionary or reminder) accidentals, or non-standard
accidentals:

Select a note and click on an accidental in the toolbar above the score.
Select a note and double-click an accidental in the Accidentals palette (basic or advanced
workspace).
Drag an accidental from the Accidentals palette on to a note.

If you wish to add parentheses to a cautionary accidental, use one of the following:

Select the accidental in the score and double-click the parentheses symbol in the Accidentals
palette.
Drag the parentheses symbol from the palette onto the accidental.

If you later change the pitch of a note with cursor keys, manual settings to the accidental are
removed.

If required, accidentals can be deleted by clicking on them and pressing Del.
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Change enharmonic spelling

To change the enharmonic spelling of a note or group of notes, select the note or notes and press J.
Repeatedly pressing J cycles through enharmonic equivalents. If the notes selected are not all the
same, the effect may be unpredictable.

To change the enharmonic spelling in the transposed view, without affecting the concert pitch view, or
vice versa, press Ctrl+J (Mac: Cmd+J).

Respell pitches

The menu function Notes → Respell Pitches tries to guess the right accidentals for the whole score.

See also

Key signature: Change

External links

Accidental at Wikipedia
Enharmonic at Wikipedia

Do you have an unanswered question? Post it in the forum.

Arpeggios and glissandi
Arpeggio and Glissando symbols can be found in the "Arpeggios & Glissandi" palette in the
advanced workspace. The default symbols also include strum arrows, and slides for string instruments
and brass etc.

You can customise the existing symbols on the score page and save them to a palette in a custom
workspace if required.

To add a symbol to the score, use one of the following methods:

Select one or more notes, then double-click a symbol in the "Arpeggios & Glissandi" palette.
Drag a symbol from the "Arpeggios & Glissandi" palette onto a note.

The Inspector allows you to make various adjustments to the appearance and playback properties of
the symbol.

Arpeggios

When an arpeggio or strum arrow is added to the score, it initially spans only one voice. However, you
can easily adjust its height by double-clicking the symbol and dragging the handles up or down (for
finer adjustment use the keyboard arrows). Playback can be turned on or off in the Inspector.
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Glissandi (slides)

A Glissando or, more informally, a slide, spans two consecutive notes on the same staff, normally in
the same voice.

You can edit, or delete the text of a glissando by clicking on it and making changes in the Inspector. If
there isn't enough room between two notes, the text is not displayed. The Inspector also allows you to
choose between a straight or wavy line, and to adjust the playback property of the symbol or turn it off
altogether.

To adjust the start and end points of a glissando:

1. Double-click the symbol to enter edit mode.
2. Click on the start or end handle and use Shift + ↑ ↓ to move the handle up or down, from note

to note. Shift + ← → moves the handle horizontally, note-by-note.

This method also allows you to move end handles between notes in different voices or even from one
staff to another—for cross-staff glissandi, for example. You can also use the keyboard arrow buttons
or Ctrl + arrow to make final adjustments to the positions of the handles.

Slides for stringed instruments, such as the guitar, can be created by editing the default glissando
line. You can create slides between single notes or chords: the placement of the slide ends can easily
be corrected using the method described above.

Other slides

Short up/down slides can be created by editing the existing slide in / slide out lines. These have
handles which allow you to set the length and angle of the slide.

External links

Arpeggio on Wikipedia
Glissando on Wikipedia

Do you have an unanswered question? Post it in the forum.

Articulations and ornaments
A comprehensive set of symbols can be found in the Articulations and Ornaments palette in the
Advanced workspace. There is also an abbreviated version in the Basic workspace.

Articulations
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Articulations are the symbols added to the score to show how a note or chord is to be played. The
principal symbols in this group are:

Fermatas
Staccato
Mezzo-staccato / Portato
Staccatissimo
Tenuto
Sforzato
Marcato

Specialist articulations are also included for bowed and plucked strings, wind instruments etc.

Ornaments

Ornaments include:

Mordents, Inverted Mordents, Pralltrillers
Trills
Turns
Bends

Note: Appoggiaturas and acciaccaturas can be found in the Grace Notes palette.

Add articulation/ornament

1. Select a note or a range of notes.
2. Double-click on a symbol in the palette.

Alternatively, you can add a symbol by dragging it from the palette directly onto a notehead.

Add accidental to an articulation

To apply an accidental to an existing articulation, such as a trill, add it from the Special Characters
window to a text object. Or, alternatively, apply an accidental to the note from the Master palette.

Add fermata to a barline

A fermata can be applied directly to a barline by selecting the barline and double-clicking the fermata
from a palette.

Keyboard shortcuts

Toggle Staccato: Shift+S
Toggle Tenuto: Shift+N
Toggle Sforzato (accent): Shift+V
Toggle Marcato: Shift+O
Add Acciaccatura (grace note): /

Keyboard shortcuts can be customized in MuseScore's Preferences.

Adjust position

Immediately after adding an articulation or ornament from a palette, the symbol is automatically
selected: It can then be moved up or down from the keyboard as follows:

Press up/down arrow keys for fine positioning (0.1 sp at a time);
Press Ctrl+↑ or Ctrl+↓ (Mac: Cmd+↑ or Cmd+↓) for larger vertical adjustments (1 sp at a time).
To flip a symbol to the other side of the note (where applicable), select it and press X.

To enable adjustments in all directions from the keyboard:

1. Double click on the symbol to enter Edit mode, or click on it and press Ctrl+E (Mac: Cmd+E) , or
right-click on the symbol and select "Edit element";

2. Press arrow keys for fine positioning (0.1 sp at a time); or press Ctrl+Arrow (Mac: Cmd+Arrow) for
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larger adjustments (1 sp at a time).

You can also change the horizontal and vertical offset values in the Inspector. To position more than
one symbol at a time, select the desired symbols and adjust the offset values in the Inspector.

Note: The symbol can also be repositioned by clicking and dragging, but for more precise control, use
the methods above.

Articulation properties

To access articulation properties, click on the symbol and make the desired adjustments to values in
the Inspector. The exact properties displayed depend on the type of articulation. Other properties (i.e.
direction and anchor position) can be accessed by right-clicking on the symbol and selecting
Articulation Properties….

You can also make global adjustments to all existing and subsequently-applied articulations by
selecting Style… → General… → Articulations, Ornaments.

See also

Grace notes

External links

Ornaments at Wikipedia

Bends

A variety of simple and complex (multi-stage) bends can be created with the Bend Tool , located
in the Articulations and Ornaments palette of the Advanced workspace.

Apply a bend

To apply a bend symbol, use one of the following options:

Select a note and double-click the bend tool in the palette.
Drag the bend tool from the palette on to a note.

By default, the tool applies a whole note up-bend. To edit the bend, right click on it and select "Bend
properties." Five preset options are available, if needed, to the left of the graph.

As you can see from the image (above), the bend is represented by a graph. The dark blue squares
are control points, connected by gray lines. The slope of the graph indicates the type of bend:

Up-slope = Up-bend
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Down-slope = Down-bend
Horizontal line = Hold

The vertical axis of the graph represents the degree to which the pitch is bent up or down: one unit
equals a quarter-tone: 2 units a semitone, 4 units a whole-tone, and so on.

The horizontal axis indicates the visual extent of the bend: each gray line segment in the graph
equals width of 1 sp in the score (sp = staff space, the distance between two staff lines). Thus, each
blue square added lengthens the bend by 1 sp; deleting a blue square shortens the bend by 1 sp.

A bend is modified by adding or deleting blue squares in the graph. To add a square to the graph,
click on an empty intersection. To delete a square, click on it. The Start and End points of the bend
can be moved up and down only.

Adjust height

The height of the bend symbol is automatically adjusted so that it appears just above the staff. This
height can be reduced, if necessary, with a workaround:

1. Create another note on the top line (or space) of the staff, vertically above the note at which you
want the bend to start.

2. Apply the bend to the higher note first: this will give you a bend symbol with the lowest height.
3. To increase the height of the bend move this note downward.
4. Drag the bend symbol downwards to the correct position.
5. Mark the top note invisible and silent (using the Inspector).

Adjust position

To adjust position use one of the following:

Drag the bend symbol with a mouse.
Click on the symbol and adjust the horizontal and vertical offsets in the Inspector.
Double click on the symbol; or click on it and press Ctrl+E (Mac: Cmd+E); or right-click on the
symbol and select "Edit element." Then use the arrow keys for fine positioning (0.1 sp at a time);
or Ctrl+Arrow (Mac: Cmd+Arrow) for larger adjustments (1 sp at a time).

Custom bends

After a bend has been created in the score it can be saved for future use by dragging and dropping
the symbol to a palette while holding down Ctrl+Shift (Mac: Cmd+Shift). See Custom palette.

Do you have an unanswered question? Post it in the forum.

Barlines
Barline symbols are available in the Barlines palette:

Change barline type

To change an existing barline, use one of the following:

Select a barline, then double click on a symbol in the Barlines palette.
Drag a symbol from the Barlines palette onto a barline in the score.
Drag a symbol from the Barlines palette onto a measure.
Select a measure, then double-click on a symbol in the Barlines palette.

To insert a new barline between existing ones, either:
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Drag a symbol from the Barlines palette onto a note or rest.
Select a note or rest, then double-click a symbol in the Barlines palette.

Barlines can also be changed in the Inspector. Other options available here include:

Dashed or dotted barlines
End, double, repeat and adjustable partial barlines,
Span staves
Color
Offset

To hide a barline entirely, select the line and press V, or uncheck Visible in the Inspector.

Connect barlines

To extend barlines over multiple staves, like in a grand staff, e.g. for piano, double-click on a barline
(see Edit mode).

Click and drag the blue handle down to the next staff.

All the rest of the barlines will update when you leave edit mode.

See also

Measure operations
Add articulation/ornament to barline

Do you have an unanswered question? Post it in the forum.

Beams
Beams are set automatically based on the time signature (see Time signatures: Change default
beaming), but they can be altered manually on a case-by-case basis. Drag a beam symbol from the
"Beam Properties" palette to a note in order to change its behavior.

Alternatively, you can first select a note (or rest), and then double-click the appropriate symbol in the
palette.

 Start a beam at this note.
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 Do not end a beam at this note (or rest).

 Do not beam this note.

 Start a second level beam at this note.

 Start a third level beam at this note.

 (back to) Automatic mode: the mode MuseScore chooses on note input, dependent on
current time signature.

 Start feathered beam (slower) at this note.

 Start feathered beam (faster) at this note.

To change the beam angle, or the distance of the beam to the notes (i.e. the length of the stems),
double-click on the beam to put it into edit mode, with the right end handle being selected. Up/down
arrow will now change the angle. Selecting the left end handle and using the up/down arrow keys will
lengthen/shorten the stems. Hit Esc to get out of edit mode, once done with the changes.

To move a beam from above to below the notes, or vice-versa, flip the direction of the stems by using
the button along the second top row (before the voice indicators) that shows a note with stems
attached above and below or use the X key.

See also

Cross-staff notation
Edit mode
Note input
How to add a beam over a rest
How to place a beam between notes

Do you have an unanswered question? Post it in the forum.

Brackets
MuseScore provides standard brackets and a curly brace within the Brackets palette in the
advanced workspace.

Add

To add a bracket or brace to systems, use one of two methods:

Drag a bracket symbol from a palette on to an empty space in the first measure of the staff
where you want the bracket to start.
Select the first measure of the staff where you want the bracket to start and double-click a
bracket symbol in a palette.

Delete
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Select the bracket and press Del.

Change

Drag a bracket symbol from a palette onto an existing bracket in the score.

Edit

When you first apply a bracket it only spans one staff. To extend the bracket to other staves, double-
click on it (or click on it and press Ctrl + E) to enter edit mode, then drag the handle downwards to
span the required staves. The handle snaps into position, so exact placement is not required.

Style

The default thickness and distance from the system of brackets and braces can be adjusted in Style →
General... → System.

Do you have an unanswered question? Post it in the forum.

Breaths and pauses
Breath and pause markings are available in the Breaths & Pauses palette in the advanced
workspace.

To add a breath or pause (the latter also called a caesura, or informally "tram lines" or "railroad
tracks") to the score, use one of the following options:

Select a note or rest and double-click a breath or pause symbol in a palette
Drag a breath or pause symbol from a palette onto a note or rest in the score.

Breath symbol in score (Emmentaler font)

The symbol is placed after the note. You may subsequently wish to adjust its position by entering edit
mode and using the arrow cursor keys, by dragging, or by changing the offsets in the Inspector.

Do you have an unanswered question? Post it in the forum.

Clefs
Commonly used Clefs (Treble, Bass, Alto, Tenor) can be found in the Clefs palette in the Basic
workspace. For a more complete range, see the Clefs palette in the Advanced workspace (see image
below).
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Note: You can tailor the display of clefs to your specific requirements using a custom palette.

Add a clef

Add clef to beginning of measure

Method 1—add clef to beginning of a measure, whether or not it is the first measure in a system

Select a measure and double-click a clef symbol in the palette, OR
Drag a clef from the palette onto a measure.

Method 2—only for changing the clef at the start of a system

Select the existing clef at the beginning of the system and double-click a new clef from the
palette, OR
Drag a new clef from the palette directly onto the existing clef.

Add mid-measure clef

To create a mid-measure clef:

Click on a note and then double-click a clef in the palette.

Note: If the clef is not the first in the system, it will be drawn smaller.

In this image, the top staff starts with a treble clef and switches immediately to bass clef, then after a
note and a rest, changes back to treble clef.

Note: Changing a clef does not change the pitch of any note. Instead, the notes move to preserve
pitch. If you want, you can use Transposition in conjunction with a clef change.

Courtesy clefs

When a clef change occurs at the beginning of a system, a courtesy clef will be generated at the end
of the previous system. To show or hide courtesy clefs, go to Style → General... → Page and
check/uncheck the "Create courtesy clef" option.

Remove a clef

Select a clef and press Del.
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Hide clefs

Display clef only in the first measure (for all staves)

Go to Style → General... → Page and uncheck "Create clef for all systems."

Display clef only in the first measure (for a particular staff)

1. Right click on the staff, select Staff properties... and uncheck "Show clef."
2. Open the Master Palette and select the "Symbols" section.
3. Drag and drop a clef from the master palette onto the first measure of the staff, OR select the

first note and double-click a clef in the master palette

Note: This option may be useful to TAB users who do not want the clef to repeat on every subsequent
line.

Hide all clefs in a particular staff

Right click on the staff, select Staff properties... and uncheck "Show clef."

Do you have an unanswered question? Post it in the forum.

Drum notation
Music notation for unpitched percussion differs significantly from notation for pitched instruments (such
as the piano or violin), but you should be familiar with standard note input before proceeding.

On a 5-line percussion staff, each instrument is assigned a particular staff position (line or space) and
a notehead shape. When writing for a drumkit it is common to use two voices: voice 1 (the upper
voice) usually contains (upstem) notes played by the hands while voice 2 (the lower voice) usually
contains (downstem) notes played by the feet (see image below).

Drum input palette

When a percussion staff is selected and note input mode is ON, a window opens at the bottom of the
screen called the Drum input palette. Each note in the palette represents a percussion instrument:
hovering the mouse pointer over the note displays the instrument name.

The letters A–G (shown above certain notes in the palette) are designated as shortcuts for entering
particular instruments (bass drum, snare, closed hi-hat etc.), rather than referring to note pitches.
They can be changed or reallocated as desired in the Edit Drumset window.

When the Drum input palette is open, double-clicking a note in the palette or entering a shortcut
letter will add that instrument note to the percussion staff. The color of the note in the palette shows
the voice allocated for that note—blue for voice 1, green for voice 2. This can be changed in the Edit
Drumset dialog if required.

This voice allocation only applies only to keyboard and mouse entry of notes: entry via a MIDI
keyboard or the virtual Piano keyboard allows any voice to be used.

Note input methods

You can add notes to a percussion staff from any of the following:
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External MIDI keyboard;
Piano keyboard (virtual);
Computer keyboard;
Mouse.

These methods can be used in any desired combination:

MIDI keyboard

The easiest way to add notes to a percussion staff is via a MIDI keyboard connected to your
computer. If you click on the percussion staff without entering note input node, you are free to demo
the percussion instruments beforehand.

To enter notes from the MIDI keyboard:

1. Click on the note or rest where you want to start.
2. Enter note input mode.
3. Select the correct voice. For example, snares, sidesticks and all cymbals are normally added to

voice 1; bass drum to voice 2.
4. Set note duration.
5. Press the MIDI key for that instrument to add a note to the score. To add another note, keep the

first key held down while pressing the second key.

Note: Refer to a GM2 drum map for details about the allocation of keys to percussion instruments.
Some MIDI keyboards (e.g., Casio) display percussion symbols next to the keys as an aid to the user.

Piano keyboard

To display the virtual Piano keyboard, press P (or select it from View → Piano Keyboard). If you click
on the percussion staff without entering note input node, you are free to demo the percussion
instruments beforehand.

To add notes to a percussion staff from the virtual Piano keyboard:

1. Ensure that the Piano keyboard is displayed.
2. Click on the note or rest where you want to start.
3. Enter note input mode.
4. Select the correct voice. For example, snares, sidesticks and all cymbals are normally added to

voice 1; bass drum to voice 2.
5. Set note duration.
6. Click on the MIDI key for that instrument to add a note to the score.
7. If you wish to add another note to an existing one, press Ctrl and hold it while pressing the new

note.

Note: Refer to a GM2 drum map for details about the allocation of keys to percussion instruments.

Computer keyboard

To enter notes on a percussion staff using your computer keyboard:

1. Click on the note or rest where you want to start.
2. Enter note input mode. The Drum input palette now appears at the bottom of the screen.
3. Select the desired note duration.
4. Press the shortcut key (A–G) for the instrument note you wish to enter.
5. If you wish to add another note to an existing one in that voice, press Shift + [A–G].

Note: Voice allocation is determined by the color of the note in the drum input palette: blue for voice 1,
green for voice 2.

Mouse

To add a note to a percussion staff

1. Click on the note or rest where you want to start.
2. Press N to to enter note input mode. The Drum input palette now appears at the bottom of the

screen.
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3. Set note duration.
4. Chose one of the following options:

Double-click a note in the Drum input palette.
Select a note (e.g. Bass drum, or Snare) in the Drum input palette, then click on the
percussion staff to add the note to the score.

To add a note to an existing chord in the percussion staff

1. Ensure you are in note input mode mode.
2. Select a note duration equal to the note you are adding to.
3. Click on the new note in the Drum input palette.
4. Click above or below the existing note in the percussion staff.

Note: Voice allocation is determined by the color of the note in the drum input palette: blue for voice 1,
green for voice 2.

Edit Drumset

Clicking on Edit Drumset at the left of the Drum input palette, opens the Edit Drumset dialog.
Alternatively, right click on a percussion staff and chose "Edit Drumset." The left-hand side of the
window consists of a list of MIDI numbers/note names, their associated percussion instruments and
any keyboard shortcuts.

Clicking on a row in the left-hand column allows you to edit the display properties for that note as
follows:

Name: The name you want displayed in the Drum input palette when you mouse over the note.
Notehead: Chose a notehead for that instrument from a drop-down list of options.
Staff line: This number indicates the staff line/space on which the note is displayed. "0" means that
the note is displayed on the top line of the 5-line staff. Negative numbers move the note upwards step
by step, while positive numbers move it downwards in the same way.
Stem Direction: Auto, Up or down.
Default voice: Assign to one of four voices. This does not affect input from a MIDI keyboard or the
virtual Piano keyboard.
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Shortcut: Assign a keyboard shortcut to enter that note.

The customised drumset can be saved as a .drm file by pressing Save. You can also import a
customised drumset using the Load button.

Roll

To create a drum roll, use Tremolo.

External links

How to create jazz drum notation [MuseScore How-To]
Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation
Drum Parts [video]
Editing the Drum Palette in MuseScore 1.1 [video]
Saving Drumset Changes in MuseScore 1.1 [video]
Guide to Drum and Percussion Notation

Do you have an unanswered question? Post it in the forum.

Grace notes
A grace note is a type of musical ornament, usually printed smaller than regular notes. The Short
grace note, or Acciaccatura, appears as a small note with a stroke through the stem. The Long grace
note, or Appoggiatura, has no stroke.

Create grace notes

Grace notes can be found in the "Grace notes" palette in the Basic or Advanced workspace.

Add a grace note

Select a regular note and double click a grace note in a palette, OR
Drag a grace note symbol from a palette onto a regular note, OR
Select a note and press / to create an acciaccatura only.

To add a group of grace note to a regular note, simply repeat the above actions as many times as
required.

Add a chord of grace notes

Grace note chords are built up just like regular chords:

1. Enter the first note of the chord as shown above
2. Select this first grace note and enter subsequent notes as you would for any other regular chord

(i.e. Shift+ note names (C, D, E etc...)).

You can also create a grace note chord by using the add interval shortcut in step 2: Alt+1-9 for
intervals from a unison to a ninth above.

Change duration

If you want to change the duration of a previously created grace note, select it and choose a duration
from the toolbar or enter with one of the keys 1 ... 9 (see Note input).

Manual adjustment

The position of a grace note after a note (such as a trill termination) may have to be adjusted by
selecting the note, going into edit mode and using the left/right keyboard arrows; or change the chord
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offset values in the Inspector.

External links

Grace note at Wikipedia
Appoggiatura at Wikipedia
Acciaccatura at Wikipedia

Do you have an unanswered question? Post it in the forum.

Hairpins

Add a hairpin

Hairpins are line objects. To create a hairpin, select the range of notes that you want the hairpin to
cover.

< creates a crescendo hairpin
> creates a diminuendo hairpin (decrescendo)

You can also create hairpins by double-clicking a hairpin in the Lines palette while notes are selected.

Edit a hairpin

Once you have a hairpin in your score, you can adjust, extend, or move it. To adjust length:

1. Double-click on the hairpin to enter edit mode. Then select (click on) the end point to move:

2. Shift+→ or Shift+← moves the anchor of the selected end point, which determines which notes
the playback will affect and enables the hairpin to extend across line breaks:

3. → or ←, Ctrl+→ or Ctrl+← (Mac: Cmd+→ or Cmd+←), and dragging with the mouse will move the
selected end point without changing where it is anchored. This method is suitable only for
small adjustments to the visual appearance of the hairpin. To extend the hairpin under more
or fewer notes, use Shift+→ or Shift+← to change the anchor (see above). The "Reset"
command Ctrl+R (Mac: Cmd+R) will undo these small adjustments, but will not undo anchor
changes.

Cresc. and dim. lines
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In addition to hairpins, there are cresc.   _     _     _ and dim.   _     _     _ lines with the same function in
the Lines palette. To change the text (e.g. to cresc. poco a poco, or decresc. instead of dim), right-click
on the line and choose Line Properties....

To turn a hairpin into its equivalent text line:

1. Select the hairpin.
2. In the Inspector, set "Line style" to "Wide dashed."
3. In the Inspector, select the "Text line" checkbox.

Hairpin playback

Playback of crescendos and diminuendos is only effective from one note to the next; it currently is not
possible to change the dynamic over the course of a single note. By default, hairpins will affect
playback only if dynamics are used before and after the hairpin.

For instance, a crescendo spanning notes between p and f dynamics will cause a dynamic change on
playback. However, between any two successive dynamics only the first appropriate hairpin will have
effect: a diminuendo between p and f will be ignored; of two or more crescendos between p and f, all
but the first will be ignored.

A hairpin may be used without dynamic marks, by adjusting "Velocity change" in the Inspector (values
in the range 0 to 127).

Do you have an unanswered question? Post it in the forum.

Key signatures
Standard key signatures are available in the Key Signatures palette in the Basic or Advanced
workspaces. You can also create custom key signatures using the Key signatures section of the
Master Palette (press Shift+K to view), which also allows you to use a wide range of non-standard
symbols.

Add a new key signature

Add new key signature to all staves

Drag a key signature from the palette onto an empty part of a measure, OR
Select a measure and double-click a key signature in the palette, OR
Select a note and double-click a key signature in a palette.

Add new key signature to one staff only

If you wish to change the key signature of only one staff line, leaving others unchanged:

Press Ctrl (Mac: ⌘) and hold while you drag a key signature from a palette onto a measure.

Replace an existing key signature

79

https://musescore.org/en/handbook/inspector-and-object-properties#inspector
https://musescore.org/en/handbook/dynamics
https://musescore.org/en/handbook/inspector-and-object-properties
https://musescore.org/en/forum
https://musescore.org/en/handbook/palette
https://musescore.org/en/handbook/key-signatures-0#custom-key-signatures


Replace key signature for all staves

Drag a key signature from the palette onto the key signature to be replaced (or onto the measure
containing the key signature), OR
Select the key signature to be replaced, and double-click a new key signature in a palette.

Replace key signature for one staff only

If you wish to replace the key signature of only one staff, leaving others unchanged:

Press Ctrl (Mac: ⌘) and hold while you drag a key signature from a palette onto the key
signature to be replaced (or onto the measure containing the key signature).

Remove a key signature

Click on an existing key signature and press Del, OR
Drag the empty key signature from the palette (in the advanced workspace) onto the measure.

Courtesy key signature

In the Inspector for a selected key signature, there is an option for "Show courtesy." Additionally, Style
→ General... → Page has on option for "Create courtesy key signatures". The Inspector will affect only
the selected one; the style setting will affect the entire score.

Naturals on key signature changes

By default MuseScore only shows naturals when changing to no signature (C Maj/A min). In all other
cases, it simply shows the new key signature:

You can choose whether to show natural(s) in certain cases when changing the key signature. Under
Style → General... → Accidentals you'll see the options:

You can Apply the changes, or click OK. If you are in a linked part, rather than in the primary score, you
can use the Apply to all parts button.

The option 'Before key signature if changing to fewer ♯ or ♭' yields this result:

The third option 'After key signature if changing to fewer ♯ or ♭. Before if changing between ♯ and
♭' produces the following output:

Key signature and multimeasure rest

Multimeasure rests are interrupted, if there is change in the key signature.
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See Multimeasure rest

Courtesy key signatures and section breaks

A courtesy key signature will not be shown at a section break.
See Break or spacer: Section break

Custom key signatures

Press Shift+K to bring up the Key signatures section of the Master palette.

The left panel contains a library of key signatures. To the right is the Create Key signature panel
where you can customize key signatures by dragging accidentals from the palette onto an appropriate
location in the staff above. When completed, press Add to move the new key signature into the library.
Clear cancels the custom key signature and allows you to start building again from scratch.

A full range of accidental symbols is available—both conventional and non-standard (such as half-
flats, half-sharps, etc.). Note, however, that playback of custom key signatures is not currently
supported (2.0.3).

Key signatures in the Master palette can be moved to a custom palette in a user workspace by
dragging and dropping. It is also possible to apply key signatures to the score directly from the Master
palette by either selecting a measure and double-clicking a key signature, or dragging the key
signature onto a measure.

Do you have an unanswered question? Post it in the forum.

Lines
The Lines palette of the Advanced workspace includes the following types of lines:

Slur

81

https://musescore.org/sites/musescore.org/files/Multimeasure_rest_key_and_time_signature.png
https://musescore.org/en/handbook/measure-rests
https://musescore.org/en/handbook/breaks-and-spacers#section-break
https://musescore.org/en/handbook/master-palette
https://musescore.org/sites/musescore.org/files/Master_palette-Key_sig_en.png
https://musescore.org/en/handbook/custom-palettes
https://musescore.org/en/forum


Hairpins (crescendo and diminuendo)
Volta brackets (1st, 2nd, 3rd time endings etc.)
Octave lines (8va, 8vb, 15ma etc)
Keyboard pedal markings
Extended ornament lines (Trills etc)
Guitar barre line
Straight line
Ambitus (early music symbol)

Applying lines to the score

Lines can be applied in the following ways:

Select a note and then double click one of the lines.

Select a range of notes by clicking on the first note and using Shift-click to select the last note.
Then double-click a line in the palette.

Select a range of notes by clicking on the first note and using Ctrl-click to select the last note.
Then double-click a line in the palette. This gives a shorter line than the previous selection.

Drag and drop a line from the palette onto the score.

Slurs can also be created using the hotkey S.

Change length

1. If you are in note input mode then press Esc

2. Double click the line that you want to change to enter edit mode

3. Move the handles using the following shortcuts:

Shift+→ to move the anchor right by one note (or measure)
Shift+← to move the anchor left by one note (or measure)

4. If you need to change the length visually without changing the notes or measures that the
line is anchored to, then drag the handles with the mouse or use the following shortcuts:
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→ to move the handle right by 0.1 sp (1 sp = one staff space = the distance between two
staff lines).
← to move the handle left 0.1 sp.
Ctrl+→ (Mac: Cmd+→) to move the handle right one sp.
Ctrl+← (Mac: Cmd+→) to move the handle left one sp.

Custom lines and line properties

Lines like ottavas (8va, 8vb, 15ma, etc.) and voltas (1st and 2nd endings, etc.) make use of features
such as embedded text or hooks at the ends of the line. You can also customize lines as you like after
adding them to the score, and even add them back into the palette for future use.

1. Right-click on a line and choose Line Properties...

2. You can specify text to appear at the beginning, continuation (i.e., the beginning of subsequent
systems), and/or end of the line. Click the ... button to control the formatting and positioning of
each text type within the line.

3. The Hook setting lets you create perpendicular or 45º angles at the ends of the line.

4. Exiting the Line Properties dialog, you can set the thickness of the line in the Inspector, where
you can also choose the Line style (e.g., continuous, dashed, dotted).

5. To save your result back into the palettes, see Custom palette.

See also Line properties.

Copying lines

Once applied to the score, lines cannot be copied using the usual copy and paste procedures.
However, you can duplicate lines within a score: press Ctrl+Shift (Mac: Cmd+Shift), click on the line
and drag it to the desired location.

Extended ornament lines

To add an accidental to an extended ornament, such as a trill line, select the line and double-click a
symbol from the Accidentals palette.

External links

Piano pedal marks at Wikipedia.
Guitar Barre at Wikipedia.

Do you have an unanswered question? Post it in the forum.

Measure rests

Full measure rest

When an entire measure is devoid of notes, a full measure (full bar) rest is used. A full measure rest
looks like a whole note (semi-breve) rest, except it is centered in the middle of a measure, and instead
of always being equal to four quarter beats it represents whatever the length of the measure is in the
current time signature.

To create a full measure rest, select a measure and press Del. All notes and rests in this measure are
then replaced by a full measure rest.
Note: To create a full measure rest for measures with custom durations select a measure and press
Ctrl+Shift+Del.

Multimeasure rest
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Multimeasure (multi-bar) rests indicate a long duration of silence for an instrument and are frequently
used in ensemble sheet music. They are automatically interrupted at important points, such as double
barlines, rehearsal marks, key- or time signatures, etc.

The number above the multimeasure rest indicates the number of measures that the rest lasts for.

Instructions

Press M on your keyboard to turn multimeasure rests on or off.

Alternatively:

1. From the menu, choose Style → General...
2. Click on the "Score" tab, if it is not already selected
3. Add a check mark next to "Create multimeasure rests"

Limitations

The style option automatically combines empty measures into multimeasure rests throughout the
score. Therefore, it is recommended that you enter all your notes first and then turn on multimeasure
rests afterward.

Break multimeasure rest

See also: Measure operations: Break multimeasure rest

You may want to have a multimeasure rest divided into two multimeasure rests.

This option should be checked before turning on the "Create multimeasure rests" option in Style →
General..., in the "Score" tab.
Select the first measure where you want the second multimeasure rest to start, and do a right-click
Measure Properties → Break multimeasure rest.

Note that multimeasure rests are interrupted if there is a rehearsal mark (not a simple text), section
break, key or time signature change, or double barline.

Do you have an unanswered question? Post it in the forum.

Octave lines
Octave (Ottava) lines are used to indicate that a section of music is to be played one or more
octaves above or below written pitch: The line may be dotted or solid. Ottavas are available in the
Lines palette of the Basic and Advanced workspaces.

8─────┐or 8va─────┐: Play one octave above written pitch (Treble clef only)

8─────┘or 8vb─────┘: Play one octave below written pitch (Bass clef only)

8va/8vb lines are particularly common in piano scores, though they are sometimes used in other
instrumental music.1 15ma (2 octaves above) and 15mb (2 octaves below) are also occasionally
used.
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(Debussy. Études, Book II, X)

Apply an octave line

Use one of the following:

Select a range of notes, then double click an octave line from a palette.
Select one or more measures, then double click an octave line from a palette.
Click on a note, then double-click an octave line from the palette (extends line from selected note
to end of bar).
Drag an octave line from a palette onto a note (extends line from selected note to end of bar).

Change length

To extend or reduce the octave line (while maintaining correct playback):

1. If you are in note input mode then press Esc

2. Double click the line that you want to change to enter edit mode

3. Move the handles using the following shortcuts:

Shift+→ to move the anchor right by one note (or measure)
Shift+← to move the anchor left by one note (or measure)

To make adjustments in length without changing playback properties, drag the handles with the
mouse or use the following shortcuts:

→ to move the handle right by 0.1 sp (1 sp = one staff space = the distance between two staff
lines).
← to move the handle left 0.1 sp.
Ctrl+→ (Mac: Cmd+→) to move the handle right one sp.
Ctrl+← (Mac: Cmd+→) to move the handle left one sp.

Custom lines

You can customize an octave line, including text if required, by editing it on the score page: Right-click
on the line then chose Line Properties.... Save the result by dragging and dropping to a palette in
your custom workspace while holding down Ctrl+Shift (Mac: Cmd+Shift).

External links

Octave at Wikipedia

1. Gerou/Lusk. Essential Dictionary of Music Notation (Internet Archive). ↩

Do you have an unanswered question? Post it in the forum.

Repeats and jumps
The start and end of simple repeats can be defined by setting appropriate barlines. For instructions on
first and second ending measures, see Volta.
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Playback

To hear repeats during playback, make sure the "Play Repeats"  button on the toolbar is
selected. Likewise, you can turn off repeats during playback by deselecting the button.

In the last measure of a repeat, you can set the property "Repeat count" to define the number of
played repeats.

Repeat symbols and text

Text and symbols related to repeats are located in the Repeats palette. This palette contains symbols
for measure repeat, segno and coda. It also contains 'D.S.', 'D.C.', 'To Coda', and Fine text:

To add a repeat symbol to the score use either of the following:

Drag the repeat symbol from the palette onto (not above) the desired measure (so the measure
changes color), then drop
Select a measure, then double-click the desired repeat symbol in the palette.

The object will appear above that measure in your score.

Jumps

Jumps generally consist of three parts:

Jump to tag
Play up to tag
Continue at tag

Tags are names you give to certain measure positions. Two tags ("start", "end") denote the start and
end of the score and don't need to get added explicitly. Tags you add explicitly are called markers.
Jumps transfer playback to markers.

Markers

Markers are the places refered to by the jumps, in addition to the implict 'start' and 'end' there are:

Segno (tag: segno)
Segno Variation (tag: varsegno)
Coda (tag: codab)
Coda Variation (tag: varcoda)
Fine (tag: fine)
To Coda (tag: coda)

Examples

At the jump instruction Da Capo the playback jumps to the start (to the implicit start tag) and plays the
entire score again (up to the implicit end tag).

At the jump instruction Da Capo al Fine the playback jumps to the start (to the implicit start tag) and
plays the score up to the Fine (the fine tag).
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Dal Segno al Fine (or D.S. al Fine) jumps to the Segno symbol (the segno tag) and then plays up to
the Fine (the fine tag)

Dal Segno al Coda (or D.S. al Coda) jumps to the Segno symbol (the segno tag) and then plays up to
the To Coda (the coda tag). Playback then continues at Coda symbol (the codab tag).

The properties (i.e. the tag names) of jumps can be set via a right-click on the element or via the
Inspector. Marker tags can only be modified using the Inspector. You need to modify them if using
multiple jumps and markers.

See also

Volta

External links

MuseScore in Minutes: Repeats and Endings, part 2 (video tutorial)
How to separate a coda from the rest of the score (MuseScore HowTo)

Do you have an unanswered question? Post it in the forum.

Slurs
A slur is a curved line between two or more notes that indicates they are to be played without
separation. If you mean to join two notes of the same pitch, see Ties.

A slur can be created from the lines palette, but the methods below are recommended.

First method

1. Make sure you are not in note input mode and select the first note that you want the slur to
cover:

2. S creates a slur:

3. Shift+Right extends the slur to the next note:

4. X flips the slur direction:

5. Esc ends edit mode:

Second method

1. Make sure you are not in note input mode
2. Select the note where you want the slur to start
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3. Hold down Ctrl (⌘ on a Mac) and select the last note that you want the slur to cover
4. Press S

Note: If you Shift-select the last note, slurs will be added to all voices in the range after step 4.

Third method

1. While in note input mode, type in the first note in the slurred section
2. Hit S to begin the slurred section
3. Type in the remaining notes in the slurred section
4. Hit S to end the slurred section

Adjustments

To adjust the size and shape of a slur, double-click it to enter edit mode (or use Ctrl+E, or right-click
and select "Edit Element"). The two outer handles adjust the start and end of the slur, whilst the three
handles on the curve adjust the contour. The middle handle on the straight line is used to move the
whole slur up/down/left/right. The Tab key can be used to move from handle to handle.

For fine adjustments, click on any of the handles (displayed in the images for steps 2-4 above) and
move them with the keyboard arrow keys. Larger adjustments can be made by dragging the handles
with a mouse or other input device (or use Ctrl+Arrow).

The following shortcuts can be used to move the left and right handles from note to note:

Shift+→ Move to next note.
Shift+← Move to previous note.
Shift+↑ Move to lower voice (voice 2 to voice 1 etc.).
Shift+↓ Move to higher voice (voice 1 to voice 2 etc.).

A slur can span several systems and pages. The start and end of a slur is anchored to a note/chord or
rest. If the notes are repositioned due to changes in the layout, stretch or style, the slur also moves
and adjusts in size.

This example shows a slur spanning from the bass to the treble clef. Using the mouse, select the first
note of the slur, hold down Ctrl (Mac: ⌘) and select the last note for the slur, and press S to add the
slur.

X flips the direction of a selected slur.

Dotted slurs

Dotted slurs are sometimes used in songs where the presence of a slur varies between stanzas.
Dotted slurs are also used to indicate an editor's suggestion (as opposed to the composer's original
markings). To change an existing slur into a dotted or dashed slur, select it and then in Inspector (F8)
change Line type from Continuous to Dotted or Dashed.

See also

Tie
Edit mode
Note input

Do you have an unanswered question? Post it in the forum.

Tablature
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Music for fretted, stringed instruments is commonly notated using tablature, also known as tab, which
provides a visual representation of the strings and fret numbers:

Tablature can also be combined with traditional staff notation:

Edit tablature properties

When a tablature staff is created in the New Score wizard it defaults to the most common tuning of the
instrument in question—in the case of a guitar, for example, it assumes standard tuning of E2, A2, D3,
G3, B3, E4. To alter the tuning—or any other tablature properties—right-click on the staff (in the
score) and select Staff Properties... See → below for details.

From Staff Properties you can access Advanced Style Properties, where detailed adjustments can
be made to the tablature display.

Create a new tablature staff

If you wish to create tablature as part of a new score, use the New Score Wizard. If you want to add
tablature to an existing score, use the Instruments dialog. Or, alternatively, you can convert an existing
standard staff. See below for details.

With the New Score wizard

To create tablature in a new score (for combined staff/tablature systems see → below):

1. Select File → New or use the shortcut Ctrl + N (Mac: Cmd+N) to open the New Score wizard.
2. Enter the score details (optional). Click Next.
3. In the Select template file page, click on Choose Instruments.

4. In the Instruments page, select one (or more) tablature options under "Plucked strings" in the
left-hand column (see image below). Then click Add.
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Note: You can use the dropdown list above the Instrument list to change the category displayed.
Alternately you can search for the instrument using the "Search" field below the Instrument list.

5. Complete the rest of the New Score Wizard.

If the desired tablature is not available in the Choose Instrument list:

1. Select an existing "Plucked strings" tablature staff (in step 4 above).
2. Press Add to move it to the right-hand column.
3. Check the drop-down menu to the right of the newly-added instrument for the most suitable Tab

option, if any.
4. Complete the rest of the New Score wizard and exit.
5. Modify the number of strings and tuning of the tablature, if needed, in the Staff properties

window (see → below).
6. Change the Instrument name in Staff Properties, if required.

This allows you to create tablature for any chromatically-fretted instrument.

With the Instruments dialog

To add a single tablature staff to an existing score (for combined staff/tab system see → below):

1. Open the instruments editor (menu Edit → Instruments... or I key).
2. Add the tab staff as described in Instruments.

By changing staff type

To convert an existing standard staff to tablature, or tablature to a standard staff:

1. Right click on the staff and select Staff Properties…. If "Instrument" is already set to a plucked-
strings type, then exit staff properties and go to step 4.

2. If "Instrument" is not a plucked-strings type, click on Change instrument and select an
appropriate instrument from "Plucked strings."

3. Click on OK twice to exit staff properties.
4. Open the instrument editor from the score page (menu Edit → Instruments... or I key).
5. Click on the staff in the right-hand column and change the "Staff type" to the desired option.
6. Click OK to exit the Instrument editor and return to the score page.

Note: If you subsequently need to make further adjustments to the staff (e.g. tuning, number of
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lines/strings etc.), right click on the staff and select Staff Properties….

Alternative version (using just the "Staff properties" dialog):

1. Right click on the staff and select Staff Properties….
2. If the Instrument displayed is in the "Plucked strings" category, go to step 4.
3. If the Instrument displayed is not in the "Plucked strings" category, click Change instrument and

select an appropriate instrument from "Plucked strings". Click on OK.
4. Click Advanced Style Properties..., change "Template" to the desired option and press < Reset

to Template.
5. Click OK twice to close the Staff Properties dialog box..

Note: Other adjustments to the staff (e.g. tuning, number of lines/strings etc.), can also be made in the
Staff Properties dialog.

Change string tuning

In MuseScore, plucked-string instrument staves (pitched and tablature) are set by default to the most
commonly-used string tunings. You can view the tuning by right-clicking on a staff in the score,
selecting Staff Properties..., and pressing Edit String Data.

To change the string tuning of a staff:

1. Right-click on an empty spot in a measure of a staff whose tuning you want to change.

2. Select Staff Properties....

3. Press the Edit String Data... button at the bottom of the dialog box (only shown if instrument
is defined as "plucked strings"). The String Data dialog opens:
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Here, you have a number of options:

Retune an existing string
1. Click on a string pitch and select Edit String.... Or, alternatively, just double-click

the string.
2. Select a new pitch in the Note Selection box and click OK. Or, alternatively, just

double-click the new pitch.

Notes: If tuning is changed when the tablature for that instrument already contains some notes,
fret marks will be adjusted to produce the same notes with the new tuning (if possible).

Any change you make to the string tuning will only affect that particular instrument for that
particular score, and will not alter any program default or built-in definition.

Add a new string
1. Click on a string pitch and select New String....
2. Select the new pitch and press OK. Or, alternatively, just double-click the new pitch.

Note: The new string is inserted below the selected string.

Delete a string. Click on a string pitch and select Delete String.

Note: After adding or deleting a tablature string you will need to adjust the number of lines in the
Advanced style properties dialog.

Mark a string as "Open". Check one or more boxes in the "Open" column. This feature is
used to designate unfretted strings – as in the Lute.

Change number of instrument frets. Select or enter a new number in the "Number of
frets" spin box. This sets the maximum fret number which can be entered on a string.

4. Click OK to close the "String Data" dialog box.

5. Click OK to close the "Staff/Part Edit Properties" dialog box.

Combine pitched staff with tablature

Plucked-string instruments, such as the guitar, are commonly notated using both a pitched staff and a
tablature (TAB) staff. The pitched staff displays conventional music notation while the associated
tablature shows the strings and fret numbers corresponding to the notes. The paired staves can be
either linked or unlinked:

1. Linked Staves: The associated staves are said to be linked if changes in one staff are
immediately applied to the other staff (mutual translation).

2. Unlinked Staves: The staves are said to be unlinked if they can be edited independently of one
another. To transfer music notation from one staff to the other, select the desired range and copy
and paste it into the other staff.
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Note: Occasionally, you may find numbers marked red in the tablature. This means that a fret mark
cannot be displayed because it clashes with an existing one. You can resolve this by moving and
adjusting existing fret numbers (see Editing existing notes). However, a fretmark clash on the lowest
line does not require any adjustment—this is "by design" and the red mark will not appear on any
printed copy.

Create a staff/tablature pair with the New Score wizard

If you want to create a staff/tablature system (linked or unlinked) from new:

1. Select File → New or use the shortcut Ctrl + N (Mac: Cmd+N) to open the New Score wizard.
2. Enter the score details (optional). Click Next.
3. In the Select template file page, click on Choose Instruments.
4. In the Instruments page, select a pitched staff in the "Plucked strings" section of the left-hand

column. Then click Add.
5. Select the newly-created staff in the right-hand column and chose one of two options:

Click Add Linked Staff to create a linked staff/tab pair
Click Add Staff to create an unlinked staff/tab pair

6. Change Staff type on the far right if required (more detailed display options are available by
right-clicking on the tablature staff and selecting Staff Properties… → Advanced Style
Properties).

7. Complete the rest of the New Score Wizard, or click Finish

Note: To create unlinked staves with separate mixer channels, instead of "Step 5" (above), select a
Tablature staff in the left-hand column and click Add. Then continue with steps 6 and 7.

Create a staff/tablature pair from an existing staff

To add tablature to a plucked-string staff in the score (or vice versa):

1. Open the instrument editor (menu Edit → Instruments... or I key)
2. Select the staff you want to add to in the right-hand column.
3. Chose one of two options:

Click Add Linked Staff to create a linked staff/tab pair
Click Add Staff to create an unlinked staff/tab pair

4. Change Staff type on the far right if required (more detailed display options are available by
right-clicking on the tablature staff and selecting Staff Properties… → Advanced Style
Properties...).

5. Use Up to change staff position, if needed.
6. Click OK.

Notes: To create unlinked staves with separate mixer channels, instead of "Step 3" (above), select an
appropriate staff in the left-hand column and click Add. Then continue with steps 4–6.

Change a linked staff/tablature pair to unlinked (or vice-versa)

(a) If you want to change a linked staff/tablature system in the score to unlinked:

1. Open the instrument editor from the score page (menu Edit → Instruments... or I key)
2. Click on the pitched staff in the right-hand column and click Add staff.
3. Change Staff type (on the far right) of the newly-created tab staff to the correct option. If the

previous staff/tablature pair was blank, go to step 5. If there is existing music notation in the
score, continue with step 4.

4. Click OK to return to the score. Copy and paste any notation from the linked to the unlinked
tablature staff. Return to the Instrument editor.

5. Click on the linked tablature staff on the right, click Remove then OK.

(b) If you want to change an unlinked staff/tablature system in the score to linked:

1. Open the instrument editor from the score page (menu Edit → Instruments... or I key)
2. Click on the pitched staff in the right-hand column and click Add linked staff.
3. Change Staff type (on the far right) of the newly-created tab staff to the correct option.
4. Select the unlinked tablature staff and click Remove, then OK.

Inputting new notes
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Keyboard

First, ensure that you are not in note-input mode. Select the measure or existing note from
which you want to begin note entry.
Switch to note input mode (N): a short 'blue rectangle' appears around one tablature string: this is
the current string.
Select the duration of the note or rest that you wish to enter (see below).
Press the up/down arrow keys to move the cursor to the desired string. Use the left/right arrow
keys to navigate through the score.
Press 0 to 9 to enter a fret mark from 0 to 9 on the current string; to enter numbers with several
digits press each digit in sequence. Keys A to L (skipping I) can also be used: convenient when
working in French tablature. Note: You cannot enter a number higher than the maximum fret
number.
You can also correct the fret number with Alt+Shift+↑ or Alt+Shift+↓.
Press ; (semicolon) to enter a rest of the selected duration.
You can enter notes in different voices if required—just as you would in a standard staff.

Mouse

Enter note input mode and select the note or rest duration (see below)
Click on a string to create a note there. Notes are initially created on fret 0 (or a for French
tablatures): to correct, type in the right number from the keyboard.
You can also correct the fret number with Alt+Shift+↑ or Alt+Shift+↓.
You can enter notes in different voices if required—just as you would in a standard staff.

Selecting note duration

In note input mode, you can use any of the following methods to set note duration in tablature:

Shift+1 to Shift+9 (availability of these shortcuts may depend on the platform and/or keyboard
layout)
NumPad 1 to Numpad 9 (if a numeric keypad exists and NumLock is on)
the input tool bar at the top of the screen
Q to decrease the selected value and W to increase it

Editing existing notes

While NOT in note input mode, three key combinations can be used to change a fret mark:

↑ / ↓ increases/decreases the fret number without changing the string (ranging from 0 to the
number of frets defined in the "Edit String Data" dialog box).
Alt+Shift+↑ / ↓ increases/decreases the fret number, but moves the note to a different string
where possible to maintain it in the open position (frets 0–4).
Ctrl+↑ / ↓ moves the selected note to upper/lower string (if the string is free and can produce
that note).
Shift+X toggles ghost noteheads on/off.

Summary of keys

Note input mode

Type: to get:
↑ Select above string as current.
↓ Select below string as current.

Shift+1 to Shift+9 Select a duration (128th note to
longa)

NumPad 1 to NumPad
9

Select a duration (128th note to
longa)

Q Decrease current input duration.
W Increase current input duration.
0 to 9 Enter a fret digit / letter.
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A to K Enter a fret digit / letter (I excluded).
Alt+Shift+↑ Increase current fret mark.
Alt+Shift+↓ Decrease current fret mark.
; (semicolon) Enter a rest

Type: to get:

Normal mode

Type: to get:
0 to 9 Change duration of selected note or rest (128th note to longa)
Alt+Shift+↑ Increase the pitch of the selected note (MuseScore chooses the string).
↑ Increase the pitch without changing string.

Alt+Shift+↓ Decrease the pitch of the selected note (MuseScore chooses the
string).

↓ Decrease the pitch without changing string.
Ctrl+↑ Move note to above string, keeping the pitch.
Ctrl+↓ Move note to below string, keeping the pitch.
Shift+X Toggle the ghost note head on/off.

External links

Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation

Do you have an unanswered question? Post it in the forum.

Ties
A tie is a curved line between two notes of the same pitch, indicating that they are to be played as one
note with a combined duration (see external links below). Ties are normally created between adjacent
notes in the same voice, but MuseScore also supports ties between non-adjacent notes and between
notes in different voices.

In note-input mode, if you specify a tie immediately after entering a note or chord, the program
automatically generates the correct destination notes to go with the ties. Or, you can simply create ties
"after the fact," between existing notes.

Note: Ties should not be confused with slurs. Slurs can look similar, but they will not be rendered
correctly in playback.

Tie notes together

1. Press Esc to make sure you are not in note input mode.
2. Click on a note, or use Ctrl (Mac: Cmd) + click to select more than one note.

3. Press + or the tie button, .

.

Ties will be created between the selected note(s) and the following note(s) of the same pitch.

Tie chords together
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To tie all the notes in a chord at once, either:

Click on the stem of the chord, or
Hold down Shift and click on any note in the chord.

Then press + or the tie button . Ties will be created between all the notes in the selected chord and
the following notes of the same pitches.

Add tied notes in note input mode

To create a single note tie during note input:

1. Select a single note (one that is not part of a chord).
2. Select a new note duration for the following note, if required (but see "Note" below).

3. Press + or the tie button, .

Note: This shortcut works, as described above, only if there is no chord following the selected note. If
there is, then the duration is ignored and the tied note is added instead to the following chord.

Add a tied chord in note input mode

1. Make sure one note is selected in a chord.
2. Select a new note duration for the following chord, if required (but see "Note" below).

3. Press + or the tie button, .

Note: This shortcut works, as described above, only if there is no chord following the selected note. If
there is, then the duration is ignored and the tied notes are added instead to the following chord.

Tied unison notes

If the chords to be tied contain unison notes the best way to ensure correct notation is:

1. Assign each note of a unison pair to a separate voice.
2. Ensure that one of the unison pairs is set to "stemless" (to remove the duplicate stem and tail).
3. Apply the ties voice by voice. Make adjustments for position, length as required.

Flip a tie

X flips the direction of a selected tie, from above the note to below the note, or vice-versa.

See also

Slur

External links

Ties (music) at Wikipedia

Do you have an unanswered question? Post it in the forum.
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Time signatures
Time signatures are available in the main palette sidebar (see Palette for general information on
working with palettes in MuseScore).

Add a time signature to a score

To add a time signature, use any of the following methods:

Drag and drop a time signature from a palette onto a space in a measure.
Select a measure and then double-click a time signature in a palette.
Select any note or rest and double-click a time signature in a palette.

The time signature will appear at the beginning of the measure in question.

To replace a time signature, use any of the following methods:

Drag and drop a time signature onto an existing time signature.
Select a time signature in the score, then double-click a time signature in a Palette.

Delete a time signature

To delete a time signature in the score, select it and press Del.

Create your own time signature

If the time signature you require is not available in the Time Signatures palette of a workspace, you
can create it in the Time Signatures section of the Master Palette: Press Shift+T to open it.

To create a new time signature, select an existing one in the Master Palette, then edit the various
parameters (numerator, denominator, text, beaming) in the Create Time Signature panel. To add the
newly-created time signature to the list, press the Add button. Once added, you can drag and drop it to
the desired score location. To delete a time signature in the Master Palette, right-click on it and select
"Clear".

You can transfer a time signature from the Master Palette to a customized workspace by dragging and
dropping it onto a Palette in the workspace.

Additive (composite) meters

Additive (or composite) time signatures are sometimes used to clarify the division of beats within a
measure. The visible time signature (numbers separated by a plus sign) is entered in the Text field in
the Create Time Signature panel. e.g.:
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Change default beaming

To make an overall adjustment to the way that notes are beamed in part or all of the score, right-click
on the relevant time signature (in the score) and select "Time Signature Properties:"

This allows you to independently adjust the beaming patterns for 1/8, 1/16 and 1/32 notes in the "Note
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Groups" panel.

To break a beam, click on the note following it. To reset the beam, click in the same place. Note: This
method only works if all secondary (or sub) beams are present at the intended location – if this is not
the case then use the icons instead (see below). The Reset button cancels any changes made in that
session.

You can also make additional changes to the beaming patterns by dragging one of the icons 

 (at the bottom left of the window) onto a note in the "Note Groups" panel:

 Start beam at this note.

 Do not end beam at this note.

 1/8th note beam to left of this note.

 1/16 note beam to left of this note.

Different duration from time signature: Pickup measures (Anacrusis) and Cadenzas

There are occasions when the actual duration of a measure is different from the duration specified by
the time signature. Pickup measures and Cadenzas are a common example. To change the actual
duration of a measure without displaying a different time signature, see Measure operations:
Properties, Measure duration.

Local time signatures

Time signatures can be different for different staves. An example here is Bach's 26. Goldberg
Variation:

MuseScore has the concept of a global time signature and an actual (local) time signature. To change
the global time signature drag and drop a palette object to a staff. The global time signature is used to
count beats (as shown in the status line) and is the reference for tempo markings. The global time
signature is the same for all staves and normally identical to the actual time signature.

The actual time signature is set in the time signature property dialog and can deviate from the global
time signature for every staff (upper staff 18/16 in the example).
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The text of the time signature can be set independent of the actual values.

A local time signature is set by dropping a time signature symbol while holding the Ctrl key (Mac:
Cmd). The local time signature is set only for one staff. A global time signature is replicated for all
staves.

Time signature changes and breaks

Multimeasure rests are interrupted when a time signature change occurs. Also, a section break will
prevent a courtesy time signature being shown at the end of the previous measure.

See also

Key signature

External links

Additive meters at Wikipedia.

Do you have an unanswered question? Post it in the forum.

Transposition
Transposition moves a selection of notes higher, or lower on the staff. MuseScore supports several
kinds of transposition, including transposing instruments.

100

https://musescore.org/sites/musescore.org/files/Time_Signature_Properties_en_1.png
https://musescore.org/en/handbook/measure-rests#multimeasure-rest
https://musescore.org/en/handbook/breaks-and-spacers#section-break
https://musescore.org/en/handbook/key-signatures-0
http://en.wikipedia.org/wiki/Time_signature#Additive_meters
https://musescore.org/en/forum


(See below for details)

Chromatic transposition, by key

Chromatic transposition moves selected notes up or down in semitone increments. From the main
menu, choose Notes → Transpose..., select which key signature to transpose - closest, up or down. If
no selection is made, transposition applies to the whole score.

Chromatic transposition, by interval

Chromatic transposition moves selected notes up or down in semitone increments. From the main
menu, choose Notes → Transpose.... Tick "By Interval", select the interval from the popup menus and
whether to transpose up or down. If no selection is made, transposition applies to the whole score.

You can also transpose a selection of notes using the arrow keys (↑ or ↓).

Diatonic transposition

Diatonic transposition (also known as scalar transposition) moves notes up, or down the current scale
according to the key signature. You can move a single note by dragging it up, or down. You can move
a selection of multiple notes with Ctrl + click and drag.

Transposition shortcuts

F2 (Mac: fn+F2): Transpose score and key signature UP one semitone.
Shift+F2 (Mac: Shift+fn+F2): Transpose score and key signature DOWN one semitone.
Ctrl+↑ (Mac: Cmd+↑): Transpose selection UP one octave.
Ctrl+↓ (Mac: Cmd+↓): Transpose selection DOWN one octave.

You can also use Edit → Preferences → Shortcuts to set a convenient keyboard shortcut to open the
Transpose dialog box.

Transposing instruments

Certain instruments such as B-flat trumpet or E-flat alto sax are known as transposing instruments.
These instruments sound lower, or higher than their written pitch. MuseScore has built-in support for
transposing instruments.
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The Concert Pitch button and Notes → Concert Pitch from the main menu lets you switch between
concert pitch and transposing pitch. Concert pitch helps composers and arrangers because it displays
every instrument in the same key, so the notes on the staff match their sounding pitches. When
concert pitch is turned off, the notes on some instrument staves may not match their sounding
pitches, but they are ready for an instrumentalist to play from. If you use concert pitch during your
session, remember to turn off concert pitch before printing the parts.

Change staff transposition

Instrument transpositions are already set up in MuseScore. However, if you want a rare instrument or
transposition that is not available in MuseScore, you may need to edit the instrument transposition
manually. Right-click an empty part of the instrument staff and choose Staff Properties.... At the
bottom of the Staff Properties window, you can select the interval of transposition, any octave shifts,
and whether the interval is "Up" (sounds higher than written) or "Down" (sounds lower than written).

You can also use the Change Instrument… button in the Staff Properties window to automatically
change the transposition to that of a different standard instrument.

External links

How to transpose (MuseScore How-To)
Concert pitch or not?? (forum discussion)

Do you have an unanswered question? Post it in the forum.

Tremolo
Tremolo is the rapid repetition of one note, or a rapid alternation between two notes or chords. It is
indicated by strokes through the stems of the notes or chords. If the tremolo is between two, the bars
are drawn between them. Tremolo symbols are also used to notate drum rolls.

The tremolo palette in the advanced workspace contains separate symbols for one note tremolos
(shown with stems below) and for two note tremolos (shown with no stem below).

To add tremolo to a single note, select the note head and double-click the desired symbol in the
tremolo palette.

In a two note tremolo, every note has the value of the whole tremolo duration. To enter a tremolo with
the duration of a half note (minim), enter two normal quarter notes (crotchets), and after applying a
tremolo symbol to the first note, the note values automatically double to half notes.

Do you have an unanswered question? Post it in the forum.

Tuplets
Tuplets are used to write rhythms beyond the beat divisions usually permitted by the time signature.
For example, a sixteenth note triplet will divide an eighth note beat into three sixteenth notes instead
of two:

In 6/8 time, an eighth note duplet will divide a dotted quarter note into two eighth notes instead of
three:
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Create a tuplet

The exact method of tuplet entry depends on whether you are starting off in note input mode or
"normal mode" (in the latter you have notes or rests selected in the score but are not in note-input
mode). We'll start off with a simple example: the creation of an eighth note triplet.

Create a triplet in normal mode

1. Select a note or rest that specifies the full duration of the desired triplet group. In the case of an
eight note triplet, you will need to select a quarter note or rest—as in the example below:

2. From the main menu, choose Notes → Tuplets → Triplet, or press Ctrl+3 (Mac: ⌘+3). This will
give the following result:

3. The program automatically changes to note-input mode and selects the most appropriate
duration—in this example an eighth note. Now enter the desired series of notes/rests. For
example:

Create a triplet in note input mode

1. Ensure you are in note input mode (press N).
2. Navigate to the note/rest (or blank measure) where you want the triplet to start (use the left/right

arrow keys as required).
3. Select a final duration for the whole triplet group. In the case of an eighth note triplet, click on the

quarter note in the note input toolbar (or press 5 on the keyboard).
4. From the main menu, choose Notes → Tuplets → Triplet, or press Ctrl+3 (Mac: ⌘+3). This

creates a triplet number/bracket and appropriately divides the original note/rest (see image
above).

5. The program automatically selects the most appropriate duration—in this example an eighth
note—allowing you to immediately start entering the desired series of notes/rests.

Create other tuplets

Most other tuplets can be entered similarly, by substituting the general create tuplet command –
Ctrl+2–9 (Mac users Cmd+2–9) – in the above series of steps: this will create tuplets ranging from a
duplet (2) to a nonuplet (9). For more complex cases, see Custom tuplets (below).

Custom tuplets

To create other tuplets than the default options (e.g., 13 sixteenth notes in the space of one quarter
note), first enter and select a note or rest equaling the total duration of the tuplet, go to Notes →
Tuplets → Other..., and enter the number of notes you want to appear relative to the number of
notes you would normally expect to appear (e.g., 13/4 for thirteen sixteenth notes in the space of the
selected quarter note).
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Delete a tuplet

To delete any tuplet, select the number/bracket and press Del.

Settings

To customize the appearance of a single tuplet, you can change its properties in the Inspector. You
can also change the general style for all tuplets in a score.

Inspector

To change the display properties of a tuplet, select the tuplet number, or bracket, and use the
Inspector.

If neither the number nor the bracket is shown, select a note from the tuplet, then use the Tuplet
button in the Inspector to see the above dialog.

For Direction, choose Auto to place the bracket on the same side of the note heads as the stem, or
beam. Choose Up, or Down to explicitly place the bracket above or below the note heads, respectively,
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regardless of the stem, or beam position.

For Number type, choose Number to show an integer, Relation to show a ratio of two integers, or
Nothing to show no number at all.

For Bracket type, choose Automatic to hide the bracket for beamed notes and show the bracket if the
tuplet includes unbeamed notes or rests. Choose Bracket, or Nothing to explicitly show, or hide the
bracket, respectively.

Style

Go to Style → General... and select Tuplets. It enables you to change all tuplet properties.

Two adjustments are possible: Vertical and Horizontal

Vertical adjustment has three options with values in space units and one (un)ticked option
Maximum slope: default value is 0.50; range is from 0.10 to 1.00
Vertical distance from stem (see (2) below): default value is 0.25; range is from -5.00 to
5.00
Vertical distance from note head (see (3) below): default value is 0.50; range is from -5.00
to 5.00
Avoid the staves: by default ticked

Horizontal has four options with values in space units
Distance before the stem of the first note (see (5) below): default value is 0.50; range is
from -5.00 to 5.00
Distance before the head of the first note: default value is 0.00; range is from -5.00 to 5.00
Distance after the stem of the last note (see (6) below): default value is 0.50; range is from
-5.00 to 5.00
Distance after the head of the last note: default value is 0.00; range is from -5.00 to 5.00
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See also

How to create triplets and other tuplets

External links

Tuplet at Wikipedia
How To Create Triplets in MuseScore [video]
The User Guide to Tuplets in MuseScore [video]

Do you have an unanswered question? Post it in the forum.

Voices
You can have up to 4 Voices on each staff line. A voice is a musical line or part which can have its
own rhythm independently of other voices on the same staff. Voices are sometimes called "layers" in
other notation software.

In a polyphonic measure, voice 1 usually takes the up-stem notes and voice 2 takes the down-stem
notes.

Note: The feature called "Voices" should not be confused with "vocal staves," which can be added
from the Instruments dialog (accessed by pressing I). When creating a closed SATB score, use
Voices 1 and 2 for Soprano and Alto parts on the top staff, and use Voices 1 and 2 on the bottom staff
for Tenor and Bass parts—do not use Voices 3 and 4 for Tenor and Bass.

When to use voices

If you need stems pointing in opposite directions within a chord, on a single staff.
If you need notes of different durations within a single staff, played simultaneously.

How to enter notes in different voices

The following example shows you how to notate a section using two voices:

1. Enter voice 1 notes: Make sure you are in note input mode: the Voice 1 button becomes
highlighted in blue in the toolbar. Enter the notes in the top voice first (see example in image
above or further down below). When inputting, some notes may have down-stems, but these will
flip automatically when the second voice is added.

2. Move cursor to start of section: When you have finished entering a section of voice 1 notes,
press the ← key repeatedly to move your cursor, note-by-note, back to the first note of the
section (or alternatively use Ctrl+← to move back measure-by-measure). Or else you could
simply exit note entry mode (press Esc) and click directly on the first note.
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3. Enter voice 2 notes: Make sure you are in note-input mode and that the voice 1 note at the
beginning of the section is selected. Click on the "Voice 2" button  (on the right of the
toolbar), or use the shortcut Ctrl+Alt+2 (Mac: Cmd+Option+2). Enter all the lower voice notes
(down-stem). The final result might look something like this:

Hidden spacer rests

Only the rests of voices 2, 3, and 4 can be deleted, but those of the main voice (1 - blue) can be
hidden.

To hide a rest, select it and press V or uncheck the "Visible" checkbox in the Inspector, which can be
enabled from the View menu or with the shortcut F8 (Mac: fn+F8). If you have Show Invisible turned
on in the View menu, the rest still shows in gray on your screen. The hidden rest will not appear if you
print, or export as PDF, PNG, SVG, etc.

Exchange voices of notes

To swap the notes between any two voices:

1. Select a range of notes.
2. From the Menu bar, select Edit → Voices
3. Exchange any two voices from the list.

Note: The selection can encompass content of any voice, but only two will be processed at once.

Move notes to another voice (without swapping)

You can also move notes from one voice to another (without note-swapping):

1. Ensure you are not in note input mode.
2. Select one or more noteheads (in any voice).
3. Click on the destination voice in the Note Input toolbar or use the shortcut Ctrl+Alt+1–4.

Note: For a successful move, either of the following conditions should apply:

1. The chord(s) in the destination voice must be the same duration as the note(s) to be moved
there.

2. There is enough rest duration in the destination voice to accomodate the new notes.

See also

Shared noteheads

External links

How to merge/combine/implode two staves in one with two voices
Video tutorial: How To Write Two Parts On One Staff: Voices

Do you have an unanswered question? Post it in the forum.

Voltas
Volta brackets, or first and second ending brackets, are used to mark different endings for a repeat.
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To place a volta bracket on the score, drag-and-drop the item from the Lines palette, or select the
measure(s) you want the volta to span and double-click the palette icon.

To change the number of measures that a volta covers, double-click to enter edit mode and press
Shift+→ to move the end handle one or more measures to the right. You can also move the end
handle back one measure by pressing Shift+←.

These commands move the "logical" start or end of the volta bracket, which determines correct
playback in MuseScore and layout over multiple systems. Moving the handles using the mouse or
using the left or right arrows keys without Shift allows fine position adjustments, but does not
change how the repeat is played (and may cause playback or layout issues).

If you move the handles, a dashed line appears on the score from the logical position of the handle to
the adjusted position:

Text

You can change the text and many other properties of a volta bracket using the line properties dialog.
Right-click on a volta bracket and choose Line Properties.... The figure below shows the volta text
as "1.-5."
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You can also right-click on the volta and bring up the volta properties dialog. From here, you can
change both the displayed Volta text (the same from the line properties above) and the repeat list. If
you want one volta to be played only on certain repeats and another volta on other repeats, enter the
repeat times in a comma separated list. In the example below, this volta will be played during repeat
1, 2, 4, 5 and 7. Another volta will have the other ending, like 3, 6 and possibly other higher numbers
like 8, 9, etc.

Playback

Sometimes a repeat plays more than two times. In the figure above, the volta text indicates that it
should play five times before it continues. If you want to change the number of times MuseScore plays
a repeat, go to the measure containing the end repeat barline and change its Repeat count (see
Measure operations: Other properties for details).

External links

MuseScore in Minutes, Lesson 8: Repeats and Endings, Part 1

Do you have an unanswered question? Post it in the forum.

Sound and playback
MuseScore has "Sound and playback" capabilities built-in. This chapter covers the playback controls
and ways to extend the instrument sounds.

MIDI import
MuseScore can import MIDI files (.mid/.midi/.kar) and convert them into music notation. To import, use
the standard Open command.

Initially, the programs renders the MIDI to notation using certain default settings. A MIDI Import Panel
appears at the bottom of the screen, showing a list of tracks (only tracks with note events are shown)
and the operations available for each track. You can change these settings on a track-by-track basis
and then reimport the data: The “Apply” button (at the top) submits any changes with immediate
effect. The "Cancel" button immediately cancels any unsaved changes. The final result should be a
better quality score reproduction of the file.

Use Shift+Wheel or Ctrl+Wheel to scroll track options horizontally; scroll tracks vertically without those
modifiers.

If there are multiple tracks, then one more track is added at the top of the list to select all tracks at
once.
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In the MIDI Import Panel, you can choose which tracks to import and reorder them. Some information
about each track is displayed: sound, staff name, and lyrics, if any. The presence of the lyric column is
an indication that the file contains a lyric track—assignable to different tracks through the drop-down
menu.

The MIDI import panel updates the relevant information of whatever file is in view, if the user has
several open. If the MIDI import panel is no longer required, it can be closed by clicking the close
button in the top-left corner. The panel will re-appear after clicking on the button "Show MIDI import
panel" which appears right after the panel is closed.

After saving the score, the MIDI Import Panel will not be available, because MuseScore is no longer
importing a MIDI file.

Available operations

MuseScore instrument
Assign a MuseScore instrument (listed in instruments.xml or in specified custom xml file in
Preferences) that defines staff name, clef, transposition, articulations, etc.

Quantization

Quantize MIDI notes by some regular grid. The grid MAX resolution can be set via the drop-
down menu:

Value from preferences (default) - quantization value is taken from the main Preferences
dialog of MuseScore (in the “Import” tab)
Quarter, Eighth, 16th, 32nd, 64th, 128th - user-defined values

However, the actual quantization grid size is adaptive and reduces when the note length is
small, so for each note the quantization value is different. But there is an upper limit for the
quantization value, and that value can be set by the user as "max. quantization".
For example, if some note is long - say, half note, and the max. quantization is set to 8th, then
the note will be quantized with the 8th-note grid, not the half- or quarter-note grid as it supposed
to be by the algorithm.
Such quantization scheme allows to quantize all notes in the score (with different lengths!)
adequately.

Max. voices
Sets maximum count of allowed musical voices.

Search tuplets
When enabled, this option attempts to detect tuplets and applies the corresponding quantization
grid to the tuplet chords.

Is human performance
If enabled, this option reduces the accuracy of MIDI-to-score conversion in favor of readability. It
is useful for unaligned MIDI files, when no regular quantization grid is provided. For such files the
automatic beat tracking algorithm is used which tries to detect the bar positions throughout the
piece.

2x less measure count
The option is active for unaligned MIDI files (when "Is human performance" is checked by
default). It halves measure count obtained in the internal beat tracking operation. It may be
convenient when the beat tracking gives 2x more frequent bar subdivision than necessary.

Time signature
The option is active for unaligned MIDI files. The user can choose an appropriate time signature
for the whole piece if the default detected value is wrong. The option is useful because it handles
imported tuplets correctly unlike the direct time signature setting from the palette.

Split staff
This option is suited mainly for piano tracks - to assign notes to the left or right hand of the
performer. It uses constant pitch separation (the user may choose the pitch via sub-options) or
floating pitch separation (depending on the hand width - sort of a guess from the program point
of view).
For drum tracks (“Percussion” sound in the track list) it splits the staff into multiple staves, each
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of which gets only one drum pitch (i.e. drum sound). There is also a sub-option to allow/disallow
the application of the square bracket for the newly created set of drum tracks.

Clef changes
Small clefs can be inserted within a staff to keep chords closer to the 5 staff lines. Clef changes
depend on the average pitch of the chord. Tied groups of notes are not broken by the clef
insertion (if it occurs, one can report a bug for algorithm in importmidi_clef.cpp). This option is
available for non-drum tracks only.

Simplify durations
Reduces number of rests to form more "simple" note durations. For drum tracks this option can
remove rests and lengthen notes as well.

Show staccato
Option to show/hide staccato markings in the score.

Dotted notes
Controls whether MuseScore will use dotted notes or ties.

Show tempo text
Shows/hides tempo text markings in the score.

Show chord names
Shows/hides chord names in the score, if any, for XF MIDI file format.

Recognize pickup measure
When enabled, this option doesn't change the time signature of the first bar that is shorter than
the second bar. It is also called anacrusis. This option is only available for all tracks at once.

Detect swing
MuseScore tries to detect swing, and automatically replace a pattern of 4th + 8th notes in triplets
(for the most common swing feel, 2:1), or a dotted 8th + 16th pattern (for shuffle, 3:1), with two
straight 8ths and a “Swing” or “Shuffle” text at the beginning.

Do you have an unanswered question? Post it in the forum.

Mid-staff instrument changes
When a musician is required to double on a different instrument for a section of a piece, the instruction
to switch instruments is generally placed above the staff at the beginning of that section. A return to
the primary instrument is handled in the same manner.

MuseScore enables users to insert a special class of text called Change Instrument text for this
purpose. This class of text is different from either Staff or System text in that it links the text to the
playback and changes the sound to the new instrument. There are, however, several limitations to the
functionality of this feature in 2.0.x, and these should be understood before attempting to use it.

1. Automatic transposition from concert pitch to the appropriate key for the transposing brass and
woodwind instruments is not currently supported. For changes to instruments notated in a
different key (C flute to Eb flute; Oboe to English Horn, etc.), the use of ordinary Staff Text to
indicate the change is preferable, and the transposition must be done after the music is entered
(using Notes>Transpose from the main menu). To avoid discord on playback, the instrument
assigned to that staff should be muted in the F10 Mixer.

2. If it is necessary to hear the new instrument sound on playback, the Change Instrument text
function must be used. However, after a mid-staff instrument change where the two instruments
on the staff are not notated in the same key, no attempt should be made to enter new music
directly from the keyboard. Instead, the music must be (a) pasted in, or (b) entered before the
instrument change is effected. New input into measures following an instrument change is
subject to two known program bugs, which cannot be resolved in the current 2.0.x versions
without adversely affecting backwards compatibility. (This has been fixed for the next stable
release, v.3.0.) In addition, the score must remain notated in concert pitch, or discord will result
from the transposition. As a convenience to the players, a copy of the part may be saved as a
separate file and the required sections transposed to the appropriate key before the part is
printed. (Note that transposing a linked part will affect the score as well.)

3. When changing from one concert-pitch instrument to another, or from one transposing
instrument to another in the same key (Bb trumpet to Bb cornet or Flugelhorn, etc.), the Change
Instrument Text may be used to ensure that the playback sound is altered to the new
instrument. Input may be done in the usual manner, and is not affected by the bugs mentioned
above.

Add an instrument change

1. Select the start point of the change by clicking on a note or rest.
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2. Open the main palette by typing F9 (or by using the View menu), and click on Text to open the
text sub-palette.

3. Double-click on Instrument
4. The word "Instrument" will appear above the anchor note or rest.
5. Double-click the word "Instrument", then type Ctrl+A to select all of it.
6. Type the actual text you wish to appear in the score, then click outside the box to exit text edit

mode.

7. Right-click the text and choose "Change Instrument…"

8. Choose the instrument, then click OK
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See also

Change instrument
Mid-staff sound change

Do you have an unanswered question? Post it in the forum.

Mixer
The Mixer allows you to change instrument sounds and adjust the volume and panning for each staff
(reverb and chorus are not currently supported). From the main menu, choose View → Mixer or press
F10 (Mac: fn+F10) to show the Mixer.

The name of each channel is the same as the Part name in the Staff properties dialog.

Mute and Solo

Use the Mute check box to quickly silence certain staves. Alternatively, use the Solo check box to
silence all staves, except the staff or staves you mark as "solo".

Dials

To turn a dial clockwise, click and drag upwards. To turn a dial counter-clockwise, click and drag
downwards. You can also hover the mouse pointer over the dial and then move the mouse wheel.

Double-clicking on any dial restores it to its default.

Sound

The Sound drop-down menu lists every instrument supported by your current SoundFont. If you have
multiple SoundFonts loaded in the Synthesizer, all the patches from all the SoundFonts will appear in
a single long list—all the sounds available from the second SoundFont appearing after all the sounds
from the first SoundFont, and so on.

Mid-staff sound change (pizz., con sordino, etc.)

Some instruments come with multiple channels in the Mixer that can be used to change sounds
midway through a score. For example, strings may utilize pizzicato or tremolo, and trumpet can switch
to muted trumpet.

The following instructions use pizzicato strings as an example, but the same principles apply to
tremolo strings or muted trumpet.
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1. Select the first note of the section you want to be pizzicato
2. From the main menu, choose Add → Text → Staff Text
3. Type Pizz. At this point, this text is a visual reference only and not applied during playback
4. Right-click on the staff text and select Staff Text Properties...
5. In the Staff Text Properties dialog, select one or more voices on the left (in the Change

Channel tab)

6. From the dropdown menu, select pizzicato

7. Click OK to return to the score

Every note after the staff text you added now sounds pizzicato. To return to a normal strings sound
later in the piece, follow the same guidelines as above except type Arco in step 3 and select normal in
step 6.

See also

SoundFont
Synthesizer
Change instrument
How to change instrument sound (e.g. pizz., con sordino) midway through score

Do you have an unanswered question? Post it in the forum.

Play mode
MuseScore has an integrated sequencer and Synthesizer to play your score. Basic playback functions
are accessed from the Play toolbar (see image below) located above the document window:

By pressing the Play  button (or Space), you enter Play mode. In Play mode, the following
commands are available:

Go back to previous chord ←
Advance to next chord →
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Go back to start of previous measure Ctrl+← (Mac: Cmd+←)
Advance to start of next measure Ctrl+→ (Mac: Cmd+→)
Rewind to start of score Home (Mac: ⌘+Home)
Show/hide Play Panel F11 (Mac: Fn+F11)

Press the play button again (or Space or Esc ) to stop and exit Play mode.

MuseScore starts playback from the place it last left off. To start playback from a specific note (or
measure), click on that note (or measure) before entering playback mode. Alternatively, if the score is
already playing back, you can jump to a specific note by clicking on that note. The toolbar also has a
rewind button to quickly return to the beginning of the score.

To include playback of repeats, activate the  Enable/Disable Repeats-Button.

Play panel

To open the Play Panel from the main menu, choose View → Play Panel, or type F11 (Mac: Fn+F11).

The Play Panel offers temporary controls over playback, including playback speed (labelled 'tempo'),
loop playback (with specified starting and ending positions), and general volume for the current
session.

Please Note: Changes to the parameters in the Play Panel are not saved-to-file for the score, even
when Save is clicked. They only affect the playback behaviour in the current session. If you wish to
modify the actual tempo of a piece, you must do it using the tempo text settings in the Inspector (F8)
or via tempo text). If you wish to reset the default playback volume, you can do this in the Synthesizer
dialogue. Synthesizer—View → Synthesizer.

Count in

You can switch on and off a count-in to be played each time the playback starts. The count-in plays
beats for a full measure (according to nominal time signature at playback starting point); if the starting
point is mid-measure or at a 'short' measure (anacrusis), it also plays enough beats to fill that
measure. The conductor icon in the play panel enables, or disables count-in.

Metronome playback

You can also switch on/off the accompanying metronome as the score is played (see the metronome
icon on the play panel).

Loop

You can loop playback of a selected passage in the score using either the Play toolbar (see image
above) or the play panel.

To loop from the Play toolbar:
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Playback should be off, and the "Loop playback button" on.
Select the desired region of the score for loop playback.
Press the playback button.

Playback will now cycle within the region marked by the blue flags.

Use the "Loop playback" button to toggle the loop on or off.

To loop from the Play Panel:

Select the note from which you want playback to start and click on the "Set loop in position"
button. The "Loop Playback" button becomes active.
Select the last note of the desired playback region and click on the "Set loop out position"
button.
Press the play button.

Playback will now cycle within the region marked by the blue flags.

You can use the" Loop playback" button to toggle the loop on or off.

Do you have an unanswered question? Post it in the forum.

SoundFonts

Overview

A SoundFont file is a special type of file that contains many samples of different instruments playing
different notes, enabling MuseScore to play each instrument sound. Some SoundFonts are custom
designed for classical music, others are designed for jazz, pop, etc. Many SoundFonts are available
on the web. Look for one that covers the 128 sounds of General MIDI (GM). If you use a SoundFont
that does not conform to the General MIDI standard, others may not hear the correct instruments
when you share the score or export a MIDI file.

MuseScore 2 comes with the soundfont FluidR3Mono_GM.sf3. Previous versions, MuseScore 0.9.6 –
1.3, featured a very light-weight SoundFont called TimGM6mb.sf2.

The file size and sound quality of SoundFonts available on the web varies. Larger SoundFonts often
sound better but take up a lot of memory and may be too large to run on your computer. If you find
MuseScore runs slowly after installing a large SoundFont, or your computer can't keep up during
playback, then look for a smaller SoundFont.

Once a SoundFont has been installed, you can use it for playback in MuseScore (and control other
aspects of the sound output) with the Synthesizer. To display the Synthesizer, go to View →
Synthesizer.

Install a SoundFont

After finding and decompressing a SoundFont (see →below), double-click to open it. In most cases,
the SoundFont file type will already be associated with MuseScore, and MuseScore will start and a
dialog will appear asking if you want to install the SoundFont. Occasionally an application other than
MuseScore will be associated with the SoundFont file type; if this is the case, you will need to right-
click or control-click on the file, so as to display a menu from which you can choose to open the file in
MuseScore. In either case, when the dialog appears asking if you want to install the SoundFont, click
"Yes" to place a copy of the SoundFont file in MuseScore's SoundFonts directory. This directory can
be viewed or changed in MuseScore's Preferences, but the default location is:

Windows: %HOMEPATH%\Documents\MuseScore2\Soundfonts

macOS and Linux: ~/Documents/MuseScore2/Soundfonts

In contrast to user-added SoundFonts, the initial default SoundFont installed with MuseScore is
located in a system directory, meant only for that purpose, which should not be modified. This
directory and its default SoundFont file is:

Windows (32-bit): %ProgramFiles%\MuseScore 2\sound\FluidR3Mono_GM.sf3

Windows (64-bit): %ProgramFiles(x86)%\MuseScore 2\sound\FluidR3Mono_GM.sf3
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macOS: /Applications/MuseScore 2.app/Contents/Resources/sound/FluidR3Mono_GM.sf3

Linux (Ubuntu): /usr/share/mscore-xxx/sounds/FluidR3Mono_GM.sf3 (with xxx being the
MuseScore version)

Uninstall

To uninstall a SoundFont, simply open the folder where the SoundFont is installed and delete it.

Synthesizer

The Synthesizer is MuseScore's central control panel for sound output. Once a SoundFont has been
installed, it needs to be loaded into the Synthesizer in order for MuseScore to use it for playback. To
make a different SoundFont the default, load it in the Synthesizer and click Set as Default.

To display the Synthesizer, go to View → Synthesizer. For more details, see Synthesizer.

List of SoundFonts

Below are some popular GM SoundFonts of different sizes.

Fluid R3 GM (141 MB uncompressed)
License: released under the MIT license (included in the archive)
MuseScore's default SoundFont is based on Fluid R3.
GeneralUser GS (29.8 MB uncompressed)
Courtesy of S. Christian Collins
Magic Sound Font, version 2.0 (67.8 MB uncompressed)
Arachno SoundFont, version 1.0 (148MB uncompressed)
Courtesy of Maxime Abbey
MuseScore 1 came with TimGM6mb (5.7 MB uncompressed)
License: GNU GPL, version 2
Courtesy of Tim Brechbill
MuseScore 2 comes with FluidR3Mono_GM.sf3 (12.6 MB).
License: released under the MIT license
Timbres of Heaven, version 3.2 (369 MB uncompressed)
Courtesy of Don Allen

Specialized SoundFonts

Acoustic grand piano, release 2016-08-04
Description: Yamaha Disklavier Pro Grand Piano, sf2 format, 36MiB compressed, 113MiB
uncompressed, 121 samples, 5 velocity layers
More information: http://freepats.zenvoid.org/ including other soundfonts.
License: Creative Commons Attribution 3.0
Courtesy of Roberto Gordo Saez

In addition to SoundFont files, MuseScore also has some support for the SFZ format, thanks to the
new synthesizer Zerberus. Here are some SFZ sound banks:

Sonatina Symphonic Orchestra (503 MB uncompressed)
Downloads: SoundFont | SFZ format
License: Creative Commons Sampling Plus 1.0
Salamander Grand Piano
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Downloads: version 2 | version 3
Description: Yamaha C5, 48kHz, 24bit, 16 velocity layers, between 80 MB and 1.9 GB
uncompressed
License: Creative Commons Attribution 3.0
Courtesy of Alexander Holm
Detuned Piano (244 MB uncompressed)
License: Creative Commons Attribution-ShareAlike 3.0
Plucked Piano Strings
Description: 44.1kHz, 16bit, stereo, 168 MB uncompressed
License: Creative Commons Attribution-ShareAlike 3.0
The City Piano
Description: Baldwin Baby Grand, 4 velocity layers, 696 MB uncompressed
License: Public domain
Courtesy of Big Cat Instruments
Kawai Upright Piano, release 2017-01-28
Description: 68 samples, 44KHz, 24bit, stereo, 2 velocity layers, 58MiB uncompressed
License: GNU General Public License version 3 or later, with a special exception
Courtesy of Gonzalo and Roberto

Note: Since SoundFont files are large, they often are compressed into a variety of formats, including
.zip, .sfArk, and .tar.gz. You need to decompress these files before they can be used.

ZIP is standard compression format supported by most operating systems.

sfArk is a compression format designed especially for compressing SoundFont files. Use the
special sfArk software to decompress it, or use this online service:
https://cloudconvert.com/sfark-to-sf2

.tar.gz is a popular compression format for Linux. Windows users can use 7-Zip; Mac users can
use The Unarchiver, or macOS' built-in Archive Utility. Note that if using 7-Zip, you will need to
apply decompression twice—once for GZip and once for TAR.

Troubleshooting

If the toolbar play panel is greyed out, or not visible, follow the instructions below to get your sound
working again:

Do a right-click on the menu bar and make sure there is a check mark next to the Transport
Tools menu item. You can add or remove the check mark by clicking on the corresponding menu
item. If this step does not solve your problem, continue below.
If the play panel disappears after changing the SoundFont, go to Edit → Preferences... → I/O
tab and click OK without making any changes. After restarting MuseScore, the play panel should
reappear.

If you are setting up a SoundFont for the first time, please use one of the recommended SoundFonts
listed above.

If playback stutters, then your computer is not able to handle the SoundFont being used. Two
solutions:

1. Reduce the amount of RAM (memory) used by MuseScore by using a smaller SoundFont. See
list above for suggestions.

2. Increase the amount of RAM available for MuseScore by quitting all applications except
MuseScore. If you still have problems and a large SoundFont is important to you, consider more
RAM for your computer.

See also

Synthesizer
Change and adjust sounds

External links

How to change the SoundFont or add another

Do you have an unanswered question? Post it in the forum.
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Swing
MuseScore is capable of playing back a score using swung eighth notes or swung sixteenth notes.

Set up swing

The recommended way to inform MuseScore (and the humans who will read your music) that a swing
feel is intended is to create a Swing System Text element.

1. Click the first note

2. Double-click Swing in the Text palette

The Swing text can be edited, like any other text element, by double-clicking it (see Text editing), and
it can be made invisible using the Inspector.

Return to straight rhythm

If you have a score containing both "swing" and "straight" sections, and want this reflected in
playback:

1. Insert a Swing text item as explained above, attached to the first note or rest of the "straight"
section.

2. Change the text as desired—double-click on the item you just inserted and change it to "Straight"
(see Text editing).

3. Turn swing off via right-click → System Text Properties… → Swing Settings → off

Swing settings

Swing text settings

Swing settings for an individual Swing text marking are available via right-click → System Text
Properties… → Swing Settings. This allows you to define how heavily to swing (i.e., the ratio of the
downbeat to upbeat), and whether it's the eighth note or the sixteenth note that is swung.

Global swing settings

By default, in the absence of a Swing text element, swing playback is turned off. To turn on swing
playback without adding a text element, use the general (score-wide) swing settings in Style →
General... → Score.

Do you have an unanswered question? Post it in the forum.

Synthesizer

Overview

The Synthesizer controls MuseScore's sound output. It allows you to:

Load and organize different sound sample libraries to play back the music
Apply effects such as reverb and compression
Adjust overall tuning
Alter the output volume of both music and the (optional) metronome.

To display the Synthesizer, go to View → Synthesizer.

The Synthesizer window is divided into four sections/tabs:
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Fluid: A software synthesizer that plays SF2/SF3 SoundFont sample libraries.
Zerberus: A software synthesizer that plays SFZ format sample libraries.
Master Effects: Used to apply multi-effects to the score.
Tuning: Used to adjust overall playback tuning.

Synthesizer settings

Set as Default: When you open MuseScore, the Synthesizer always assumes the current default
settings. If you want a new default to apply at the next session, change the settings as desired, then
press the Set as Default button.

Save to Score / Load to Score: You can save a particular configuration of settings to an individual
score by pressing the Save to Score button. When you next load the score, use the Load from Score
button to transfer the stored settings to the Synthesizer.

Note: Only one set of Synthesizer settings can be in effect at a time—i.e. if multiple scores are open
at once, it is not possible to make changes to the Synthesizer in one score and leave other scores'
settings untouched.

Note: Changes made in the Synthesizer will not be heard in exported audio files unless the
Synthesizer settings have been saved to the score with the Save to Score button. See also Tuning
(below).

SoundFont

A SoundFont is a file containing a set of sounds that MuseScore can use for playback. MuseScore
comes with a SoundFont called FluidR3Mono_GM.sf3; other SoundFonts can be downloaded from the
internet (see this list of SoundFonts). Once a SoundFont has been installed, you can select it to be
used for playback and control other aspects of the sound output with the Synthesizer.

By default, the SoundFont FluidR3Mono_GM.sf3 should be loaded in the Synthesizer:

Click the Add button to load another installed SoundFont from the SoundFonts directory.

Note: If you have not installed any other SoundFonts, then there will not be any SoundFonts available
to load. To use a SoundFont for playback, it needs to be first installed (which is a one-time action) and
then loaded in the Synthesizer (which can be done on a case-by-case basis, or set up permanently).

A loaded SoundFont can be removed from the Synthesizer (but not uninstalled) by selecting it in the
list and clicking Delete, and if multiple SoundFonts are loaded their order can be rearranged with the
Up and Down buttons.

If you have not changed any sounds in the Mixer, then the SoundFont at the top of the list is the one
that will be used for playback. However, if you are using the Mixer to play different instruments with
sounds from different SoundFonts, playback will only work correctly if you have the same SoundFonts
loaded in the same order in the Synthesizer. Therefore, if you are using multiple SoundFonts, it is
advised to click the Save to Score button in the Synthesizer, so that the next time you open that score
you can recall the list of SoundFonts loaded (and other Synthesizer settings) with the Load from Score
button.

Optionally, you can use the Set as Default button to change the default Synthesizer settings so you
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won't have to load the settings from a score the next time. Otherwise, the Synthesizer will be in its
original default settings in your next session with MuseScore.

Volume

At the right in the Synthesizer are two sliders. One controls the playback volume, the other controls
the volume of the optional built-in metronome. You can turn the metronome on or off by clicking the
button underneath its volume slider. As with all the rest of the Synthesizer controls, any changes made
here are temporary unless saved to the score or set as the new default.

Effects

The Master Effects tab of the Synthesizer houses the Zita 1 stereo reverb and SC4 stereo
compressor modules. Two slots are provided, "Effect A" and "Effect B," both with a drop-down list of
available effects – including the option to set one or both channels to "No Effect." The effects are
applied in series: Effect A → Effect B.

To store an effects configuration as the default option for the synthesizer, click the Set as Default
button. If you subsequently change the effects set-up, you can restore whatever settings you made the
defaults by clicking the Load Default button.

You can store a particular effects configuration with a score by clicking on the Save to Score button,
and later load those settings from the score by clicking on Load from Score.

Zita 1 reverb

The Zita 1 stereo reverb module allows you to simulate the ambience of anything from a small room to
a large hall. The predelay, reverb time and tone of the reverb can be finely tuned using the controls
provided:

Delay: Set a pre-delay for the reverb from 20-100 ms.
Low RT60 (Low frequency reverb time): Use the grey control to adjust the center frequency (50–
1000 Hz) of the low frequency band which you want to affect: the green control adjusts the
reverb time (1–8 secs) of this frequency band.
Mid RT60 (Mid-range reverb time): Adjust the reverb time (1–8 secs) of the mid-range
frequency band.
HF Damping: Adjusts the high frequency component of the reverb. Increasing this value
increases the frequency of the cut-off point and makes the reverb appear brighter and longer.
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EQ1: Allows you to cut or boost (-15 to +15) a frequency band (center = 40 Hz - 2 KHz) in the
lower part of the spectrum.
EQ2: Allows you to cut or boost (-15 to +15) a frequency band (center = 160 Hz - 10 KHz) in the
higher part of the spectrum.
Output: Controls the amount of effect applied. "Dry" is no effect. "Wet" indicates 100% reverb.
"Mix" is a 50/50 balance of wet:dry signal.

Note: EQ1 and EQ2 affect the tone of the reverb only, not the dry (unprocessed) signal.

To quickly set up an effects patch, set "Output" to "Mix" and adjust the "Mid RT60" control to the
desired reverb time. Then fine tune the effect as explained above.

SC4 compressor

The SC4 stereo compressor offers the following controls:

RMS: Adjusts the balance between RMS (0) and Peak (1) compression. In the former, the
compressor responds to averaged-out levels in the signal; in Peak mode, the compressor
responds to peak levels.
Attack: (1.5–400 ms) The length of time it takes for compression to engage fully after the signal
exceeds the threshold level.
Release: (2–800 ms) The time it takes for compression to return to zero after the signal falls
below the threshold level.
Threshold: (in dB) The signal level above which compression starts to take effect. Lowering the
threshold increases the amount of signal that is compressed.
Ratio: The amount of compression applied to the signal above the threshold. The higher the
ratio, the greater the compression. Varies between 1:1 to 20:1.
Knee: Allows you to select a range between "soft knee" and "hard knee". The softer the knee,
the more gradual the transition between uncompressed and compressed signal.
Gain: Compression tends to lower the volume, so use this control to boost the signal as
required.

Tuning

For Concert Pitch instruments, MuseScore uses the A4 = 440 Hz pitch standard by default. To change
it, simply enter a new value in the Tuning tab of the Synthesizer.

Like all other Synthesizer settings, the master tuning affects playback within MuseScore but does not
affect exported audio files (WAV, OGG, MP3) unless the Save to Score option is selected.

Change master tuning

Notes: Applies to all scores. Current session only (tuning resets to default on MuseScore exit). Affects
playback but doesn't affect exported audio files (WAV, OGG, MP3, and MIDI).

1. View → Synthesizer.
2. Click the Tuning tab.
3. Enter a new Master Tuning value (Minimum value = 300 Hz; Maximum value = 600.0 Hz; Default

440 Hz).
4. Click Change Tuning.
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Set default tuning

Note: Applies to all scores. Current session and all subsequent sessions (until you change it again).
Affects playback but doesn't affect exported audio files (WAV, OGG, MP3, and MIDI).

1. Change the Master Tuning as shown above for the current session.
2. Select Set as Default.

Change tuning for an individual score

Note: Applies to current score for current session, use the Save to Score button, and settings can be
recovered in subsequent sessions with Load from Score. Affects playback and exported audio files
(WAV, OGG, MP3).

1. Change the Master Tuning as shown above for the current session.
2. Click Save to Score.
3. You will now get this new tuning in exported audio files of the current score, but other scores will

export with the default tuning as expected. However, due to a limitation in MuseScore, you need
to click Load from Score to get the correct tuning on playback.

See also

SoundFont
Mixer

Do you have an unanswered question? Post it in the forum.

Tempo
Tempo markings can be added to a score in the form of tempo text. Playback tempo can also be
temporarily overridden through the Play Panel.

Tempo text

Tempo markings are used to indicate the pace of the music to the person reading the score, and they
are also reflected in playback. It is possible to have multiple tempo markings at different points
throughout a score.

To add a tempo marking:

1. Select the note or rest where the tempo should be added.
2. Open the Tempo palette and double-click a tempo marking style to add it to the selected note or

rest. Alternatively, you can drag-and-drop a tempo from the palette directly onto a note or rest.
You can also add a tempo from the main menu with Add → Text... → Tempo Marking or use the
shortcut Alt+T, in which case it automatically will derive the note value to be used from the time
signature.

Existing tempo markings can be changed by double-clicking the text to enter text edit mode.

A tempo marking's beats per minute can be changed by directly editing the text, if "Follow text" is
selected in the Inspector and the tempo text is expressed in the form "note duration = number", as in
this example, which includes the information "quarter note = 75":

If a tempo marking has been edited and no longer includes that information (for example, simply the
word "Andante" with no number associated with it), click once on the marking to select it. Uncheck the
"Follow text" checkbox in the Inspector, and you can manually set the number of quarter note beats
per minute that the tempo marking represents.
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Note: Playback may be faster or slower if the tempo setting in the play panel is at a percentage other
than 100%.

Ritardando and accelerando

Gradual tempo changes like ritardando ("rit.") and accelerando ("accel.") can be added to the score
as system text, but currently don't have any effect on playback. The effect can be achieved, however,
by stepping down the tempo using multiple invisible tempo markings. In this example, the tempo is
decreased by 10 BPM on the first note of each measure, starting from 110 BPM before the ritardando.
Each tempo change is made invisible by unchecking the Visible checkbox in the Inspector, so that
only the ritardando shows on the printed score.

A plugin has been developed to automate this process: TempoChanges (external link)

Fermatas

Fermatas, available in the Articulations and Ornaments palette, have a Time stretch property that can
be set via the Inspector. By default, this property is set to 1.00. To have MuseScore play back a
fermata for twice its normal duration, click on the fermata and set "Time stretch" to 2.00.

Play panel

Display the play panel: View → Play Panel or F11 (Mac: fn+F11)
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Change the percentage of the score's actual tempo using the Tempo slider

This setting is not saved in the score and will proportionally override all tempo markings set in the
score. If you have multiple tempo markings in the score, the BPM (Beats per Minute) number
displayed above the slider will depend on where in the score you are. For example, if you have a
tempo of 80 BPM set, and the Play Panel is set to 120% of tempo, the actual tempo of the playback
will be 96 BPM, which you can tell by the number displayed above the percentage in the Play Panel.

See also

Play mode

Do you have an unanswered question? Post it in the forum.

Dynamics
Dynamics are symbols indicating the loudness of a note or phrase of music. Symbols can be found in
the Dynamics palette in either the Basic or Advanced workspace:

Note: Overall playback volume of the score can be changed using the volume slider in the Play Panel
or Synthesizer.

Add a dynamic

To apply a dynamic to the score, use one of the following methods:

Select a note and double-click a dynamic symbol in a palette.
Drag a dynamic symbol from a palette onto a note.

For additional dynamics use the Master Palette (Shift+F9). You can also create a custom palette for
future use.

To create a crescendo or decrescendo sign, see Hairpin.

Adjusting playback volume for a dynamic

Click on the dynamic to select it, and adjust its Velocity in the Inspector—higher for louder, lower for
softer.

Adjusting range for a dynamic

Via the Inspector you can set the range of a dynamic to span a single staff, all staves of an instrument
(e.g. both staves of a piano), or the entire system. The default setting is to span the instrument.

List of dynamics in palettes

In the Basic workspace, there are 8 options in the Dynamics palette: ppp, pp, p, mp, mf, f, ff, fff.

In the Advanced workspace, there are all of the above plus 15 additional options in the Dynamics
palette: fp, sf, sfz, sff, sffz, sfp, sfpp, rfz, rf, fz, m, r, s, z, n.

In the Dynamics section of the Master Palette, there are all of the above plus 6 additional options:
pppppp, ppppp, pppp, ffff, fffff, ffffff.
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Edit a dynamic

Any dynamic can be edited after being added to the score, just like standard text. See Text editing.

See also

Tempo

External links

Video tutorial: Lesson 10 - Articulations, Dynamics and Text
Dynamics at Wikipedia

Do you have an unanswered question? Post it in the forum.

Text
Many score elements in MuseScore are either wholly text-based—such as staff text, dynamics,
tempo, fingering, lyrics etc.— or consist of text in combination with a line—such as voltas, octave
lines, guitar barre lines etc.

This chapter covers some of the different classes of text available in MuseScore, and shows you how
to format them. Other specific types of text are covered in other chapters:

Tempo (→Sound and playback)
Dynamics—p, mf, etc. (→Sound and playback)
Swing (→Sound and playback)
Instrument change (→Sound and playback)
Repeats and jumps —DC, Fine, Coda, etc. (→Notation)
Figured bass (→Advanced topics)
Frame text—in vertical, horizontal or text frames (→Formatting)
Headers and footers —different from standard text objects (→Formatting)
Lines (→Notation)

Text basics

Add text

To add a text-based element to the score, use one of the following general methods:

From the main menu, select Add → Text (to create a title, for example).

Select a text element from a palette (to create swing text, for example).

Press a keyboard shortcut (to create lyrics, for example).

Note: The exact method depends on the type of text you are adding—refer to the relevant pages of
the Handbook for details (see Text). For general-purpose text boxes attached to staves, see Staff and
system text.

Format text

Every text-based element in the score has three levels of formatting:

Text Style

This is the top level of formatting and sets the style for a particular class of text in the score. All staff
text, for example has a unique text style, as do tempo markings, lyrics, chord symbols and so on.
MuseScore comes with many predefined text styles, which can be customised, but you are also free
to create your own.

To edit the text style of an element, go to Style → Text…, or right-click on some text and select Text
Style….
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Any text style can be applied to any text element. Changing a text style affects all text objects in the
score which use that style.

For full details, see Text styles.

Text Properties

This is the next level down in the formatting hierarchy and affects the style of the text in one specific
text object. To edit the text properties for that object—and no other—right click on the text and select
Text Properties…. For full details, see Text properties.

Text editing

While editing the actual text in a text element, you can also apply specific formatting to individual
characters, using basic formatting options such as Bold, Italic, font, font size, subscript and
superscript. To edit text:

Double click on the text, or
Right-click on the text and select "Edit element," or
Click on the text and press Ctrl + E (Mac: Cmd + E).

For full details, see Text editing.

Adjust position of text objects

To adjust the position of a selected text object, either:

Use one of the following keyboard shortcuts:
←: Move text left 0.1 staff space (one staff space is the distance between two staff lines, as
set in Page Settings)
→: Move text right 0.1 staff space.
↑: Move text up 0.1 staff space.
↓: Move text down 0.1 staff space.
Ctrl+← (Mac: ⌘+←): Move text left one staff space.
Ctrl+→ (Mac: ⌘+→): Move text right one staff space.
Ctrl+↑ (Mac: ⌘+↑): Move text up one staff space.
Ctrl+↓ (Mac: ⌘+↓): Moves text down one staff space.

Adjust the horizontal or vertical offset values in the Inspector.
Drag the object.

Do you have an unanswered question? Post it in the forum.

Text editing

Text edit mode

To enter text edit mode there are several methods:

Double click on the text
Right-click on the text and select "Edit element"
Click on the text and press Ctrl+E (Mac: Cmd+E)

Formatting and entry options can then be accessed from the text toolbar at the bottom of the window.
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Editing commands and keyboard shortcuts

In text edit mode, the following commands are available:

Ctrl+B (Mac: ⌘+B) toggles bold face
Ctrl+I (Mac: ⌘+I) toggles italic
Ctrl+U (Mac: ⌘+U) toggles underline
Home End ← → ↑ ↓ moves cursor
Backspace (Mac: Delete) remove character to the left of the cursor
Delete (Mac: → Delete or fn+Delete) remove character to the right of the cursor
Return start new line
F2 (Mac: fn+F2) Insert special characters (see below)

Special character shortcuts

In text edit mode the following keyboard shortcuts can be used to access certain special characters:

Ctrl+Shift+B: Flat
Ctrl+Shift+F: Forte
Ctrl+Shift+H: Natural
Ctrl+Shift+M: Mezzo
Ctrl+Shift+N: Niente
Ctrl+Shift+R: Rinforzando
Ctrl+Shift+S: Sforzando
Ctrl+Shift+Z: Z

Symbols and special characters

You can use Special Characters to insert quarter notes, fractions, and many other kinds of special

symbols or characters into your text. In the text toolbar, click on the keyboard icon, , or press F2
(Mac: fn+F2) to open the Special Characters dialog:

The dialog is divided into 3 tabs: Common symbols, musical symbols and unicode symbols. The
musical and unicode tabs are further subdivided into alphabetically-arranged categories.

Double-clicking an item in the Special Characters dialog immediately adds it to the text where the
cursor is positioned. Multiple items can be applied without closing the dialog box, and the user can
even continue to type normally, delete characters, enter numerical character codes etc., with it open.

Note: It is not possible to display the Special Characters dialog when not in text editing mode, and this
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should not be confused with the menu item of the same name in the macOS version of MuseScore.

See also

Chord symbol
Lyrics
Frame
Edit mode

Do you have an unanswered question? Post it in the forum.

Text styles and properties

Text styles and text properties

Every piece of text has a basic style. Title text, for example, is centered and uses a large font size;
Composer text is smaller and aligned to the right within the top vertical frame. To edit text styles, go to
Style → Text..., or right-click on some text and select Text Style...

Changes to a text style will affect all text that uses that style within a score.

You can also edit the same parameters as are available with a text style by right-clicking on a piece of
text and selecting Text Properties...

Unlike changes to a text style, changes to text properties only apply to the single specific piece
of text you right-clicked on. The text style for the rest of the score remains unchanged, and
other text using the same style is unaffected.

During text editing you can make changes that depart from the basic style and may also differ from the
specific text properties of a given piece of text. You can revert changes made through text editing
(such as font size and italics) with the reset text to style option.

The available options are divided into categories:

Text
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Font: name of the font such as "Times New Roman" or "Arial"
Size: size of the font in points
Style: style of the font, italic, bold, underline
Color: click on the color demonstrated to change
Size follows "Staff space" setting: whether size follows the distance between two lines in
a 5-lines standard staff
System flag: text applies to all staves of a system.

Offset
Horizontal
Vertical
Offset Unit: in mm or Staff space units

Alignment
Horizontal: left, right, center
Vertical: align top edge of text to reference point, center text vertical to reference point,
center text vertical to text baseline or align bottom edge of text to reference point

Frame

Frame: add a frame around the text
Frame Type: Circle or Box
Border thickness: thickness of the line of the frame in space units
Border radius: for box frame, radius of rounded corner
Text margin : inner frame margin in space units
Foreground color: of the frame border
Background color: of the background within the frame.

Note: Opacity is set by the parameter "Alpha channel" in the colors dialog: a value between 0,
transparent, and 255, opaque.

Text types

Title, Subtitle, Composer, Poet: anchored to page
Fingering: Fingerings are anchored to note heads.
Lyrics: Lyrics are anchored to a time position (a note/chord, but not a rest).
Chord symbol: Chord symbols are anchored to a time position.
System text: Applies to all staves in a system. Anchored to a time position.
Staff text: Applies to a single staff in a system. Anchored to a time position.

The distinction between system text and staff text matters for part extraction in ensemble scores.
System text will extract to all parts. Staff text will only extract to the part to which it is anchored. For
details, see Text.

Create a new text style

1. Go to Style → Text... or right-click on some text and select Text Style...
2. Click on New
3. Set a name
4. Set all properties as desirerd

This text style will be saved along with the score. It will not be available in other scores, unless you
explicitly save the style sheet and load it with another score.

Apply options

You can apply to either the score or part you are seeing, if you hit Apply and then OK.
If you are in one of the parts of your score, you also have the option to use the Apply to all parts
button before OK, so you don't have to manipulate all parts individually.

Reset text to style

If you have made changes to an individual piece of text and you want to return it to the defined text
style for the score, or if you changed the style with an old version of MuseScore and you want the
style to correspond to the default text style in MuseScore 2, you can use the Reset Text to Style
option.

Select the text you want to reset to style and click on Reset Text to Style in the Inspector. If you need
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all text from a given style to be "reset", right-click on one, then from the context menu choose
Select → All Similar Elements first.

Save and load text styles

Text styles (together with all other styles in a document) can be saved as a style file and loaded into
other MuseScore files. See Save and load style.

See also

Text editing
Header/Footer

Do you have an unanswered question? Post it in the forum.

Staff and system text
For general-purpose text, use Staff Text or System Text. The difference between these two types of
text is whether you want it to apply to a single staff, or the whole system. This matters when extracting
parts: staff text will only appear in a part that contains the specific instrument the text is attached to,
while system text will appear in all parts. Additionally, if you choose to hide empty staves, any staff text
belonging to an empty stave will also be hidden. System text is never hidden by the "hide empty
staves" feature.

Staff text

Staff text is general purpose text associated with a particular staff at a particular location in the score.
To create staff text, choose a location by selecting a note or rest and then use the menu option Add →
Text → Staff Text, or use the shortcut Ctrl+T (Mac: ⌘+T). A small text box appears and you can
immediately start typing. You can exit the text box at any time (even without typing anything) by
pressing Esc.

Staff text can, for example, be used to apply indications such as "Solo" or "Pizzicato" to one staff in a
score. Depending on what the instructions of the staff text are, MIDI playback of that staff at the text
location can be altered to match the instructions by right-clicking on the staff text and selecting Staff
Text Properties…. See How to change instrument sound (e.g. pizz., con sordino) midway through
score.

System text

System text is used when you wish to apply text indications to a whole system rather than just to one
staff line. This makes a difference when extracting parts, or if you choose to hide empty staves. To
create system text, chose a location by selecting a note or rest and then use the menu option Add →
Text → System Text, or use the shortcut Ctrl+Shift+T (Mac: ⌘+Shift+T). A small text box appears and
you can immediately start typing. You can exit the text box at any time (even without typing anything)
by pressing Esc.

Do you have an unanswered question? Post it in the forum.

Chord symbols
To begin adding Chord symbols to your score, first select a note or rest and press Ctrl+K (Mac:
⌘+K). This positions the cursor above the staff ready for input.

Enter a chord symbol

Chord symbols can be entered and edited just like normal text. Sharps and flats are entered as
follows:

Sharp: #.
Flat: b.
Double-sharp: x or ##.
Double-flat: bb.
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Note: When you exit the chord symbol, the characters you have typed will automatically assume the
correct format : a "#" or "b" will turn into a proper sharp or flat and so on. Do not try to use actual flat
and sharp signs as MuseScore will not understand those properly.

After you have finished entering a chord symbol you can either:

Exit by pressing Esc.
Move the cursor forward or backwards to continue note entry (see commands below).

Keyboard Commands

The following commands are available for chord symbol entry:

Space move Cursor to next note, rest, or beat
Shift+Space move cursor to previous note, rest, or beat
Ctrl+Space (Mac: ⌘+Space) add a space to the chord name
; move cursor to next beat
: move cursor to previous beat
Tab move cursor to next measure
Shift+Tab move cursor to previous measure
Ctrl plus number (1 - 9) move Cursor by duration corresponding to number (e.g.; half note for 6)
Esc exit.

Edit a chord symbol

An existing chord symbol can be edited just like ordinary text. See Text editing.

Chord symbol syntax

MuseScore understands most of the abbreviations used in chord symbols:

major: M, Ma, Maj, ma, maj, Δ (type t or ̂  for the triangle)
minor: m, mi, min, -
diminished: dim, ° (entered with lowercase letter o, shows as ° if using the the Jazz style, as o
otherwise)
half-diminished: ø (type 0, zero)
augmented: aug, +

Note that for half-diminished chords, you can of course also enter abbreviations like mi7b5 and they
will be rendered that way instead of using the ø.

You can also use extensions and alterations like b9 or #5, sus, alt, and no3. You can indicate
inversions and slash chords using notations like C7/E. You can use parentheses and commas within
chord symbols, and you can also enclose an entire chord symbol in parentheses.

Chord symbol text

The appearance of chord symbol text can be adjusted in the Text Styles window (right click on any
chord symbol and select Text Style…).

Chord symbol style

Formatting options for chord symbols are available in Style → General... → Chord Symbols,
Fretboard Diagrams. Adjustable properties are listed under the following headings:
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Style

MuseScore supports two primary styles of chords symbols: Standard and Jazz. You can select
between these using the radio buttons.

In the Standard style, chords are rendered simply, with the font determined by your chord symbol text
style.

In the Jazz style, the MuseJazz font is used for a handwritten look, and superscript and other
formatting techniques are used as well.

The Jazz style is selected by default if you use any of the Jazz templates.

The third radio button is mostly for compatibility with older scores. You can also use it to specify your
own custom chord descriptions files. These can be created by copying one of the standard files and
reading the documentation within them on their structure. However, this is for advanced users only,
and there is no guarantee these files will be supported in the future.

Note spelling

By default, MuseScore uses letter names for chord symbols. For users in regions where other note
naming schemes are used, MuseScore provides the following controls:

Standard: A, Bb, B, C, C#,...
German: A, Bb, H, C, C#,...
Full German: A, B, H, C, Cis,...
Solfeggio: Do, Do#, Reb, Re,...
French: Do, Do#, Réb, Ré,...

In addition, there are options to control capitalization. By default, MuseScore automatically capitalizes
all note names as shown above, whether you originally enter those using capital or lower case letters.
However, you can also choose other automatic capitalization options:

Lower case minor chords: c, cm, cm7,...
Lower case bass notes: C/e,...
All caps note names: DO, RE, MI,...

You can also turn off the automatic capitalization completely, in which case note names are simply
rendered the way you type them.

Positioning

Default vertical position: The height at which the chord symbol is applied above the staff
(negative values can be used)
Distance to fretboard diagram: If a fretboard diagram is present, this value is the height at
which the chord symbol is applied above the diagram (negative values can be used).
Minimum chord spacing: The space to leave between chord symbols.
Maximum barline distance: Changes the size of the gap between the last chord symbol in the
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measure and the following barline. You only need to adjust this value if there is a continuous
problem in the score with overlap between the last symbol in one measure and the first symbol
in the next.

Note: In addition to the settings described here, the default position of applied chord symbols is also
determined by settings in the Text Styles dialog. The effect is cumulative.

Capo

Enter the number of the capo position at which you want to display substitute chords, in brackets, after
all chord symbols in the score.

Do you have an unanswered question? Post it in the forum.

Fingering
Fingering symbols for various instruments are found in the Fingering palette in the Advanced
workspace.

Keyboard music employs the numbers 1–5 to represent fingers of the left or right hand.

Guitar music uses the numbers 0–4 to represent left-hand fingering (T is occasionally used for
the thumb). Right-hand fingering is indicated by the letters p, i, m, a, c. Circled numbers
represent instrument strings.

The last five symbols in the palette are used for lute fingering in historical music.

To add a fingering symbol to a note:

Select a note and double click one of the fingering symbols in a Palette
Drag and drop a fingering symbol from a palette onto a note

To add fingering symbols to a series of notes:

1. Select the desired notes
2. Double-click a fingering symbol in a palette

When fingering is added to a note, the focus immediately shifts to the symbol, so you can adjust it
right away.

Adjust symbol position

Use one of the following methods:

For fine adjustments (0.1 sp) use the arrow keys; For larger adjustments (1 sp) use Ctrl+Arrow
Change horizontal and vertical offsets in the Inspector
Drag the symbol using your mouse

To move more than one symbol

1. Select the desired fingering symbols
2. Adjust using the horizontal and vertical offset fields in the Inspector

To restore a symbol to its default position, select it and press Ctrl+R
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Fingering is a form of text symbol and can be edited and styled like any other. Right-clicking on the
symbol gives you a range of options.

Do you have an unanswered question? Post it in the forum.

Lyrics

Enter lyrics in a score

In order to attach lyrics to music in a score:

1. Enter the notes to which you intend to attach lyrics.
2. Click on the note where you want to start entering lyrics.
3. Type Ctrl+L (Mac: ⌘+L); or from the main menu, select Add → Text → Lyrics. Then type the

syllable for the first note.
4. Use the following options to continue entering lyrics:

Type Space (or Ctrl+→) at the end of a word to go to the next note.
Type a hyphen - at the end of syllable to go to the next note. The syllables are connected
with a dash.
Press Shift+Space (or Ctrl+←) to move to the previous syllable.
Press ↵ to move down to the next lyric line (Note: Don't use the Enter key from the
numeric keypad!)
Press Up to return to the above lyric line.

5. PressEscto end lyrics entry.
6. To type a second or further lyric line repeat steps 2 and 3 above, or double-click the first syllable,

hit ↵ and type the syllable for the first note, then continue at step 4

Example

Melisma

A melisma is a syllable or word that extends over two or more notes. It is indicated by an underline
extending from the base of a syllable to the last note of the melisma. The underline is created by
positioning the cursor at the end of a syllable and pressing Shift+_: once for each note in the
melisma. See the image below:

135

https://musescore.org/en/handbook/text-editing
https://musescore.org/en/forum


The above lyric was created in the following manner:

1. Type the letters, s-o-u-l, then a comma.
2. At the end of the word, press Shift+___.
3. Type the letters T-o, then press Esc.

For non-last syllables to extend, just use additional dashes -, only one of them will show, and the
syllable will right-align to the first note, similar to last syllables that got notated with a melisma, see
above.

Elision / Synalepha / Lyric Slur

Two syllables under a note can be joined with an elision character, also known as a "lyric slur" or
"synalepha".

In the text toolbar, click on the keyboard icon , or hit F2 to open the Text Symbols palette. The
synalepha is the 4th from the end (U+203F ‿ "undertie"). The synalepha will be evenly centered
separating the syllables with two spaces and by inserting it after the first. For the "e ͜A" example
shown above:

1. Type e
2. Insert the synalepha using the F2 palette
3. Type Ctrl+Space (Mac: ⌥+Space)
4. Type A

Not all fonts include the synalepha character. To find out which fonts on your computer support the
synalepha, see "fontlist" (look for any font that shows a tie between "e" and "A" instead of a blank
rectangle). The alignment of the character also varies between fonts.

Special characters

Lyrics can be edited as normal text with the exception of a few characters: If you want to add a space,
hyphen, or underscore to a single syllable, use the following shortcuts:

Ctrl+Space (Mac: ⌥+Space) enters a space ( ) into the lyrics text
Ctrl+- (Mac: ⌥+-) or AltGr+- enters a hyphen (-) into the lyrics text
Ctrl+Shift+_ (Mac: ⌥+_) enters an underscore (_) into the lyrics text
Ctrl+↵ (Mac: ⌥+Return) or Enter (from the numeric keypad) enters a line feed into the lyrics text

Adjusting individual lyric lines

The top margin and line height of all lyric lines can be adjusted globally from the menu, Style →
General... → Page.

However, the horizontal (and vertical) offset of individual lyric lines can be finely adjusted by right-
clicking on a word in the desired line, and using the various selection options available to select all the
words that you wish to change. Then adjust using the offset option in the Inspector.

For example, to change the horizontal position of the lyrics in one staff only of one particular system:
right click on a word in that line, choose Select → More..., then tick the boxes labelled "Same Stave"
and "Same System". Now use "horizontal offset" in the Inspector to fine tune the line position.

To select lyrics for a range of notes, first select the range of notes (click first note, shift+click last), then
right click a lyric and choose Select / All Similar Elements in Range Selection. Now use the Inspector
to adjust the lyrics.

Copy lyrics to clipboard
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Select Edit → Tools → Copy Lyrics to Clipboard.

Paste lyrics from clipboard

To copy and paste lyrics from a text file into a score:

1. Enter the notes in the score to which the lyrics will be attached.
2. Set up your lyrics in a text file, with appropriate spaces, hyphens, line-breaks etc.
3. Copy the lyrics from the text-file.
4. Select the start note in Musescore, and press Ctrl+L (Mac: Cmd+L) (step 3 under Enter lyrics in a

score).
5. Repeatedly applying paste will enter successive words of the lyrics. You may need to enter

melismas and make other corrections as you go along.

See also

Text
Chord symbol
How to insert Lyrics
How to move lyrics
How to add a block of text to a score

External links

Video tutorial: MuseScore in Minutes: Lesson 6 - Text, Lyrics and Chords

Do you have an unanswered question? Post it in the forum.

Rehearsal marks
Rehearsal marks are used to identify specific points in a score to facilitate rehearsing. They are
typically consecutive letters or numbers (A, B, C…, or 1, 2, 3…), or contain the number of the
measure they are attached to (though they are generally larger than plain measure numbers, often
boldface and/or enclosed in boxes). Whichever you choose, MuseScore can automatically display the
appropriate letters or numbers in each rehearsal mark. Rehearsal marks can also be used as
bookmarks to which you can instantly navigate when creating a large score (see →below).

Add a rehearsal mark

Manual Placement

The simplest way to add a rehearsal mark is to click on a note (or rest) at the start of a rehearsal
section and use the keyboard shortcut Ctrl+M (Mac: Cmd+M), or use the menu command Add → Text →
Rehearsal Mark: then enter the desired text yourself.

Automatic placement

Alternatively, select a note, open the Text palette, and double-click the [B1] rehearsal mark icon: the
correct letter or number is entered automatically, according to the following rules:

1. The first automatic rehearsal mark you create is labelled "A," the second "B," the third "C," and
so on. If you want to establish a different format (lower case, number or measure-number),
change the first rehearsal mark accordingly before adding the second one. Subsequently-added
rehearsal marks follow the format of the previously-added mark.

2. If you add a (palette) rehearsal mark between two existing alphabetical marks, a "1" is appended
to the name of the new mark: so a mark added between letters "C" and "D" becomes "C1," and
so on. Similarly, if you add a new rehearsal mark between two existing numerical marks, an "A"
is appended: so a mark added between numbers "3" and "4" becomes "3A" and so on.
Afterward, you can automatically resequence the rehearsal marks, if required (see →below).

3. To create a series based on measure number, the first rehearsal mark should be altered, before
creating a second one, so that it reads the same as the number of the measure it is attached to.
(If the number of the rehearsal mark is different from the actual measure number, subsequent
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marks will assume a numerical order.)

Automatically resequence rehearsal marks

MuseScore allows the user to automatically re-order a series of rehearsal marks if they have got out
of sequence for any reason. Use the following method:

1. Before making a selection, you can, if desired, establish a new format for the rehearsal marks
(lower/upper case, number, or measure number) by manually altering the first mark in the range
accordingly.

2. Select the range of measures you wish to apply the Resequence command to (if there is no
selection then the program assumes you wish to resequence all measures).

3. Select Edit → Tools → Resequence Rehearsal Marks.

MuseScore automatically detects the sequence based on the first rehearsal mark in the selection—all
rehearsal marks in the selection are then altered accordingly. The following sequences are possible:

A, B, C etc.
a, b, c etc.
Numerical: 1, 2, 3 etc.
Numerical: according to measure numbers. This requires the number of the first mark in the
series to be equal to the number of the measure it is attached to.

Search for a rehearsal mark

To navigate to a specific rehearsal mark, press Ctrl+F (Mac: Cmd+F) to open the Find bar, then enter
the name of the rehearsal mark. The first character of a rehearsal mark must be a letter for it to be
found: subsequent characters can be letters or numbers.

Note: If the text entered in the Find bar consists only of numbers, the program assumes you are
searching for a measure number. See Viewing and Navigation: Find.

Text style

Rehearsal marks are a variety of system text. They will appear on every part and on the score.
Multimeasure rests are automatically broken before and after rehearsal marks.

By default, rehearsal marks are bold, in large font size, and enclosed in frames with rounded corners.
All aspects of their appearance can be changed globally via the rehearsal mark Text style.

See also

Text properties

Do you have an unanswered question? Post it in the forum.

Formatting
Layout and formatting
You've finished your score and you want to print it out. However, you want to improve how it looks.
This page describes many different ways, and how they work together.

Ways to affect layout

Layout → Page Settings...: Change global settings such as page size, how big a "Staff space"
is (under "Scaling"), and how big page margins are. Staff space is used in other settings
(example: "5.0sp"), so changing "Staff space" will change most other settings.
Layout → Increase Stretch, Decrease Stretch: Adjust spacing—stretch or squash measures
you specifically select.
Style → General... → Page: Change global settings that affect how close staves are and
systems are, how much margin lyrics have, and so on.
Style → General... → System: Adjust System bracket thickness and distance, or the Brace
thickness and distance.
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Edit → Tools → Add/Remove line breaks: Fix the number of measures per system.
Style → General... → Score: Change score details, such as whether there are multimeasure
rests or hidden empty staves.
Style → General... → Measure: Set measure spacing, key to controlling number of measures
per line.
Palette → Breaks & Spacers: Break a line at a particular measure, a page at a particular line, or
add space between measures.
Style → General... → Sizes: Set the proportional size of "small" and grace notes. Changing this
would be unusual.

Note: Here, options will almost always apply to all objects you refer to in your score, some options
may be individually done with inspector and other object properties for one, or a selection of objects...

Layout → Page Settings...

See Page settings.

Layout → Increase Stretch, Decrease Stretch

To increase or decrease the horizontal spacing of notes within a measure or measures, you can
select the measures you want to affect, then use the "Increase Stretch" command (}) to widen them
so that fewer are on a line, or "Decrease Stretch" ({) to squash them to fit more on a line. You can
also access the exact same property from Measure Properties, where you can precisely edit the exact
percentage of additional space (or negative stretch). To reset a measure's stretch to the default
spacing of 1, use the "Reset Stretch" menu command.

Style → General... → Score
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Here you can choose whether to create multimeasure rests and whether to hide empty staves. Both
of these can affect score size greatly; Hide empty staves is used for creating condensed scores.
You can also specify the minimum size and minimal duration for multimeasure rests.

"Hide instrument name if there is only 1 instrument" can also be a good space saver in your parts (or
in solo score), as it won't write the instrument name at the beginning of the line.

You can also change the musical font for text and symbols. There are 3 musical fonts available (for
symbols used in the staves): Emmentaler, Gonville, and Bravura. There are 4 musical text fonts
available (for use in texts like dynamics, tempo markings, etc.): Emmentaler, Gonville, Bravura and
MuseJazz. Of these Emmentaler is the default and Bravura the most complete one.

(To change text font and properties see Text style)

Some options are specific to early music, and swing playback.

Style → General... → Page
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The options available here affect the overall layout of your score on the page. You can:

Adjust the distance between one system and the next, and between staves.
Change the spacing between lyric lines and adjust the height of their top and bottom margins.
Change the space at the top and bottom of the page between the music staves and page
margins.
Change the overall top and bottom margins of vertical frames.
Control the display (on/off) of key signatures, time signatures and clefs including courtesy
elements.

Distance to page margins

Music top margin: the distance between the top staff line of the first staff on the page and the
top page margin.
Music bottom margin: The distance between the bottom staff line of the last staff on the page
and the bottom page margin.

Distance between staves

Staff distance: The space between staves which are not part of a grand staff (see below).
Grand staff distance: The space between staves that share the same instrument—such as the
piano, organ, or those of a guitar staff/tab pair.

Note: To alter the space above one particular staff see Extra distance above staff (Staff properties).

Distance between systems

Min. system distance: The minimum distance allowed between one system and the next.
Max. system distance: The maximum distance allowed between one system and the next.

Lyrics Margins
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Lyrics top margin: The height of the margin above the top lyrics line (in a system).
Lyrics bottom margin: The height of the margin underneath the bottom lyrics line (in a system).
Lyrics line height: The distance between lyrics line (in a system), expressed as a percentage of
the line height associated with the lyrics text style.

Vertical frame margins

Vertical frame top margin: The default margin height above a vertical frame.
Vertical frame bottom margin: The default margin height below a vertical frame.

Last system fill threshold

If the last system is longer than this percentage of the page width, it gets stretched to fill that
width.

Style → General... → Header, Footer, Numbers

You can show the content of a score's meta tags (see Score information) or show page numbers in a
header or footer for your score. To create a header or footer for a score with linked parts, make sure
the main score is in the active tab. To create a header or footer for an individual part, that part needs
to be the active tab.

If you hover with your mouse over the Header or Footer text region, a list of macros will appear,
showing their meaning, as well as the existing meta tags and their content.
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You can create different Headers and Footers for even and odd pages, such as putting page numbers
on the right for odd-numbered pages and on the left for even-numbered pages.

You can also edit whether and how often measure numbers appear.

Style → General... → System

Bracket and Braces
See Bracket

Distances
You can set distance between the system and the Brackets and Brace
Width
You can set the width of Bracket and Brace.

Style → General... → Measure

See General style: Measure.

Style → General... → Barlines
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Control whether to show barlines at the beginning of a staff or multiple staves.
Scale barlines to staff size affects "small" staves only. See Barline adjustment possibilities
(external link) for details.
Control proportion of thickness and distance within double barlines, including repeat barlines.

Palette → Breaks & Spacers

See Breaks and spacers.

Style → General... → Notes
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This page can also be accessed direct from the score by right-clicking on any note and selecting
"Style…" Here you can adjust the distance and thickness of note-related objects (stems, ledger lines,
dots, accidentals). Changing these would be unusual.

Style → General... → Clefs
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You can choose between Serif and Standard clef for your tablature sheet.

Style → General... → Arpeggios
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Here you can change the thickness, spacing and hook height of the following arpeggio and strum
symbols:

Changes to these properties would be unusual.

Style → General... → Beams
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Style → General... → Slurs/Ties
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Style → General... → Sizes
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Sets the proportional size of "small" and grace notes, as well as small staves and clefs. Changing this
would be unusual.

Style → General... → Hairpins, Volta, Ottava
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The  button returns the setting to the original value.

Style → General... → Pedal, Trill
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Style → General... → Chord Symbols, Fretboard Diagrams
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This section allows you to adjust the format and positioning of chord symbols and Fretboard diagrams.

Appearance: Chose a default chord symbol style—Standard, Jazz or Custom.

Note Spelling: Chose the spelling convention for chord symbols and whether to use capital or small
letters.

Positioning:

Default vertical position: The default vertical distance in space units (sp.) between a newly-
applied chord symbol and the music staff. Negative values may be used.
Distance to fretboard diagram: The distance (in sp. units) from a chord symbol to a fretboard
diagram when both are applied to the same location on a staff. This value overrides the above
"Default vertical position" setting. The user can chose to place a chord symbol below a fretboard
diagram by entering a negative value.
Minimum chord spacing: The minimum space to allow between chord symbols.
Maximum barline distrance: Increases the distance between the final chord symbol in a
measure and the following barline. You may wish to adjust this value if there is a recurring
problem in the score with overlap between the final chord symbol in one measure and the
following chord symbol.

Capo: Enter the number of the capo position at which you want to display substitute chords, in
brackets, for all chord symbols in the score.

Fretboard diagrams:

Default vertical position: the distance in sp. units from a newly applied fretboard diagram to a
staff. A negative value may be used.
Scale: Increase or decrease the size of the fretboard diagram in the score.
Fret offset number font size: Increase or decrease the size of a fret number displayed next to
a diagram.
Position Left/Right: Display fret number to the left or right of the fretboard diagram.
Barre line thickness: Make barre lines in fretboard diagrams thicker or thinner.
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Style → General... → Figured Bass

Options about figured bass font, style and alignment.
See also Figured bass

Style → General... → Articulations, Ornaments
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Position of articulation with respect to the notes and staves

Style → General... → Accidentals
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Options about naturals at key signature changes

Style → General... → Tuplets
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Apply and OK buttons

With the Apply button you can see (without closing the window) what the changes you make are like.
OK will save the changes you made in your sheet and close the window.

Apply to all parts in one go

When in a part tab while changing layout and formatting, you can use the Apply to all Parts button
to apply all changes (either in Layout → Page Settings.... or Style → General...) to apply the new
settings to all parts in just one click.

Save/Load style

It is easy to transfer a complete set of styles (all General Style settings, all text styles, and page
settings) from one score to the other using the Save/Load Style functions.

To save a customized style:

1. Go to Style → Save Style....
2. Name and save the style file (the default folder is set in your Preferences). Styles are stored as

*.mss files.

Note: You can also define a preferred style for scores and parts in the Score section of MuseScore's
Preferences.

To load a customized style:

1. Go to Style → Load Style....
2. Navigate to and select the the Style file (.mss) and click Open (or double click on the file).

All existing styles in the score should update automatically.
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See also

To edit spacing between notes
Tutorial – How to create large-print stave notation (MSN)
Upgrading from MuseScore 1.x, local relayout

External links

MuseScore in 10 Easy Steps: Part 10A Layout and Formatting (a video tutorial)
MuseScore in 10 Easy Steps: Part 10B Layout and Formatting (a video tutorial)

General style: Measure

Style → General → Measure  allows you to adjust the distance between various items within measures.

Note: As you shrink or expand distances between notes and rests, MuseScore will always attempt to
keep the elements within each measure relatively spaced according to best engraving practice. In
other words, you may specify a certain amount of space between notes, but MuseScore will not apply
your change in such a way as to make all notes perfectly equidistant—there will always be less space
to the right of shorter notes than longer notes. In addition, elements attached to notes or rests such as
fingerings, dynamics, lines, and so forth, will be moved along with the notes or rests they are
anchored to when you make changes, so you need not worry about readjusting them separately.

All settings related to measure width and note spacing are minimum values. Measures are
automatically stretched, if necessary, to justify both margins.

Options

All the parameters here use the staff space unit of measurement, abbreviated sp. The staff space is
the vertical distance from one individual line in a staff to another (so a five-line staff is four staff spaces
tall). As the same unit is also used for horizontal measurements, in some cases you may need to
rotate the staff space distance 90 degrees in your mind. Measuring using the staff space unit enables
proportional scaling of everything in the score if you change the size of the staff. See Page settings:
Staff space/scaling for more details.
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Minimum measure width
Sets the minimum horizontal length of measures. In measures containing very little content (e.g.,
a single whole note or whole measure rest), the measure will only shrink as far as this minimum.

Spacing (1=tight)
Condenses or expands the space after notes or rests. This setting thus affects not only space
between notes but also between the last note and the ending barline. For the space between the
beginning of the measure and the first note or rest, see Barline to note distance (below).
Note: Changes to an individual measure's Stretch (under Layout → Increase Stretch,
Decrease Stretch) are calculated after, and proportional to, the global Spacing setting.

Barline to note distance
Sets the distance between the barline which begins a measure and the first note or rest in that
measure. For the initial measures of systems, which start with clefs instead of barlines, use
Clef/key right margin (below).
The following two options set the distance between barlines and specific elements that may
come between a barline and the first note in a measure, independent of the Barline to note
distance setting.

Barline to grace note distance
Sets the distance between a barline and a grace note that occurs before the first actual note in a
measure.

Barline to accidental distance
Sets the distance between a barline and an accidental placed before the first note in a measure.

Minimum note distance
Specifies the smallest amount of space MuseScore will allow after each note (depending on
other factors, more space may be allowed).

Clef left margin
Sets the distance between the very beginning of each line and the clef. (This option is rarely
needed.)

Key signature left margin
Sets the distance between the key signature and the clef preceding it.

Time signature left margin
Sets the distance between the time signature and the key signature or clef preceding it.

Clef/key right margin
Sets the distance between the material at the beginning of each line (such as the clef and key
signature) and the first note or rest of the first measure on the line. (Note that, although not
named in the option, if a time signature is present, it is the element from which the spacing
begins.)

Clef to barline distance
Sets the distance between a barline and a clef change preceding it.

Multimeasure rest margin
Sets the distance between a multimeasure rest and the barlines on either side.

Staff line thickness
Sets the thickness of the lines of the staff, which allows you to make the staff thicker and darker,
if you need greater visibility on your printouts.

Do you have an unanswered question? Post it in the forum.

Page settings
Layout → Page Settings... (like Style → General...) allows you to change the layout and formatting
of a score. The Page Settings dialog controls general formatting options, including page size,
printable margins, and how big a staff space is (Scaling). Page Settings is the first place to go to
make the size of your sheet music bigger or smaller.
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Page size

Here you can select the paper format, either by standard name (e.g., Letter or A4), or by specifying
the height and width in either mm or inches (use the radio buttons to choose which unit of
measurement to use). The initial default page size depends on your localization—in the United States,
Letter size paper is standard.

You can also choose to format your music in Landscape orientation (de-select the checkbox to get
Portrait format), and you can optionally use Two sided layout (i.e., book format, with mirror left and
right margins for even and odd pages—see below).

Page margins

The Even Page Margins and Odd Page Margins settings allow you to define the printable area of
your pages. Aside from changing the margins around the music on the page, other settings, such as
the positions of headers and footers, are calculated relative to the margins defined here.

If the "Two sided" checkbox under "Page Size" is selected, you can set margins differently for
mirroring odd and even pages. Otherwise, only one set of margins can be modified, but will apply to all
pages.

To display page margins in your score on screen (though not in print), go to View → Show Page
Margins.

Staff space/scaling

Staff space (sp) is the size of the space between two lines of a staff (or one-quarter the size of the
full five-line staff). Since notes fit in that space, it also controls the size of note heads, and, in turn,
proportionally, the size of note stems, accidentals, clefs etc. Additionally, many other formatting
options are defined in terms of sp as a unit of measure (e.g., 5.0sp). Since changing the staff space
size has a proportional affect on almost everything, it is also sometimes called scaling.
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Note: Changing the scaling does not always change the number of systems per page, because
system distance can vary between limits set under "Min system distance" and "Max system distance"
(see Style → General... → Page).

Miscellaneous

First page number sets the number of the first page of the particular score. Page numbers below 1
won't get printed—e.g., setting the first page number to -1 would result in the first and second page
showing no page number, and page number 1 appearing on the third page.

The Apply to all Parts button is available when modifying a part, rather than the main score (see
Part extraction). If you change the page settings of one part and want the rest of the parts to have the
same settings, this button will apply the change to all parts in one go.

Do you have an unanswered question? Post it in the forum.

Breaks and spacers
Page breaks, line breaks (system breaks), section breaks, and spacers are available in the "Breaks
& Spacers" palette in the Advanced workspace. They can be applied to either a measure or a frame.

A page break applied to a measure forces the following measure to start on a new page.
A line break forces the next measure to start in a new system.

A section break forces a line break and allows you to create sections within a score (see
below).

(Note: To split an existing measure in two, see Measure operations: Split and join.)

Spacers are used to increase the space between two adjacent staves or systems. To apply a
spacer or adjust its height, see below. (Note: To adjust the space between staves score-wide,
use the style settings. Spacers are designed for local adjustments.)

Adding a break or spacer

To add a break or spacer chose one of the following options:

Select a measure or frame, then double-click a palette break or spacer symbol (for example, in
the Breaks & Spacers palette).
Drag a break or spacer symbol from a palette onto a measure or frame.
For line breaks only, click on a barline and press Return (press again to remove the line break).
For page breaks only, click on a barline and press Ctrl+Return (Mac: Cmd+Return) (press again to
remove the page break).

A break is inserted after the marked measure or frame. Blue break/spacer symbols are visible on the
screen, but do not appear on printouts.

Adjusting a spacer

To adjust the height of a spacer chose one of these options:

Double-click the spacer and drag the blue end-handle up and down.
Double-click the spacer and use the ↑ ↓ keys and/or Ctrl+↑ ↓ to move the end-handle up and
down.
Click (or double-click) on the spacer and adjust the height property in the Inspector.

Deleting a break or spacer

There are times that you may want to remove a break or spacer. To delete a break or spacer:
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1. Single click the break or spacer (it will turn into a darker blue to indicate that it is selected)
2. Press the Delete key

Section break

A section break, as the name suggests, is used to create separate sections within a score. Like a line
break, it forces the next measure or frame to begin a new system, and can also be used in
association with a page break if required.

A section break could be used, for example, to divide a piece into separate movements.

Each section can have its own measure numbering independent of the rest of the score. By default,
the first measure of a section is numbered "1" (see image below), though like the first measure of the
score itelf, the number is not displayed unless configured in the measure properties dialog. The same
dialog can be used to change the numbering according to your preference.

If you change Time signature or Key signature at the beginning of the new section, there will be no
courtesy signature at the end of the previous measure. See example below:

When you play back the score, the program adds a short pause between each section. In addition, the
first end repeat barline in a section always sends the playback cursor to the beginning of the section,
so a start repeat barline is optional.

See also

Add/Remove Line Breaks tool

Do you have an unanswered question? Post it in the forum.

Frames
A Frame is a rectangular container for empty space, text or pictures in the score. It can be one of
three types:

Horizontal: Used to create a break in a particular system. It can contain text or pictures.
Vertical: Inserted above or below a particular system. It can contain text or pictures.
Text: Inserted above or below a particular system. It can contain one item of text only.

Horizontal frame

Horizontal frames are used to create a break in a system. For example, you can:

Create a coda, with an adjustable gap separating it from the rest of the score (as in the example
below).

Create an offset at the beginning of the score, where there is no staff name to perform the same
function.
Create an adjustable right margin at the end of a system.
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Create space for some text or image(s).
Create a space between a 'historical incipit' and the beginning of the modern edition.

To Insert or append a horizontal frame, see Create a Frame.

The height of the frame is equal to the height of the parent system, and its width can be adjusted by
double-clicking on the frame and dragging the handle back and forth. Single clicking on the frame
allows you to edit several parameters in the Inspector:

Left Gap: ?
Right Gap: ?
Width: Adjusts the width of the frame.

(Note: It is possible to create a 'Negative-width' horizontal frame, by dragging the edit-handle back
over the left border of the frame. But this is not a standard feature and once editing is finished you
cannot reselect the frame).

To add one or more text objects or images to the frame, right-click on it and select Add → Text or Add →
Image.

A horizontal frame can also be inserted in a Vertical frame or Text frame by right clicking on the frame
and selecting Add → Insert Horizontal Frame. It is automatically left-aligned and fills the entire
vertical frame. Double clicking the frame allows you to adjust the width using the editing handle. To
right align, drag it across the vertical frame using the mouse, having made it smaller first.

Vertical frame

Vertical frames provide empty space between, before or after systems, and can contain one or more
text objects and/or images. The height is adjustable and the width equals the system width.

You can use a vertical frame to:

Create an area at the head of a score for Title/Subtitle/Composer/Lyricist text etc (see below).
Add single- or multi-column lyric text.

To Insert or append a vertical frame, see Create a Frame.

A vertical frame is automatically created at the beginning of a score – showing the title, subtitle,
composer, lyricist etc. – when you fill in the information fields provided in the New Score Wizard.

If the score does not have a vertical frame at the beginning, one is automatically created when you
right-click on an empty space and select Text → Title/Subtitle/Composer/Lyricist.

Selecting a frame allows you to adjust various parameters in the Inspector:
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Top Gap: Adjusts distance between frame and element above (negative values not currently
supported).
Bottom Gap: Adjusts distance between frame and element below (Negative values can be entered).
Height: Adjusts height of the frame.
Left Margin: Moves left-aligned text objects to the right.
Right Margin: Moves right-aligned text objects to the left.
Top margin: Moves top-aligned text objects downwards (see also Style → General... → Page).
Bottom Margin: Moves bottom-aligned text objects upwards (see also Style → General... → Page).

Double-clicking the vertical frame allows you to change the height property using the editing handle.
This is useful for adjusting space between particular systems.

Right-clicking the frame brings up a menu allowing you to create an object within the frame: this can
be text (Text, Title, Subtitle, Composer, Lyricist, and Part name), a picture or a horizontal frame. You
can create as many objects as you like within a frame. Each object can be moved and styled
independently of the others. Text objects can be positioned inside or outside the frame boundaries.

Each text object created within the frame can be moved by left-clicking and dragging (use the Ctrl or
Shift buttons to constrain movement in the horizontal or vertical). You can also click on the text object
and make adjustments to color, visibility, horizontal offset and vertical offset in the Inspector. Right-
clicking on a text object opens a menu allowing you to apply a unique style to the text ("Text
Properties") or to alter the overall style for that class of objects ("Text Style").

Text frame

A text frame looks like a vertical frame – and shares some of its features – but is specifically designed
to allow the user to enter text quickly and easily: as soon as the frame is created the user can start
typing. Unlike the vertical frame, only one text object is allowed per frame, the height automatically
expands to fit the content and there is no height adjustment handle.

To Insert or append a text frame, see Create a Frame.

Selecting the frame (not the text object) allows you to edit various parameters in the Inspector:

Top Gap: Adjusts distance between frame and element above (negative values not currently
supported).
Bottom Gap: Adjusts distance between frame and element below (negative values can be entered).
Height: Not applicable to text frames.
Left Margin: Moves left-aligned text objects to the right.
Right Margin: Moves right-aligned text objects to the left.
Top margin: Moves top-aligned text objects downwards.
Bottom Margin: Moves bottom-aligned text upwards.

You can also click on the text object and make adjustments to color, visibility, horizontal offset and
vertical offset in the Inspector

Create a frame

Frames are inserted into or appended to the score from the Add Menu.

To insert a frame, select a measure, and make your choice from the Add → Frames menu. The frame is
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inserted before the selected measure. To append a frame to the end of the score, no measure
selection is required. Chose the desired frame to append from the Add → Frames menu.

Delete a frame

Select the frame and press Del.

Apply a break

Line, page or section breaks can be applied to frames as well as measures. Use one of two methods:

Select a frame and double-click a palette break symbol (for example, in the Breaks & Spacers
palette).
Drag a break symbol from a palette onto a frame.

See also

How to add a block of text to a score
Text Properties—put a visual frame (border) around text

External links

Page Formatting in MuseScore 1.1 - 1. Frames, Text & Line Breaks [video]

Do you have an unanswered question? Post it in the forum.

Image capture
Image capture allows to create image snippets out of scores. It can be toggled on/off with the Image

capture button, .

In image capture mode, a selection rectangle can be spawned with Shift + mouse drag.

The selection rectangle can be moved with the mouse, or resized by moving one of the eight handles.

Once you specify the bounding box of the image snippet you want to create, right-click into the
rectangle to popup the context menu:
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Saving as a PNG file results in this file:

If you save your snippet in "print mode", it will appear as a cut out of the score as it would be printed.
In "Image capture mode", the image will look like the score on your screen (including line break
markers, etc.), which are not printed (100dpi example):

See also

Image
Create an ossia with image capture

Do you have an unanswered question? Post it in the forum.

Images
You can use Images to illustrate scores, or add symbols that are not included in the standard palettes.

To add an image, drag-and-drop an image file either into a frame or onto a note or rest of the score.
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Alternatively, right-click into a frame, choose Add → Image, then pick an image from the file selector.

MuseScore supports the following image formats:

PNG (*.png)
JPEG files (*.jpg and *.jpeg)
SVG files (*.svg) (MuseScore currently does not support SVG shading, blurring, clipping or
masking.)

See also

Image capture
Custom palettes

External links

How to create an ossia with image capture

Do you have an unanswered question? Post it in the forum.

Align elements
While dragging an element:

Press Ctrl to constrain movement to the horizontal only.
Press Shift to constrain movement to the vertical only.

Snap to grid

Snap to grid is a feature which allows you to drag an element in precise steps—useful for exact
positioning.

To enable snap to grid, select an element and click one or both of the snap to grid buttons, located to
the right of the horizontal and vertical offset fields in the Inspector. You can then drag the element in
steps equal to the grid spacing. The default value is 0.5 sp.

To change the grid spacing:

1. Right-click on any of the snap to grid buttons in the Inspector, and select Configure Grid.
2. Set values for the horizontal and vertical grid spacing as required. Note that this is a fractional

setting.

Do you have an unanswered question? Post it in the forum.

Advanced topics
Accessibility

Introduction

This document is written for blind and visually impaired users of MuseScore 2.0. It is not intended to
provide a full description of all of the features of MuseScore; you should read this in conjunction with
the regular MuseScore documentation.

MuseScore comes with support for the free and open source NVDA screen reader for Windows. The
features in this document have been tested on Windows with NVDA. There is no support at the
moment for other screen readers such as Jaws for Windows, or VoiceOver for macOS, which may
work differently, or not at all.
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At this point in time, MuseScore 2.0 is mostly accessible as a score reader, not so much as a score
editor. This document will focus on the score reading features, with only a brief description of score
editing.

Initial setup

When you run MuseScore for the first time, you may want to permanently disable the Start Center
window. To do so, go close the Start Center window first, then the Edit menu (Alt+E), choose
Preferences, and in there, uncheck Show Start Center. Save and close the preferences window.

Finding your way around

The user interface in MuseScore works much like other notation programs, or other document-
oriented programs in general. It has a single main document window in which you can work with a
score. MuseScore supports multiple document tabs within this window. It also supports a split-screen
view to let you work with two documents at once, and you can have multiple tabs in each window.
In addition to the score window, MuseScore has a menu bar that you can access via the shortcuts for
the individual menus:

File: Alt+F
Edit: Alt+E
View: Alt+V
Add: Alt+A
Notes: Alt+N
Layout: Alt+L
Style: Alt+S
Plugins: Alt+P
Help: Alt+H

Of these, only the File menu is of much interest when using MuseScore as a score reader. Once
opening a menu, it may take several presses of the Up or Down keys before everything is read properly.

There are also a number of toolbars, palettes, and subwindows within MuseScore, and you can cycle
through the controls in these using Tab (or Shift+Tab to move backwards through this same cycle).
When you first start MuseScore, or load a score, focus should be in the main score window. Pressing
Tab takes you to a toolbar containing a series of buttons for operations like New, Open, Play, and so
forth. Tab will skip any buttons that aren't currently active. The names and shortcuts (where
applicable) for these buttons should be read by your screen reader.

Once you have cycled through the buttons on the toolbar, the next window Tab will visit is the Palette.
This would be used to add various elements to a score, but it is not currently accessible except for two
buttons that are visited by Tab: a drop down to select between different workspaces (a saved
arrangement of palettes), and a button to create a new workspace.

If you have opened one of the optional windows, such as the Inspector, or the Selection Filter, the Tab
key will also visit these. You can close windows you do not need by going to the View menu and
making sure none of the first set of checkboxes are selected (the windows that appear before the
Zoom settings). By default, only the Palette, Navigator and MuseScore Connect should be selected,
and the latter two are not included in the Tab order.

To return focus to the score window after visiting the toolbar, or a subwindow, press Esc. This also
clears any selection you may have made in the score window.

The score window

When you first start MuseScore 2.0, an empty example score entitled “My First Score” is loaded by
default. If you wish to experiment with editing features, this would be a good place to begin.
Otherwise, you will probably want to start by loading a score. MuseScore uses the standard shortcuts
to access system commands like Ctrl+O (Mac: Cmd+O) to open a file, Ctrl+S (Mac: Cmd+S) to save,
Ctrl+W (Mac: Cmd+W) to close, etc.

If you press Ctrl+O (Mac: Cmd+O) to load a score, you are presented with a fairly standard file dialog.
MuseScore can open scores in its own format (MSCZ or MSCX) as well as import scores in the
standard MusicXML format, in MIDI format, or from a few other programs such as Guitar Pro, Capella,
and Band-in-a-Box. Once you have loaded a score, it is displayed in a new tab within the score
window. You can move between the tabs in the score window using Ctrl+Tab (does not apply for
Mac).
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There are a few interesting things you can do with a loaded score besides reading it note by note. You
can press Space to have MuseScore play the score for you. You can use File / Export to convert to
another format, including PDF, PNG, WAV, MP3, MIDI, MusicXML, etc. And of course, you can print it
via File / Print or Ctrl+P (Mac: Cmd+P).

If a score contains multiple instruments, it may already have linked parts generated. Linked parts are
presented as part tabs within score tabs, but currently, there is no way to navigate these part tabs
using the keyboard. The parts would not normally contain information different from the score; they
would just be displayed differently (each part on its own page). If a score does not already have parts
generated, you can do so through File / Parts, and that dialog is accessible. If you wish to print the
parts, you can work around the inability of accessing part tabs individually by using the File / Export
Parts dialog, which automatically exports PDF’s (or other formats) for all parts in one step.

Score reading

When you first load a score, the score window has the keyboard focus, but there will be nothing
selected. The first step to reading a score is to select something, and the most natural place to begin
is with the first element of the score. Ctrl+Home (Mac: Cmd+Home) will do this. You will probably also
want to use this, should you ever clear your selection by pressing Esc.

As you navigate between elements, your screen reader should give the name of the selected element
(most likely the clef at the beginning of the top staff of your score). You will hear it read the name of
the element (for example, “Treble clef”) and also give position information (for example, “Measure 1;
Beat 1; Staff 1”). The amount of information read is not currently customizable, but we tried to place
the most important first so you can quickly move on to the next element before it has finished reading,
or just ignore the rest of what is read. Pressing Shift currently interrupts the reading, which might also
be useful.

Most navigation in MuseScore is centered around notes and rests only – it will skip clefs, key
signatures, time signatures, barlines, and other elements. So if you just use the standard Right and
Left keys to move through your score, you will only hear about notes and rests (and the elements
attached to them). However, there are two special navigation commands that you will find useful to
gain a more complete summarization of the score:

Next element: Ctrl+Alt+Shift+Right (Mac: Cmd+Option+Shift+Right)
Previous element: Ctrl+Alt+Shift+Left (Mac: Cmd+Option+Shift+Left

These commands include clefs and other elements that the other navigation commands skip, and also
navigate through all voices within the current staff, whereas other navigation commands such as Right
and Left only navigate through the currently selected voice until you explicitly change voices. For
instance, if you are on a quarter note on beat 1 of measure 1, and there are two voices in that
measure, then pressing Right will move on to the next note of voice 1—which will be on beat 2—
whereas pressing Ctrl+Alt+Shift+Right (Mac: Cmd+Option+Shift+Right) will stay on beat 1 but move
to the note on voice 2. Only once you have moved through all notes on the current beat on the current
staff will the shortcut move you on to the next beat. The intent is that this shortcut should be useful for
navigating through a score if you don’t already know what the contents are.

When you navigate to an element, your screen reader should read information about it. For notes and
rests, it will also read information about elements attached to them, such as lyrics, articulations, chord
symbols, etc. For the time being, there is no way to navigate directly to these elements.
One important note: Up and Down by themselves, with Shift, or with Ctrl / Cmd are not useful shortcuts
for navigation! Instead, they change the pitch of the currently selected note or notes. Be careful not to
inadvertently edit a score you are trying to read. Up and Down should only be used with Alt/Option if
your intent is navigation only. See the list of navigation shortcuts below.

Moving forwards or backwards in time

The following shortcuts are useful for moving “horizontally” through a score:

Next element: Ctrl+Alt+Shift+Right
Previous element: Ctrl+Alt+Shift+Left
Next chord or rest: Right
Previous chord or rest: Left
Next measure: Ctrl+Right
Previous measure: Ctrl+Left
Go to measure: Ctrl+F
First element: Ctrl+Home
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Last element: Ctrl+End

Moving between notes at a given point in time

The following shortcuts are useful for moving “vertically” through a score:

Next element: Ctrl+Alt+Shift+Right

Previous element: Ctrl+Alt+Shift+Left
Next higher note in voice, previous voice, or staff above: Alt+Up
Next lower note in voice, next voice, or staff below: Alt+Down
Top note in chord: Ctrl+Alt+Up
Bottom note in chord: Ctrl+Alt+Down

The Alt+Up and Alt+Down commands are similar to the Ctrl+Alt+Shift+Right and
Ctrl+Alt+Shift+Left commands in that they are designed to help you discover the content of a score.
You do not need to know how many notes are in a chord, how many voices are in a staff, or how
many staves are in a score in order to move vertically through the score using these commands.

Filtering score reading

Excluding certain elements like lyrics, or chord names while reading the score is possible by using the
Selection filter (F6). Uncheck those elements you don't want to read.

Score playback

The Space bar serves both to start and stop playback. Playback will start with the currently selected
note if one is selected; where playback was last stopped if no note is selected; or at the beginning of
the score on first playback.

MuseScore supports looped playback so you can repeat a section of a piece for practice purposes. To
set the “in” and “out” points for the loop playback via the Play Panel (F11):

1. First select the note in the score window where the loop should start
2. Go to the Play Panel and press the Set loop In position toggle button
3. Back to the score window, navigate to the note where you want the loop to end
4. Switch again to Play Panel, and press the Set loop Out position toggle button
5. To enable or disable the loop, press the Loop Playback toggle button

You can also control the loop playback and control other playback parameters, such as overriding the
basic tempo of a score, using the View / Play Panel (F11).

Score editing

Score editing is currently not very accessible – too many score elements require intervention of the
mouse in order to place objects onto a score. Additionally, visual reference and manual adjustment of
the position of various elements is sometimes necessary due to MuseScore's limited support for
conflict avoidance of elements.

In contrast, MuseScore does often provide ample default, and a platform to experiment with the basics
of note input.
To enter note input mode, first navigate to the measure in which you would like to enter notes, then
press “N”. Almost everything about note input is designed to be keyboard accessible, and the standard
documentation should be good to help you through the process. Bear in mind that MuseScore can
either be in note input or normal mode, and it won’t always be clear which mode of these you are in.
When in doubt, press Esc. If you were in note input mode, this will take you out. If you were in normal
mode, you will stay there, although you will also lose your selection.

Customization

You can customize the keyboard shortcuts using Edit / Preferences / Shortcuts. At some point, we
may provide a set of special accessibility-optimized shortcuts and/or a way of saving and loading sets
of shortcut definitions.

Do you have an unanswered question? Post it in the forum.
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Albums
The Album Manager allows you to prepare a list of multiple scores and save the list as an album file
("*.album"), print all the scores as one long print job with consistent page numbers, or even join the
scores into a single new MSCZ score. This is ideal for preparing an exercise book or combining
multiple movements of an orchestration.

To open the Album Manager, go to File → Album...

Create album

1. To create a new album, click the New button. Fill in a title in the "Album Name:" box at the top.

2. To add scores to the album, click Add Score. A file selection dialog will appear and let you
choose one or multiple scores from your file system. Click OK.

3. The scores you add will appear in a list in the Album Manager. You can rearrange their order by
selecting a score and clicking the Up or Down button.

Load album

If you have previously created an album, you can open it through the Album Manager by clicking the
Load button. A file selection dialog will appear to let you load the .album file from your file system.

Print album

To print an album as if it were a single document, click Print Album. The scores loaded into the Album
Manager are printed in the order they are listed in with the correct page numbers, ignoring the page
number offset values in Layout → Page Settings... → First page number for all but the first score. As
the album is printed in one print job, double-sided printing (duplex printing) also works as expected.

Join scores

To combine multiple scores into a single .mscz file, click Join Scores. The scores are combined in the
selected order into one single score. If not already present, line- and section breaks are added to the
last measure or frame of each score in the combined file.
All style settings are taken from the first score, different style settings from subsequent score are
ignored.

All the scores should have the same number of parts and staves for this to work correctly, ideally with
the same instruments in the same order. If the scores have the same total number of instruments but
not the same ones, or not in the same order, then the instrument names from the first score will
overwrite ones from subsequent scores. If some of the scores have fewer instruments than the first
score, then empty staves will be created for those sections. Any part or staff that is not present in
the first score will be lost in the joined score.

Save album
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Upon clicking the Close button, you will be prompted to save your album as a .album file. This file is
not the same as a joined score; it simply consists of the list of scores. Album files can be loaded into
the Album Manager as described above.

Do you have an unanswered question? Post it in the forum.

Cross-staff notation
In piano scores, it is common to use both staves (bass and treble clef) to write a musical phrase.

This can be entered in MuseScore as follows:

Enter all notes in one staff:

Ctrl+Shift+↓ moves the selected note, or chord to the next staff (Mac: ⌘+Shift+↓.)

If you want to move the beam, double-click the beam to show the handles. Drag the handles to adjust
the layout.

See also

Barline for cross-staff barlines (i.e. grand staff)
Edit mode

Do you have an unanswered question? Post it in the forum.

Early music features
MuseScore 2 offers several specialized functions to create engravings of early music (particularly
medieval and renaissance) akin to commercial editions from the 20th century onwards.

Unbarred notation

Since most renaissance music was unbarred (i.e. not divided into measures), having long notes
divided up and tied over barlines significantly changes the look of the score. Recognizing large
melodic lines and repeated motives could become more difficult. Therefore, MuseScore provides an
experimental display method where the note values stay intact. This method can be activated by
ticking a checkbox in the Score section of the Style dialog, found under Style → General...
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Apply and the display is adjusted immediately.

Original notation (De Profundis Clamavi for 4 voices by Nicolas Champion)

Before style Change

After style Change

Note that the feature is still experimental and may contain bugs. The longest supported note value is
the longa (a dotted longa is still broken up and tied over).
To get rid of the barlines, just untick the “Show barlines” box in the Staff properties dialog. However,
there is another option.
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Mensurstrich

Since a complete lack of barlines could make performing the music more difficult for current
musicians, many modern engravers settled on a compromise called Mensurstrich, where barlines are
drawn between, but not across, staves. This is also possible now: double click a barline, drag the
lower end to the top of the staff below it, and drag the upper end to the bottom of the current staff. Do
this in precision mode (hold down Shift). Then deselect the barline and the changes should be
applied to the entire staff.

It may be easier to use the Inspector to change the numbers manually. To open the Inspector, press
F8 and select a barline. The correct values are:

 Default Mensurstrich
Spanned
staves 1 2

Span from 0 8
Span to 8 0

You may want to set the barlines back to the default values at the end of the score or a section, but
remember to hold down Ctrl, or else the entire staff will be reset.

Ambitus

Before there was the concept of an absolute pitch, performers were required to transpose vocal music
to a singable range for their ensemble on the fly. To aid them, an ambitus was sometimes included,
marking the entire range of a voice at the beginning of the piece. The ambitus is located in the palette
at the bottom of the Lines section, from there drag it onto a clef. It will automatically detect the range.

The ambitus will consider all measures of music up until the next section break, beyond which a new
ambitus may be applied. It can be adjusted manually or automatically in the Inspector. First select the
ambitus to adjust. For manual adjustments edit the top and bottom note values. For automatic
adjustment click the Update Range button in the inspector.

Mensural time signatures

In the mensural notation system, time signatures did not define the length of a measure, but the length
of breves and semibreves. MuseScore supports mensural time symbols as a display method in the
Time signature properties dialog rather than as symbols, but they are just for show, as the proportion
of e.g. half notes per whole notes cannot be modified.
One way to make use of these symbols is to replicate when composers of the renaissance had
multiple voices in different time signatures simultaneously without using tuplets. Edit the time
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signature on a per-staff basis, as long as the beginning and end of a measure in all staves match up. If
they do not, then consider increasing the size of the measures to the lowest common denominator.

De Profundis Clamavi for 5 voices by Josquin Des Prez

See also

Measure Operations: Split and join

Do you have an unanswered question? Post it in the forum.

Figured bass

Adding a new figured bass indication

1. Select the note to which the figured bass applies
2. Press the Figured Bass shortcut (default Ctrl+G; can be changed in Preferences)
3. Enter the text in the editor 'blue box' as required (see below)
4. Press Space to move to the next note ready for another figured bass indication (or click outside

the editor box to exit it)

With Space, the editor advances to the next note, or rest of the staff to which figured bass is being
added. To move to a point in between, or to extend a figured bass group for a longer duration, see
below Group Duration.

Tab advances the editing box to the beginning of the next measure.

Shift+Space moves the editing box to the previous staff note or rest.

Shift+Tab moves the editing box to the beginning of the previous measure.

Text format

Digits

Digits are entered directly. Groups of several digits stacked one above the other are also entered
directly in a single text, stacking them with Enter:
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Accidentals

Accidentals can be entered using regular keys:

To enter: type:
double flat bb
flat b
natural h
sharp #
double sharp ##

These characters will automatically turn into the proper signs when you leave the editor. Accidentals
can be entered before, or after a digit (and of course, in place of a digit, for altered thirds), according to
the required style; both styles are properly aligned, with the accidental 'hanging' at the left, or the right.

Combined shapes

Slashed digits or digits with a cross can be entered by adding \, / or + after the digit (combining
suffixes); the proper combined shape will be substituted when leaving the editor:

The built-in font can manage combination equivalence, favoring the more common substitution:

1+, 2+, 3+, 4+ result in  (or )

and 5\, 6\, 7\, 8\, 9\ result in  (or )

Please remember that / can only by combined with 5; any other 'slashed' figure is rendered with a
question mark.

+ can also be used before a digit; in this case it is not combined, but it is properly aligned ('+' hanging
at the left side).
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Parentheses

Open and closed parentheses, both round: '(', ')' and square: '[', ']', can be inserted before and after
accidentals, before and after a digit, before and after a continuation line; added parentheses will not
disturb the proper alignment of the main character.

Notes:

The editor does not check that parentheses, open and closed, round or square, are properly
balanced.
Several parentheses in a row are non-syntactical and prevent proper recognition of the entered
text.
A parenthesis between a digit and a combining suffix ('+', '\', '/') is accepted, but prevents shape
combination.

Continuation lines

Continuation lines are input by adding an '_' (underscore) at the end of the line. Each digit of a group
can have its own continuation line:

Continuation lines are drawn for the whole duration of the figured bass group (but currently are not
continued on following systems, the same as for lyric continuation lines).

'Extended' continuation lines

Occasionally, a continuation line has to connect with the continuation line of a following group, when a
chord degree has to be kept across two groups. Examples (both from J. Boismortier, Pièces de viole,
op. 31, Paris 1730):

In the first case, each group has its own continuation line; in the second, the continuation line of the
first group is carried 'into' the second.

This can be obtained by entering several (two or more) underscores "__" at the end of the text line of
the first group.

Duration

Each figured bass group has a duration, which is indicated by a light gray line above it (of course, this
line is for information only and it is not printed or exported to PDF).

Initially, a group has the same duration of the note to which it is attached. A different duration may be
required to fit several groups under a single note or to extend a group to span several notes.

To achieve this, the key combinations listed below can be used; each of them

advances the editing box by the indicated duration
AND
sets the duration of the previous group up to the new editing box position.

Pressing several of them in sequence without entering any figured bass text repeatedly extends the
previous group.

Type: to get:
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Ctrl+1 1/64
Ctrl+2 1/32
Ctrl+3 1/16
Ctrl+4 1/8 (quaver)
Ctrl+5 1/4 (crochet)
Ctrl+6 half note (minim)

Ctrl+7
whole note
(semibreve)

Ctrl+8 2 whole notes (breve)

Type: to get:

(The digits are the same as are used to set the note durations)

Setting the exact figured bass group duration is only mandatory in two cases:

1. When several groups are fit under a single staff note (there is no other way).
2. When continuation lines are used, as line length depends on the group duration.

However, it is a good practice to always set the duration to the intended value for the purposes of
plugins and MusicXML.

Editing existing figured basses

To edit a figured bass indication already entered:

Select it, or the note it belongs to and press the same Figured Bass shortcut used to create a
new one
or
Double-click it

The usual text editor box will open with the text converted back to plain characters ('b', '#' and 'h' for
accidentals, separate combining suffixes, underscores, etc.) for simpler editing.

Once done, press Space to move to a next note, or click outside the editor box to exit it, as for newly
created figured basses.

Style

The Style → General... menu command allows to configure how figured bass is rendered. Select
"Figured Bass" in the list on the left side to display the following dialogue box:
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The Font drop list contains all the fonts which have been configured for figured bass. A standard
installation contains only one font, "MuseScore Figured Bass", which is also the default font.

The Size is the size of the font (in points). It is linked to the spatium value: for the default spatium, the
entered value is used; for smaller or larger spatium values, a size value proportionally smaller or larger
is used.

Vertical Position is the distance (in spatia) from the top of the staff to the top margin of the figured
bass text. Negative values go up (figured bass above the staff) and positive values go down (figured
bass below the staff: a value greater than 4 is needed to step over the staff itself).

Line Height is the distance between the base line of each figured bass line; it is expressed in percent
of the font size.

The following picture visualizes each numeric parameter:

The Top / Bottom radio buttons select the vertical alignment: with Top, the top line of each group is
aligned with the main vertical position and the group 'hangs' from it (this is normally used with figured
bass notation and is the default); with Bottom, the bottom line is aligned with the main vertical position
and the group 'sits' on it (this is sometimes used in some kinds of harmonic analysis notations):
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The Modern / Historic radio buttons select the typographic style of the combined shapes. The
difference between the two styles is shown below:

Proper syntax

For the relevant substitutions and shape combinations to take effect and for proper alignment, the
figured bass mechanism expects input texts to follow some rules (which are in any case, the rules for
a syntactical figured bass indication):

There can be only one accidental (before or after), or only one combining suffix per figure;
There cannot be both an accidental and a combining suffix;
There can be an accidental without a digit (altered third), but not a combining suffix without a
digit.
Any other character not listed above is not expected.

If a text entered does not follow these rules, it will not be processed: it will be stored and displayed as
it is, without any layout.

Summary of keys

Type: to get:
Ctrl+G Adds a new figured bass group to the selected note.
Space Advances the editing box to the next note.
Shift+Space Moves the editing box to the previous note.
Tab Advances the editing box to the next measure.
Shift+Tab Moves the editing box to the previous measure.
Ctrl+1 Advances the editing box by 1/64, setting the duration of the previous group.
Ctrl+2 Advances the editing box by 1/32, setting the duration of the previous group.
Ctrl+3 Advances the editing box by 1/16, setting the duration of the previous group.
Ctrl+4 Advances the editing box by 1/8 (quaver), setting the duration of the previous group.
Ctrl+5 Advances the editing box by 1/4 (crochet), setting the duration of the previous group.

Ctrl+6
Advances the editing box by a half note (minim), setting the duration of the previous
group.

Ctrl+7
Advances the editing box by a whole note (semibreve), setting the duration of the
previous group.

Ctrl+8
Advances the editing box by two whole notes (breve), setting the duration of the
previous group.

Ctrl+Space Enters an actual space; useful when figure appears "on the second line" (e.g., 5 4 -> 3).
B B Enters a double flat.

B Enters a flat.
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H Enters a natural.
# Enters a sharp.
# # Enters a double sharp.
_ Enters a continuation line.
_ _ Enters an extended continuation line.

Type: to get:

Do you have an unanswered question? Post it in the forum.

File formats
MuseScore supports a wide variety of file formats, which allows you to share and publish scores in the
format that best meets your needs.

You can import files via File → Open... and export via File → Export.... For more details, see
Save/Export/Print.

In addition to the formats detailed below, you can save and share your scores on the web at
MuseScore.com via File → Save Online.... See Share scores online.

A note about fonts

MuseScore does not embed text fonts in saved or exported files, except for the FreeSerif and
FreeSans font families. If you want to share a MuseScore file with other parties, make sure you are
using either of these fonts for your text, or a font that the other parties have installed too. If a system
does not have the fonts specified in the file, MuseScore will use a fallback, which may cause your
score to appear differently.

MuseScore native format

These are the formats used by File → Save or the  button or shortcut (Ctrl+S) and
File → Save as... dialog.

MuseScore format (*.mscz)

MSCZ is the standard MuseScore file format and recommended for most uses. A score saved in this
format takes up very little disk space, but preserves all the necessary information. The format is a ZIP-
compressed version of .mscx files and includes any images.

Uncompressed MuseScore format (*.mscx)

MSCX is the uncompressed version of the MuseScore file format. A score saved in this format will
retain all information, except images. It is recommended for when manually editing the file format
(using a text editor).

MuseScore backup file (.*.mscz,) or (.*.mscx,)

Backup files are created automatically and saved in the same folder as your normal MuseScore file.
The backup copy contains the previously saved version of the MuseScore file and can be important if
your normal copy becomes corrupted, or for looking at an older version of the score.

The backup file adds a period to the beginning of the file name (.) and a comma (,) to the end (e.g. if
your normal file is called "untitled.mscz", the backup copy will be ".untitled.mscz,"), and the period
and comma need to be removed from the name in order to open the backup file in MuseScore. As it is
stored in the same folder as your normal MuseScore file, you may also need to give it a unique name
(e.g. changing ".untitled.mscz," to "untitled-backup1.mscz").

Note: In order to see the MuseScore backup files, you may need to change your system settings to
"Show hidden files". See also How to recover a backup copy of a score (MuseScore 2.x).

Graphics—view and print (export only)

MuseScore can export (via the File → Export... command) to the following formats that contain a
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visual representation of the score, but cannot be edited or played back:

PDF (*.pdf)

Portable Document Format (PDF) is ideal for sharing your sheet music with others who do not need to
edit the content. Most users have a PDF viewer on their computer, so extra software won't usually be
required to see it.

PNG (*.png)

Portable Network Graphics (PNG) is a bitmap image format widely supported by software on
Windows, Mac OS, and Linux. The image format is particularly popular on the web. Multi-page scores
export a PNG file for every page. MuseScore creates images as they would appear on the printed
page. On the export tab in Edit → Preferences... (Mac: MuseScore → Preferences...), you can set
the resolution and whether to use transparent background. Note: If you want to create images that
show only parts of the score (with or without screen-only items such as frame boxes, invisible notes,
and out-of-range note colors), use Image capture.

SVG (*.svg)

Scalable Vector Graphics (SVG) can be opened by most web browsers (except Internet Explorer
before version 9) and most vector graphics software. However, most SVG software does not support
embedded fonts, so the appropriate MuseScore fonts must be installed to view these files correctly.

Audio—listen (export only)

MuseScore can export (via the File → Export... command) to the following formats that contain a
synthesized audio recording of the score:

WAV audio (*.wav)

WAV (Waveform Audio Format) is an uncompressed sound format. This was developed by Microsoft
and IBM, and is widely supported by software for Windows, OS X, and Linux. It is an ideal format for
use when creating CDs, as full sound quality is preserved. However, the large file sizes make it
difficult to share via email or the web.

FLAC audio (*.flac)

Free Lossless Audio Codec (FLAC) is compressed audio format. FLAC files are approximately half
the size of uncompressed audio and just as good quality. Windows and OS X do not have built-in
support for FLAC, but software such as the free and open source VLC media player can play FLAC
files on any operating system.

Ogg Vorbis (*.ogg)

Ogg Vorbis (external link) is intended as a patent-free replacement for the popular MP3 audio format
(which MuseScore also supports—see below). Like MP3, Ogg Vorbis files are relatively small (often a
tenth of uncompressed audio), but some sound quality is lost. Windows and OS X do not have built-in
support for Ogg Vorbis. However, software such as VLC media player and Firefox can play Ogg files
on any operating system.

MP3 (*.mp3)

MP3 files are relatively small (often a tenth of uncompressed audio), but some sound quality is lost.
To be able to create MP3 files, an additional library, lame_enc.dll (Windows) or libmp3lame.dylib
(Mac), needs to be installed. MuseScore will prompt you for its location. You can get it at
http://lame.buanzo.org/.

Some Mac users may find MuseScore encounters an error loading the MP3 library, possibly due to
that library being a 32-bit library. A 64-bit build that will work with MuseScore is available from
http://thalictrum.com/en/products/lame (note that it is necessary to rename the file to libmp3lame.dylib
for MuseScore to recognize it).

Share with other music software
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The following are musical score formats (like MuseScore's native format, MSCZ), which allow you to
import files made with other music notation programs or export files that you can open with other
music notation programs.

MusicXML (*.xml)

MusicXML is the universal standard for sheet music. It is the recommended format for sharing sheet
music between different scorewriters, including MuseScore, Sibelius, Finale, and more than 100
others.

Compressed MusicXML (*.mxl)

Compressed MusicXML creates smaller files than regular MusicXML. This is a newer standard and
isn't as widely supported by older scorewriters, but MuseScore has full import and export support.

MIDI (*.mid, *.midi, *.kar)

Musical Instrument Digital Interface (MIDI) (external link) is a format widely supported by sequencers
and music notation software.

MIDI files are designed for playback purposes and do not contain score layout information about
formatting, pitch spelling, voicing, ornaments, articulations, repeats, or key signatures, among
other things. To share files between different music notation software, MusicXML is
recommended instead. If you are only interested in playback, use MIDI.

MuseData (*.md) (import only)

MuseData is a format developed by Walter B. Hewlett beginning in 1983 as an early means of sharing
music notation between software. It has since been eclipsed by MusicXML, but several thousand
scores in this format are still available online.

Capella (*.cap, *.capx) (import only)

CAP and CAPX files are created by the score writer, Capella. MuseScore imports version 2000 (3.0)
or later fairly accurately (2.x doesn't work, while the *.all format from 1.x versions is not supported at
all).

Bagpipe Music Writer (*.bww) (import only)

BWW files are created by the niche score writer, Bagpipe Music Writer.

BB (*.mgu, *.MGU, *.sgu, *.SGU) (import only)

BB files are created by the music arranging software, Band-in-a-Box. MuseScore's support is currently
experimental.

Overture (*.ove) (import only)

OVE files are created by the score writer Overture. This format is mainly popular in Chinese-language
environments, such as Mainland China, Hong Kong, and Taiwan. MuseScore's support is currently
experimental.

Guitar Pro (*.GTP, *.GP3, *.GP4, *.GP5, *.GPX) (import only)

GP files are created by Guitar Pro.

See also

Save/Export/Print
Recovered files

External links {external-links}
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How to recover a backup copy of a score

Do you have an unanswered question? Post it in the forum.

Fretboard diagrams
Musescore allows you to create fretboard diagrams (also known as chord diagrams) for any fretted
string instrument. You will find diagrams for the most common guitar chords (major, minor and
seventh) already provided in the Fretboard Diagrams palette in the Advanced workspace.

You can customize any fretboard diagram to your liking, and optionally add it back to a custom palette
for future use.

Add a fretboard diagram

To add a fretboard diagram to the score, open a palette containing a fretboard diagram (it could be the
default Fretboard Diagrams palette in the Advanced workspace, or a custom palette) and either:

Select a note in voice 1 and double-click the fretboard diagram.
Drag and drop the fretboard diagram into position on the score.

Edit fretboard (chord) diagram

1. Right-click on the diagram and select Fretboard Diagram Properties....
2. Adjust the number of instrument strings, using the "Strings" spin box at the bottom left of the

window.
3. Adjust the fret position number using the scroll bar on the right-hand side.
4. Adjust how many frets to display (heightwise) using the "Frets" spin-box at the bottom right of

the window.
5. To place a dot on a string fret, click on that fret. To remove the dot, click on the fret again.
6. Click above the lowest fret to toggle a string between:

Open string (o),
mute/unplayed string (x)
Off.

7. To create a barre or partial barre, first make sure the desired fret position is clear of dots. Then
click on a fret while holding Shift (see "step 2" below). Delete the barre by shift-clicking again on
the same fret. Note: Only one barre can be applied per diagram.

So, for example, to create a full-barre F# chord, from a C chord:

1. Place the C fretboard diagram on the score, right-click on it to get the Fretboard Diagram
Properties window, then click on the relevant fret positions to establish the fingering dots.

2. Set "Frets" to "4" and fret number (right-hand scroll bar) to "2." The diagram should now look like
this:
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3. Create the barre by using Shift and click on the second fret of the 6th string. Click "OK" to exit
and you should get this:

The same principle applies if you want a partial barré. For example, the partial barré in an A7
chord is created by pressing Shift, then clicking on the 4th string, second fret:

Adjust position, size, color

The size ("Scale"), color and position of a fretboard diagram can be changed by clicking on it and
altering the relevant values in the Inspector.

Position can also be adjusted more directly in Edit mode:

1. Double-click on the diagram (or click on it and press Ctrl+E (Mac: Cmd+E) , or right-click on the
symbol and select "Edit element").

2. Press arrow keys for fine positioning (0.1 sp at a time); or press Ctrl+Arrow (Mac: Cmd+Arrow) for
larger adjustments (1 sp at a time).

Fretboard diagram style

Some default properties of fretboard diagrams (barre thickness, vertical position, size etc.) can be
adjusted via Style → General… → Chord Symbols, Fretboard Diagrams. Any changes made here affect
all existing diagrams, as well as those applied subsequently.

Do you have an unanswered question? Post it in the forum.

Master palette
The Master Palette enables you to access all the possible elements that could be added to custom
palettes, and, in the case of Time Signatures and Key Signatures, make your own.

Go to View → Master Palette or use the shortcut Shift+F9 (Mac: fn+Shift+F9).

185

https://musescore.org/en/handbook/inspector-and-object-properties
https://musescore.org/en/handbook/edit-mode
https://musescore.org/en/handbook/layout-and-formatting#style-edit-general-style-chords-fretboard
https://musescore.org/en/forum


Hovering over an item with the mouse shows a tool tip (a short definition in black on yellow
background).

Symbols

The Symbols section of the Master Palette is a large repository of hundreds of musical symbols in
addition to those found in the default palettes. You can open it from the Master Palette, or directly from
the score by using the shortcut Z.

Find a symbol
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The symbols are listed under their respective musical font types: use the font menu on the bottom
right of the box to specify Emmentaler, Gonville or Bravura. You can search for a particular symbol by
entering a keyword in the search box.

Apply a symbol

Symbols are applied to the score by dragging and dropping, or by selecting a note or rest and double-
clicking the symbol. The position can then be adjusted by dragging or by changing the horizontal /
vertical offsets in the Inspector. Color and visibility can also be adjusted in the Inspector.

Note: Elements from the Symbols section do not follow any positioning rules (in many cases unlike
identical elements from other sections of the Master Palette), nor do they affect score playback.

Connect symbols

Elements from the Symbols section can be connected to each other on the score page, so that they
can be moved as one unit:

1. Apply first symbol to the score. Adjust position as required.
2. Double click, or drag-and-drop, a second element onto the first symbol. Adjust position as

required.

Drag the first element and the attached element will follow.

See also

Palettes

Do you have an unanswered question? Post it in the forum.

Noteheads
A range of alternative noteheads – in addition to the "normal" – can be found in the Note Heads
palette of the advanced workspace and via the Inspector (see Change notehead group, below).

Note: The design of the notehead may vary depending on the music font selected (Emmentaler,
Gonville or Bravura). Those in the palette are displayed as half notes in Bravura font.

Notehead groups

MuseScore supports a number of notehead styles:

Normal: A standard notehead.
Crosshead (Ghost note): Used in percussion notation to represent cymbals. It also indicates
muted and/or percussive effects in stringed instruments such as the guitar.
Diamond: Used to indicate harmonic notes in instruments such as the guitar, violin etc.
Slash: Used to notate rhythmic values.
Triangle: Used in percussion notation.
Shape notes: Do, Re, Mi, Fa, Sol, La, Ti.
Circle cross: Used in percussion notation.
Alternative Brevis: Used in early music notation.
Brackets (Parentheses): When applied, these go round the existing note (or accidental).

Change notehead group

To change the shape of one or more noteheads in the score, use one of the following:

Select one or more notes and double click a notehead in a palette
Drag a notehead from a palette onto a note in the score.
Select one or more notes and change the notehead in the Inspector, using the drop-down list
under Note → Head group (not supported for drum staves).

Change notehead type
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Occasionally you may need to change the apparent duration of a notehead—i.e., notehead type—
without altering its actual, underlying duration:

1. Select one or more notes.
2. Chose one of the following options from the Inspector under Note → Head type:

Auto: Automatic, i.e, apparent duration = actual duration.
Whole: Whole notehead, regardless of actual duration.
Half: Half notehead, regardless of actual duration.
Quarter: Quarter notehead, regardless of actual duration.
Breve: Breve notehead, regardless of actual duration.

Shared noteheads

When two notes of the same written pitch fall on the same beat, they are either offset – arranged side
by side – or allowed to share the same notehead (the latter is particularly common in classical and
fingerstyle guitar music).

Note: The rules governing the default behavior of such unison notes are as follows:

Unison notes in the same voice do not share noteheads.
Notes with stems in the same direction do not share noteheads.
Dotted notes do not share noteheads with undotted notes.
Black notes do not share noteheads with white notes.
Whole notes never share noteheads.

Change offset noteheads to shared

Offset noteheads can be turned into shared noteheads in one of two ways:

Make the smaller-value notehead invisible by selecting it and using the keyboard shortcut V (or
unchecking the "Visible" option in the Inspector).
Alter the notehead type of the shorter-duration note to match the longer one by switching "Head
type" in the "Note" section of the Inspector.

Remove duplicate fret marks

In certain cases, a shared notehead, when pasted to a tablature staff, may result in two separate fret
marks on adjacent strings. To correct this, make any extraneous tablature notes invisible by selecting
them and using the keyboard shortcut V (or by unchecking the "visible" option in the Inspector).

Examples of notehead sharing

1. In the first example below, the notes of voices 1 and 2 share noteheads by default, because they
are all black, undotted notes:

2. By contrast, in the next example, white notes cannot share noteheads with black notes, so are
offset to the right:
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To create a shared notehead, make the black eighth note invisible or change its head type to
match that of the white note (as explained above):

External links

Shape Notes at Wikipedia.
Ghost notes at Wikipedia.

Do you have an unanswered question? Post it in the forum.

Part extraction
If you have written a full ensemble score, MuseScore can create sheet music that shows only the
individual part for each musician in the ensemble.

Note: In the current version of MuseScore, it is not possible to split a single staff (that contains two or
more voices) into separate parts. So, any instrument that you want to print out a separate part for also
needs to have its own staff in the full score.

Set up all parts at once

If you have an orchestral score in which each instrument should be extracted, you can create the parts
more easily:

1. Go to File → Parts...

2. Click the New All button (parts are named with the instrument name, and if needed with an
appended "-<number>")
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3. Click OK

Now you will see a tab for each part with your score.

Define specific parts

You can define the parts at any point after creating a new score. You only need to define the parts
once for each score, but you can make changes if needed. The following instructions use a string
quartet as an example, but the same principles apply for any other ensemble.

1. From the main menu, choose File → Parts...

2. In the Parts window click New to create a "part definition"

3. In the right pane, type the words you want to use for the "Part title" (this also serves for the
corresponding part of the filename when exporting)

4. Pick the instrument that you want to appear in your part by marking the relevant box in the right-
hand pane. Usually, you only want one instrument per part, but sometimes you might need a
part that includes more than one instrument (such as multiple percussion staves). MuseScore
allows you to mark as many instruments per part as you need
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5. Repeat steps two through four (above) for each part as needed

6. Once you're done, click OK to dismiss the Parts window

You have now finished setting up the parts. You do not need to do this again, unless you add or
remove an instrument from your full score.

Exporting the parts

1. Go to File → Export Parts...

2. Navigate to the place you want them to be exported to and select the file format (PDF is the
default)

3. For filename just enter whatever prefix is useful for all parts, or leave the default (the filename of
your score)

4. Click OK

This will generate files with the names "<title>" + "-" + "<part name>.<extension>". In addition, when
exporting as PDF, this will also generate "<title>" + "-Score_And_Parts.pdf".

Saving

Parts and score are "linked", which means that any change to the content in one will affect the other,
but changes to the layout will not. When you have the parts created, they are saved along with the
score (if you open the score you have tabs for the score and every part you created).
You can, however, save each part individually by selecting its tab and use File → Save As...

Do you have an unanswered question? Post it in the forum.

Plugins

Overview
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Plugins are small pieces of code that add a particular feature to MuseScore. By enabling a plugin, a
new menu option will be appended to the Plugins menu in MuseScore to accomplish a given action on
the score or a part of it.

Some plugins come pre-installed with MuseScore—see →below. You can find many more plugins in
the plugin repository. Some plugins there work with MuseScore 2; others will only work with older
versions of MuseScore, some work with either.
To tell one from the other: for MuseScore 2.0 the plugin code files have an extentsion of .qml, for older
versions it is .js.

Installation

Note that some plugins may require the installation of other components (fonts, e.g.) to work. Check
the plugin's documentation for more information.

Most plugins are provided as ZIP archives, so download the plugin's .zip file and uncompress it to one
of the directories mentioned below. If a plugin is provided directly as an (unzipped) .qml file, simply
download and place into one of these directories.

Once a plugin is installed, it needs to be enabled in the Plugin Manager in order to use it—see
→below.

Windows

MuseScore looks for pre-installed plugins in %ProgramFiles%\MuseScore 2\Plugins (or
%ProgramFiles(x86)%\MuseScore 2\Plugins for the 64-bit versions) and in
%LOCALAPPDATA%\MuseScore\MuseScore 2\plugins on Vista, Seven and 10 or C:\Documents and
Settings\USERNAME\Local Settings\Application Data\MuseScore\MuseScore 2\plugins (adjusted to
your language version) on XP.

To install new plugins, the above folders should not be used or modified. Instead you can add other
plugins to %HOMEPATH%\Documents\MuseScore2\Plugins, or specify a different folder to look for plugins in
MuseScore's Preferences.

macOS

On macOS, MuseScore looks for pre-installed plugins in the MuseScore bundle in
/Applications/MuseScore 2.app/Contents/Resources/plugins (to reveal files in the app bundle, right
click on MuseScore 2.app and choose "Show package contents") and in ~/Library/Application
Support/MuseScore/MuseScore 2/plugins.

To install new plugins, the above folders should not be used or modified. Instead you can add other
plugins to ~/Documents/MuseScore2/Plugins, or specify a different folder to look for plugins in
MuseScore's Preferences.

Linux

In Linux, MuseScore looks for plugins in /usr/share/mscore-2.0/plugins and in
~/.local/share/data/MuseScore/MuseScore 2/plugins.

To install new plugins, the above folders should not be used or modified. Instead you can add other
plugins to ~/Documents/MuseScore2/Plugins, or specify a different folder to look for plugins in
MuseScore's Preferences.

Enable/disable plugins

To be able to access the installed plugins from the Plugins menu, they need to be enabled in the
Plugin Manager:
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Create/edit/run plugins

It is possible to create new or edit existing plugins and run them via the Plugin Creator:

Here also the documentation of all available elements can be found

Plugins installed by default
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Some plugins come pre-installed with MuseScore, but they are not enabled by default. See →above
to enable plugins.

ABC Import

This plugin imports ABC text from a file or the clipboard. Internet connection is required, because it
uses an external web-service for the conversion, which uses abc2xml and gets send the ABC data,
returns MusicXML and imports that into MuseScore.

Break Every X Measures

This plugin enters line breaks in the interval you select on the selected measures or, if no measures
are selected, the entire score. It is no longer being distributed and has been replaced by Edit → Tools
→ Add/Remove Line Breaks. If you ever used an early beta version of MuseScore 2, though, you may
still see the plugin left over.

Notes → Color Notes

This demo plugin colors notes in the selected range (or the entire score), depending on their pitch. It
colors the note head of all notes in all staves and voices according to the Boomwhackers convention.
Each pitch has a different color. C and C♯ have a different color. C♯ and D♭ have the same color.
To color all the notes in black, just run that plugin again (on the same selection). You could also use
the 'Remove Notes Color' plugin for this.

Create Score

This demo plugin creates a new score. It creates a new piano score with 4 quarters C D E F. It's a
good start to learn how to make a new score and add notes from a plugin.

helloQml

This demo plugin shows some basic tasks.

Notes → Note Names

This plugin names notes in the selected range or the entire score. It displays the names of the notes
(as a staff text) as per MuseScore's language settings, for voices 1 and 3 above the staff, for voices 2
and 4 below the staff, and for chords in a comma separated list, starting with the top note.

Panel

This demo plugin creates a GUI panel.

random

Creates a random score.

random2

Creates a random score too

run

This demo plugin runs an external command. Probably this will only work on Linux.

scorelist

This test plugin iterates through the score list.

ScoreView

Demo plugin to demonstrate the use of a ScoreView
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Walk

This test plugin walks through all elements in a score

See also

Tools

Do you have an unanswered question? Post it in the forum.

Preferences
You can customize many of MuseScore's default behaviors via Edit → Preferences... (Mac:
MuseScore → Preferences...).

The Preferences dialog has multiple tabs:

Reset All Preferences to Default  will reset all preferences to the ones MuseScore had when you
installed it.

Cancel will close the dialog without applying changes.

General

Here you can define:

Your opening score
The default folder to search for/save to scores, styles, templates, plugins, SoundFonts, and
images
Your auto save timing
The languages of MuseScore (translations may be updated from here too)
The style of your MuseScore windows and size of icons
The windows to show at startup (Play Panel, Navigator, Start Center)
Note that language translation updates can also be done via Help → Resource Manager
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Canvas

Use Canvas to set your preferred color and wallpaper for the score background and paper.

Under Scroll Pages, you can choose whether to display pages of a multi-page score laid out in a
horizontal row, or scrolling in a vertical column.

Under Miscellaneous, checking Draw antialiased (on by default) makes diagonal lines and edges of
shapes look smoother (less jagged). Proximity for selecting elements controls the distance the
mouse may be from an object and still act on it. Smaller numbers require more precision, making it
harder to click on small objects. Larger numbers are less precise, making it harder not to click on
nearby objects unintentionally. Choose a comfortable working value.

Note input
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On this tab there are note input and MIDI remote control preferences. Here the following can be set:

Enter notes via MIDI
Enable playback on entering a note
Its playback duration
Color notes outside the usable pitch range
MIDI Remote Control settings

Midi Remote Control allows you to enter or leave note input mode and also choose the duration for
notes and rest directly from the MIDI keyboard as you enter notes into the score via MIDI, without
having to use the computer mouse or keyboard at the same time.
The default setting for Midi Remote Control is 'off' with the checkbox blank, and all the option buttons
below are grey. In order to set preferences it must be turned on with the MIDI keyboard connected.

To turn on Midi Remote Control click the checkbox, the current status of all Midi Remote Control Key
settings is now indicated by the coloured input option buttons:
- Green button is lit only if the MIDI key action is defined by the user.
- Red button is lit only during the preference setting process.
- By default no MIDI key actions are set and all buttons are unlit.

To enable a MIDI key operation: click the red button which lights up and stays lit until you press your
chosen MIDI key for that operation and the green button is lit permanently. Once you have defined
your key settings you can use the MIDI keyboard to control note input operations. You can verify your
key settings by observing the MuseScore Note Input panel while pressing the MIDI keys.

To temporarily deactivate Midi Remote Control: click the Midi Remote Control checkbox, it is un-ticked
and all MIDI input key action buttons are greyed. Your selections are always saved between
MuseScore sessions so you can deactivate remote control at any time without losing your settings.

IMPORTANT, at the time of writing:-
1. The Clear option turns off all the green buttons for the current MuseScore session but all the user
recorded MIDI key settings are retained and will be reloaded on the next session.
2. A MIDI key setting that is activated cannot afterwards be turned off and the green button will always
remain lit but it can be overwritten with a different MIDI key by using the red button again.
3. Unfortunately, if the same MIDI key is used accidentally for two (or more) note inputs then both (or
all) the associated green buttons stay lit but only one will work. You can fix this as in 2 above.

Score
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Score preferences include

Default instrument list files (two may be selected)
Default style for score and parts
Default zoom

I/O

Input/Output preferences enable you to set what device will be used for audio playback (e.g., built-in
speakers, USB headset, wireless, etc.), whether to use a MIDI trigger (plugged-in keyboard), and
whether to route audio output through JACK.
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Import

These settings determine how files from other sources are imported:

Using either the built in MuseScore style or a style you choose
Guitar Pro and Overture character sets
MusicXML layout options
Shortest note in MIDI files

Export
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These settings determine how MuseScore files are exported:

PNG/SVG image resolution (in DPI) and whether to use transparent background
Whether to expand repeats in exported MIDI files
Digital audio sample rate
Whether to export the layout and how to export system and page breaks to MusicXML

Shortcuts

Every action possible with MuseScore is listed, with the associated shortcut if it exists. To define a
new shortcut, select an existing entry in the list and click Define... (or just double click the entry),
then enter the new shortcut using up to four keys. You can also reset any shortcut in the list to its
default value, or clear a shortcut you select. Shortcuts listed in preferences appear next to their
associated commands in the menus.

Note: Some shortcuts, including default ones, may not work with some keyboards.

The list of shortcuts can be printed out or exported to other media (pdf etc.) using the Print button in
the bottom right of the window.

Update
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This sets whether MuseScore will check for updates at startup.

Updates may be checked manually in Help → Check for updates

See also

Keyboard shortcuts
Language settings and translation updates
Update checking

Do you have an unanswered question? Post it in the forum.

Recovered files
If MuseScore or your computer should crash, or if power is lost, a pop-up message upon restarting
MuseScore will ask if you wish to restore the previous session.

If you click No, any work from your previous session will be lost. If you click Yes, MuseScore will
attempt to recover the files that were open.

Behavior of saving after session recovery

When MuseScore recovers files after a crash, it renames them with the full path name added in front
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of the original file name. This very long name will appear in the tab(s) above the active score window.
On some operating systems, when a user saves any of these recovered files, it will be saved in the
folder in which the program itself is running. This is not necessarily the same directory in which
the scores were saved when they were created. You may not be able to locate the revised file
in the usual folder.

To avoid this, do not use "Save" the first time you save a recovered file. Use the "Save As..." menu
item before making any revisions to the score, to save each recovered file under either its original
name or a new name. This will open a window to allow you to navigate to the correct folder and
directory. This is important in order to ensure that the file is saved to the folder in which you
expect to find it later.

Finding recovered files

In the event that "Save" is used instead of "Save As..." with a recovered file, you will have to find the
files in your computer. The actual location of those files will vary, depending on your operating
system, and in which directory MuseScore is installed.

For Windows 7, with a default installation of MuseScore to the x86 program files directory, recovered
files are auto-saved to C:\Program Files (x86)\MuseScore2\bin.

For Windows 10, look in C:\Users\[User Name]\AppData\Local\VirtualStore\Program Files
(x86)\MuseScore 2\bin

You may need to run a system-wide search in order to find files saved directly after a session
recovery. Use keywords from the original file name as well as wildcards, and specify the date
modified.

See also

Save/Export/Print

External links

How to recover a backup copy of a score

Do you have an unanswered question? Post it in the forum.

Replace pitches without changing rhythms
If you have a passage where you want a change in notes but not in rhythm, but that is more
complicated than a simple transposition of notes, re-pitch mode is highly useful. In essence, when in
re-pitch mode, new pitches will replace the old ones, following the original rhythm.

Not to be confused with Accidental: Respell pitches

To activate re-pitch mode, use the re-pitch button, , next to the Note input button, , or use the
shortcut Shift+Ctrl+I (Mac: Shift+Cmd+I).

To reproduce a rhythmical passage with different pitches, select the passage, copy it, and paste it
where you want. (If you are in a situation of having written the wrong notes but correct rhythm, no
copy and paste is necessary.)

Then click on the first note you want to re-pitch, enter note input mode, and activate re-pitch mode.
Begin typing the new pitches. Unlike normal circumstances, where the length of the notes you are
entering are based on what length you have selected in the toolbar, in re-pitch mode the rhythm (the
notes' length) will stay the same.

See also

Note input
Copy and paste
Transposition
Introduction to the new 'Repitch Mode'
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Do you have an unanswered question? Post it in the forum.

Score properties
Several meta tags are generated automatically on creation of a score, and more may be created later.
These may then be used in a header or footer—see below.

File → Score Properties... (File → Info... in versions earlier than 2.0.3) shows the values of the
existing meta tags.

Preexisting meta tags

Every score has the following fields available in Score Properties. Some are automatically filled in on
score creation, while others will be empty unless specifically changed. The first four items in the
following list are not user-modifiable, and cannot be used in the header or footer (they are not really
meta tags).

File Path: The score file's location on your computer.
MuseScore Version: The version of MuseScore the score was last saved with.
Revision: The revision of MuseScore the score was last saved with.
API-Level: The file format version.
arranger: (empty)
composer: As entered in the New Score Wizard (which is also used to fill the composer text in
the top vertical frame—be aware that later changes to one are not reflected in the other).
copyright: As entered in the New Score Wizard. Copyright info appears as seemingly uneditable
text at the bottom of every page of a score, but it can be edited or removed by changing the
value here.
creationDate: Date of the score creation. This could be empty, if the score was saved in test
mode (see Command line options).
lyricist: As entered in the New Score Wizard (which is also used to fill the corresponding lyricist
text in the top vertical frame—be aware that later changes to one are not reflected in the
other).
movementNumber: (empty)
movementTitle: (empty)
originalFormat: This tag exists only if the score got imported and then contains the format the
score got imported from (see file formats).
platform: The platform the score was created on: "Microsoft Windows", "Apple Macintosh",
"Linux" or "Unknown". This might be empty if the score was saved in test mode.
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poet: (empty)
source: May contain a URL if the score was downloaded from or saved to MuseScore.com.
translator: (empty)
workNumber: (empty)
workTitle: As entered in the New Score Wizard (which is also used to fill the corresponding title
text in the top vertical frame—be aware that later changes to one are not reflected in the
other).

Every part additionally has the following meta tag, generated and filled on part creation:

partName: Name of the part as given on part creation (which is also used to fill the
corresponding part name text in the top vertical frame—be aware that later changes to one
are not reflected in the other).

Modify a meta tag

To modify a meta tag of a score with linked parts, make sure the score is in the active tab. To modify
a meta tag for an individual part, that part needs to be the active tab. Go to File → Score Properties
and you can change the current text or fill in the empty field for any of the tags listed.

Add a new meta tag

To add a meta tag to a score with linked parts, make sure the score is in the active tab. To add a meta
tag to an individual part, that part needs to be the active tab.

Go to File → Score Properties... (File → Info... in versions earlier than 2.0.3) and click the New
button.

Fill in the name of your new meta tag and click OK (or Cancel). The meta tag will be added to your tag
list. You can then fill in the content of the tag.

Header/Footer

You can show the content of meta tags in a header or footer for your score. To create a header or
footer for a score with linked parts, make sure the score is in the active tab. To create a header or
footer for an individual part, that part needs to be the active tab.

Go to Style → General... to open the Edit Style window and choose Header, Footer, Numbers  from
the sidebar on the left.
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If you hover with your mouse over the Header or Footer text region, a list of macros will appear,
showing their meaning, as well as the existing meta tags and their content.

You can use these tags (e.g. $:workTitle:) and macros (e.g. $M) in the appropriate boxes to add them
to headers or footers.

Click Apply to see how the header or footer looks in the score. Click OK to assign the header or footer
to the score or the active part. If a part is in the active tab, you can also click Apply to all parts if you
want that and then OK to leave the dialog. Cancel allows you to exit without applying the changes.

See also
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Layout and formatting: Header and footer
Command line options: Test mode

Do you have an unanswered question? Post it in the forum.

Staff properties
To display the Edit Staff/Part Properties dialog, right-click on any staff line and select Staff
Properties.... This allows you to make changes to the display of a staff, adjust its tuning and
transposition, change instrument etc.

For practical purposes, there are four different staff types:

1a. Standard staff I. A pitched staff used for most instruments except fretted, plucked-string ones.
1b. Standard staff II. A pitched staff containing a fretted, plucked-string instrument, with options to set
the number of instrument strings and tuning.
2. Tablature staff. A staff containing a fretted, plucked-string instrument, which displays music as a
series of fret-marks on strings. Also contains options to set the number of instrument strings and
tuning.
3. Percussion staff. A pitched staff for percussion instruments.

It is possible to change one type of staff into another using the Instruments dialog, as long as the
original staff is loaded with the right instrument. For example, in order to change a standard staff to
tablature, it must contain a plucked-string instrument. Similarly, to change a standard staff to a
percussion staff you need to ensure that it has an appropriate percussion instrument loaded and so
on.

Most options in the Staff properties dialog are common to all staves, but each type also has one or
two specific options of its own.

Common Staff Properties options

The following options are common to the Staff Properties dialog for all staff types:

Lines
The number of lines making up the staff

Line Distance
The distance between two staff lines, measured in spaces (abbr.: sp). If you set this to a higher
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value, the lines are spaced more widely apart; a lower value and they are closer together. It is
not recommended to change this value for the standard group, for which the default distance is
1.0 (instead, change the actual size of the sp unit in Page settings); other groups may have
different default values (for instance, tablature usually has a line distance of 1.5 sp).

Extra distance above staff
Use this to increase the distance between the selected staff and the one above (in all systems).
You can also alter this value directly from the score page: click on an empty space in a staff,
press Shift and drag the staff up or down. (To alter the spacing above just one staff line in a
particular system, see Breaks and spacers).

Scale
Changes the size of a staff and all associated elements, as a percentage.

Never Hide
Show clef

Whether the staff clef will be shown.
Show time signature

Whether the staff time signature(s) will be shown or not.
Show barlines

Whether the staff barlines will be shown.
Hide system barline

Show/hide barline at left-hand edge of the staff.
Do not hide if system is empty
Small staff

Create a reduced-size staff. You can set the default in Style → General... → Sizes.
Invisible staff lines

Make staff lines invisible.
Staff line color

Use a color picker to change the color of the staff lines.
Part name

The name of the part. This is also displayed in the Mixer and the Instruments dialog (I).
Instrument

The instrument loaded in the Instruments (I) or Select Instrument dialog. The sound associated
with this instrument can be changed, if desired, in the Mixer.

Long instrument name
Name displayed to the left of the staff in the first system of the score.

Short instrument name
Name displayed to the left of the staff in subsequent systems of the score.

Usable pitch range
Notes outside this range will be marked in red in the score window, if "Color notes outside of
usable pitch range" is ticked in Preferences > Note input.

Play transposition
This option ensures that the staves of transposing instruments display music at the correct
written pitch. Set the transpose in term of a musical interval (plus octave if required) up or down.
For plucked-string instruments such as the guitar, this property can be used to create the effect
of applying a capo.

Plucked-string Staff Properties: specific options

In addition to the common options listed above, the staves of fretted, plucked-string instruments have
a few extra type-specific properties:

Number of strings
Displays the number of instrument strings.

Edit String Data…
This button opens a dialog box which allows you to set the number and tuning of strings. See
Change string tuning.

Advanced style properties

Clicking the Advanced Style Properties... button opens a dialog giving access to advanced options
for the staff. The following illustrations show how the dialog looks for the different staff types:

Standard staff:
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Percussion staff:

Tablature staff—Fret Marks:
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Tablature staff—Note Values:
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There are also some buttons:

Template

Displays the list of all the staff templates available in the score and which can be applied to the
current staff.

Note: Each score is initially created with 17 pre-defined staff "templates" (not to be confused
with Templates): one standard, three percussion and 13 tablature templates. Each template
addresses a specific need, common enough or standardized enough to deserve a specific
template; each template can be modified (independently for each score staff) and new templates
can be created to accommodate specialized needs.

< Reset to Template

Resets all the staff properties to the properties of the selected template.

Add to Templates

Adds the current property set to the score as a new template (not yet implemented).

OK

Closes the dialog box, accepting the changes.

Cancel

Closes the dialog box, rejecting the changes.

Standard and Percussion staff specific items

Show key signature
Whether the staff key signature will be shown.

Show ledger lines
Whether the staff ledger lines will be shown.

Stemless
If checked, staff notes will have no stem, hook or beam.

Tablature staff specific items

Upside down
If not checked, the top tablature line will refer to the highest string and the bottom tablature line
will refer to the lowest string (most common case). If checked, the top tablature line will refer to
the lowest string and the bottom tablature line will refer to the highest line (used in Italian style
lute tablatures).

Fret marks

Fret marks are the numbers or letters used to indicate the location of notes on the fingerboard. The
following group of properties define the appearance of fret marks:

Font
The font used to draw the marks. Currently 4 fonts are provided supporting all the necessary
symbols in 4 different styles (modern serif, modern sans, Renaissance, Late Renaissance).
More fonts (or the possibility to use custom fonts) may be available in the future.

Size
The font size to use, in typographic points. Built-in fonts look usually good at a size of 9-10pt.

Vertical offset
MuseScore tries to place symbols in a sensible way and this value is usually not needed (set to
0) for built-in fonts. If the font has symbols not aligned on the base line (or in some other way
MuseScore does not expect), this value allows to move mark symbols up (negative offsets) or
down (positive offsets) for better vertical positioning. Values are in sp.

Numbers / Letters
Whether to use numbers (‘1’, ‘2’...) or letters (‘a’, ‘b’...) as fret marks. When letters are used, ‘j’ is
skipped and ‘k’ is used for the 9th fret.

On lines / Above lines
Whether marks should be placed on the string lines or above them.
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Continuous / Broken

Whether string lines should pass ‘through’ fret marks or should stop at them.
Example of numbers on broken lines:

Example of letters above continuous lines:

Example of 'upside down' tablature (same contents as number example above):

Show back-tied fret marks
If unticked, only the first note in a series of tied notes is displayed. If ticked, all notes in the tied
series are displayed.

Note values

This group of properties defines the appearance of the symbols indicating note values.

Font
The font used to draw the value symbols. Currently 3 fonts are provided supporting all the
necessary symbols in 3 different styles (modern, Italian tablature, French tablature). More fonts
(or the possibility to use custom fonts) may be available in the future. Used only with the Note
symbols option.

Size
The font size to use, in typographic points. Built-in fonts look usually good at a size of 15pt.
Used only with the Note symbols option.

Vertical offset
As for Fret Marks above, but referring to value symbols instead. Used only with the Note
symbols option.

Shown as: None
No note value will be drawn (as in the examples above)

Shown as: Note symbols

Symbols in the shape of notes will be drawn above the staff. When this option is selected,
symbols are drawn only when the note value changes, without being repeated (by default) for a
sequence of notes all of the same value.
Example of values indicated by note symbols:

211



Shown as: Stems and beams

Note stems and beams (or hooks) will be drawn. Values are indicated for each note, using the
same typographic devices as for a regular staff; all commands of the standard Beam Palette can
be applied to these beams too.
Example of values indicated by note stems:

Repeat: Never / At new system / At new measure / Always
Whether and when to repeat the same note symbol, if several notes in sequence have the same
value (only available with the Note symbols option).

Beside staff / Through staff
Whether stems are drawn as fixed height lines above/below the staff or run through the staff to
reach the fret marks each refers to (only available with the Stems and Beams option).

Above / Below staff
Whether stems and beams are drawn above or below the staff (only available with the Stems
and Beams option / Beside staff sub-option).

None / As short stems / As slashed stems
To select three different styles to draw stems for half notes (only available with the Stems and
Beams option / Beside staff sub-option).

Show rests
Whether note symbols should be used to indicate also the rests; when used for rests, note
symbols are drawn at a slightly lower position. Used only with the Note symbols option.

Preview

Displays a short score in tablature format with all the current parameters applied.

Change instrument

You can change any instrument in a score to a different instrument at any time. The following method
updates instrument sound, staff name, and staff transposition all at once.

1. Right-click on an empty part of any measure OR on the instrument name and choose Staff
Properties...

2. Click on Change Instrument... (button on the right)
3. Choose your new instrument and click OK to return to the Staff Properties dialog
4. Click OK again to return to the score

Not to be confused with Mid-staff instrument change.

See also

How to turn a staff into an ossia.

Do you have an unanswered question? Post it in the forum.

Tools
A number of useful commands can be found in the Edit → Tools submenu.
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Add / Remove line breaks

This tool adds or removes line breaks over all or part of the score:

1. Select a range of measures: if no selection is made, the command is applied to the whole score.

2. Chose Edit → Tools → Add/Remove Line Breaks…. The following dialog appears.

3. Chose one of the following options:

Break lines every X (select number) measures.
Add line break at the end of each system.
Remove current line breaks.

4. Press OK.

Explode

The explode command allows you to select a passage of music in a single staff and split (explode) the
chords into their constituent notes. The top note of each chord is retained on this "source staff" while
lower notes are moved to subsequent staves. Explode only affects notes in voice 1.

Note: This feature is meant to be used on passages containing a single voice only. If the desired
passage contains more than one voice, you should, instead, cut and paste each voice to a separate
staff with the help of the selection filter.

To explode a section of the score:

1. Make sure all notes to be exploded are in voice 1.
2. Ensure that there are enough staves underneath the "source staff" to receive the exploded

notes. Create extra staves if necessary in the Instruments dialog.
3. Chose one of two options:

Select a range of measures in the "source staff": this allows all notes to be exploded if
there are enough staves available.
Select a range of measures that includes both the source staff and also extends
downwards to include one or more destination staves: This limits the number of exploded
notes to the number of selected staves.

4. Chose Edit → Tools → Explode.

Notes: (1) MuseScore will discard the lowest note(s) of any chord that contains more notes than the
number of staves in the selection. (2) If a given chord has fewer notes than the number of destination
staves, then notes will be duplicated as needed so that every staff receives a note. (3) Any existing
music in the destination staves is overwritten. (4) If you select a partial measure, the explode
command will automatically expand it to a full measure.

Implode

The Implode command works in the opposite way to "explode":

If several staves are selected, all voice 1 notes in underlying staves are copied to the top staff.
If just one staff is selected, all notes in voices 1–4 are combined into voice 1.

Note: Implode works best if the rhythms of selected underlying staves are similar to that of the top
staff—the latter providing the rhythmic template for the operation.

Apply implode to multiple staves

1. Select a range of measures in a staff and extend this selection downwards to include the other
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staves to be imploded.
2. Chose Edit → Tools → Implode.

The voice 1 notes of underlying staves are copied to the top staff in the selection.

Apply implode to a single staff

1. Select a range of measures in the desired staff.
2. Chose Edit → Tools → Implode.

All selected notes in the staff are now displayed in voice 1.

Fill with slashes

This command fills the selection with slashes, one per beat. For normal (empty) measures, the
slashes are added in voice 1.

If there are already notes in a measure in the selection, the command will put the slashes into the first
empty voice it finds. If a measure contains notes in all 4 voices, voice 1 will be filled with slashes, over-
writing any existing notes. In voices 1 and 2 the slashes will be centered on the middle line of the staff,
in voices 3 and 4 they appear small and above or below the staff. All slashes are set to not transpose
or playback.

Toggle rhythmic slash notation

This command toggles selected notes between normal notes and rhythmic slash notation: notes with
slash heads, set to not transpose or playback. For notes in voices one or two, the notes are fixed to
the middle staff line.

For notes in voices three or four, the notes are fixed above or below the staff and are also marked
small (also known as "accent" notation). You may find it helpful to use the selection filter to exclude
voices one and two from your selection before running this command, so only the notes in voices
three and four are affected.
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In percussion staves, the notes in voices 3 and 4 are not converted to small slashes but to small
notes above or below the staff.

Resequence rehearsal marks

Rehearsal marks added via the text palette will automatically be labeled with the next letter or number
(based on whatever you typed into the first rehearsal mark), but with the menu command Edit →
Tools → Resequence Rehearsal Marks, you can change all marks at once from letters to numbers (e.g.)
or correct marks that have become out of order through use of copy and paste. Select the range of
measures you want to apply the command to before running it.

MuseScore automatically detects the sequence based on the first rehearsal mark in the selection—all
rehearsal marks in the selection are then altered accordingly.

The sequence can be:

a, b, c,
A, B, C,
numerically simple sequence - 1, 2, 3,
numerically corresponding to measure numbers

Copy lyrics to clipboard

This command copies all the lyrics of a score, so you can paste them into another document.

See also

Breaks and spacers
Rehearsal marks

Do you have an unanswered question? Post it in the forum.

New features in MuseScore 2
For an overview of the new features, see What's New in MuseScore 2, Release notes for MuseScore
2.0, Release notes for MuseScore 2.0.1, MuseScore 2.0.2 Release Notes, MuseScore 2.0.2 is
released, MuseScore 2.0.3 Release Notes, MuseScore 2.0.3 is released, and Changes in MuseScore
2.0.
Documentation of new features are available in the chapter they belong to logically (except the one
that is referring to upgrading from 1.x) , but for users coming from 1.x here's a collection of links to be
able to see at a glance what can be done now...
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See also

Album (→Advanced topics)
View modes: Continuous view and Navigator (→Basics)
Copy and paste: Selection filter (→Basics)
Custom palette (→Advanced topics)
Early music features (→Advanced topics)
Figured bass (→Advanced topics)
Grid-based movement of symbols and staff text (→Text)
Image capture (→Formatting)
Inspector and object properties (→Advanced topics)
Measure operations: Split and join (→Basics)
MIDI import (→Sound and playback)
Mid-staff instrument change (→Sound and playback)
Part extraction (new options available) (→Advanced Topic)
Rehearsal marks: Automatic next rehearsal mark and Search for a rehearsal mark (→Text)
Save/Export (→Basics)
Staff type properties (→Advanced topics)
Swing (→Sound and playback)
Tablature (→Advanced topics)
Workspace (→Basics)
Master palette (→Advanced topics)
Layout and formatting (some options have changed, and there is a new "apply to all parts"
feature) (→Formatting)
Break and spacer: Section break (→Formatting)
Selection modes: Select all similar new options (same subtype) (→Basics)
Create a new score: start center (→Basics)
Languages settings and translation updates (→Basics)
Helping and improve translation (→Support)
Accidentals: Respell pitches (→Notation)
Re-pitch mode (→Advanced topics)
Tools (→Advanced topics)
Score Information (→Advanced topics)

Upgrading from MuseScore 1.x

How to upgrade MuseScore

Download and install the latest version from the download page as described at Installation. If you
want to remove 1.x, check the installation page of the 1.x handbook.

Installing MuseScore 2 won't uninstall 1.x—both versions can coexist peacefully and can even be used
in parallel. So this isn't really an upgrade but an installation of a new and different program.

Opening 1.x scores in MuseScore 2

MuseScore 2 significantly improved the typesetting quality to make scores attractive and easier to
read. Improvements cover many items such as beam slope, stem height, layout of accidentals in
chords and general note spacing. However, this means that sheet music made with MuseScore 1.x
looks slightly different from sheet music made with 2.x.

It also means that scores saved with 2.x won't open with 1.x.

To prevent you from accidentally overwriting your 1.x scores, 2.x treats them as an import, which
means:

The score gets marked as being modified, even if you haven't change anything
On exiting MuseScore you're asked to save the score (as a result from the above)
MuseScore uses the "Save As" dialog to save it, not the "Save" dialog
MuseScore uses the score's title to create a default filename rather than taking the old filename

Local relayout

If you did not manually adjust the layout of a 1.x score, then MuseScore uses the 2.x typesetting
engine to layout the score. If you did touch the layout of the 1.x score, the individual adjustments you
may have made should remain after opening it in MuseScore 2.x, but due to slight changes in the
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surrounding layout they may still not appear correct in context. If you wish to reset even manual
adjustments to use the 2.x typesetting engine throughout, select the complete score with the shortcut
Ctrl+A (Mac: Cmd+A) and reset the layout with Ctrl+R (Mac: Cmd+R).

Getting the sound from MuseScore 1.x

While the sound in 2.x has been much improved, you may still prefer the sound from MuseScore 1.x.
In that case, you can get the 1.x sound in 2.x by downloading the 1.3 SoundFont and add it in 2.x. You
can do this in two steps:

1. Download the 1.3 SoundFont named TimGM6mb
2. Install and use the TimGM6mb SoundFont in 2.0

Do you have an unanswered question? Post it in the forum.

Support
This chapter describes how to find help using MuseScore: the best places to look, the best way to ask
a question on the forums, and tips for reporting a bug.

Helping improve translations
You can help translate the MuseScore software and documentation into your own language, as
mentioned in Development / Translating.

Software translation

1. Ask in the forum to improve translation
2. Connect to Transifex/MuseScore http://translate.musescore.org, which will redirect you to

https://www.transifex.com/projects/p/musescore
3. Select the language and then the section you want to help with (musescore or instruments)
4. Click on the "translate" button (the button text will depend on your language...)
5. Search for "strings" (informational meaning) you want to translate (you could filter "already

translated items")

Here is a technical explanation: Continuous translation for MuseScore 2.0

Website and handbook translation

See Translation instructions

See also

Language Settings and Update Translation, Update Translation

Do you have an unanswered question? Post it in the forum.

How to ask for support or file bug reports
Before submitting your support request in the forum, please:

Look for a solution in the Handbook (search the Handbook)
Check the How Tos, FAQ and Tutorials
Search the forums of the website to see if someone has already encountered the same problem

If posting in either the issue tracker (for established reports), or forum (for inquiries/discussions):

Try to reproduce the issue with the latest nightly. You may also view the older and new version
history to check whether it has been fixed/implemented already.

Please include as much of the following information as you know and limit each issue to one
report:

Version/revision of MuseScore you are using (e.g. version 2.0, revision 2902cf6). Check
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Help → About... (Mac: MuseScore → About MuseScore...).
Operating system being used (e.g. Windows XP SP3, Mac OS 10.7.5 or Ubuntu 10.10)
If reporting a bug, describe the precise steps that lead to the problem (where do you click,
what keys do you press, what do you see, etc.).
If you are not able to reproduce the problem with the steps, it is probably not worth
reporting it as the developers will not be able to reproduce (and solve) it either. Remember
that the goal of a bug report is not only to show the problem, but to allow others to
reproduce it easily.
Remember to attach the score that shows the problem—use the "File attachments"
option at the bottom of the page, just above the Save and Preview buttons when you're
typing your post.

See also

How to write a good bug report: step-by-step instructions

Do you have an unanswered question? Post it in the forum.

Revert to factory settings
Recent versions of MuseScore have the option to revert back to the standard built-in presets or
"factory-settings". This can be necessary if your settings are corrupted. Warning: Reverting to factory
settings removes any changes you have made to the preferences, palettes, or window settings. This is
not a commonly needed procedure; consult the forums first, as there may be a way to solve your
problem without resetting everything.

MuseScore 2.0.3 and above

In recent versions it is possible to revert from within MuseScore, providing that MuseScore itself is able
to start.
Go to Help → Revert to Factory Settings . A warning dialog will appear:

Clicking Yes resets all MuseScore's settings as if the program was installed for the first time, and
MuseScore will immediately restart. No will safely cancel the revert.

MuseScore 2.0 through 2.0.2

In older versions of MuseScore, or in later versions if they do not start, you must run this process via
the command line.

Instructions for Windows

1. If you have MuseScore open, you need to close it first (File → Quit)
2. Type Windows key+R to open the Run dialog (The Windows key is the one with the logo for

Microsoft Windows). Alternatively select Start using your mouse.
3. Click Browse...
4. Look for MuseScore.exe on your computer. The location may vary depending on your

installation, but it is probably something similar to My Computer → Local Disk → Program Files
(or Program Files (x86)) → MuseScore 2 → bin → MuseScore.exe

5. Click Open to leave the Browse dialog and return to the Run dialog. The following text (or
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something similar) should display in the Run dialog

"C:\Program Files\MuseScore 2\bin\MuseScore.exe"

For 64-bit Windows, the location is

"C:\Program Files (x86)\MuseScore 2\bin\MuseScore.exe"

6. Click after the quote and add a space followed by a hyphen and a capital F: -F

7. Press OK

After a few seconds, MuseScore should start and all the settings reverted to "factory settings".

For advanced users, the main preference file is located at:

Windows Vista or later: C:\Users\<USERNAME>\AppData\Roaming\MuseScore\MuseScore2.ini
Windows XP or earlier: C:\Documents and Settings\USERNAME\Application
Data\MuseScore\MuseScore2.ini

The other preferences (palette, session...) are in:

Windows Vista or later: C:\Users\<USERNAME>\AppData\Local\MuseScore\MuseScore2\
Windows XP or earlier: C:\Documents and Settings\USERNAME\Local Settings\Application
Data\MuseScore\MuseScore2\

Instructions for MacOS

1. If you have MuseScore open, you need to quit the application first (MuseScore → Quit)
2. Open Terminal (in Applications/Utilities, or via Spotlight search) and a session window should

appear

3. Type (or copy/paste) the following command into your terminal line (include the '/' at the front):

/Applications/MuseScore\ 2.app/Contents/MacOS/mscore -F

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore
application. Note that you cannot quit the Terminal without quitting MuseScore. You can safely quit
MuseScore, quit the Terminal, and then reopen MuseScore in the normal fashion, ready to continue
using.

For advanced users, the main MuseScore preference file is located at
~/Library/Preferences/org.musescore.MuseScore2.plist.

The other preferences (palette, session...) are in ~/Library/Application\
Support/MuseScore/MuseScore2/

Instructions for Linux

The following is true for Ubuntu, and most likely all other Linux distributions and UNIX-style operating
systems.

1. If you have MuseScore open, you need to quit the application first (File → Quit)
2. From the Ubuntu main menu, choose Applications → Accessories → Terminal. A Terminal

session window should appear

3. Type, (or copy/paste) the following command into your terminal line (Ctrl+Shift+V to paste in
Terminal):

mscore -F

Or, if you are using the AppImage version, you must first use the cd command to change
directory to wherever you saved the AppImage. For example, if you saved it to your Desktop:

cd ~/Desktop
./MuseScore*.AppImage -F

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore
application. You can now quit Terminal, and continue using MuseScore.
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For advanced users, the main MuseScore preference file is located at
~/.config/MuseScore/MuseScore2.ini. The other preferences (palette, session...) are in
~/.local/share/data/MuseScore/MuseScore2/

See also

Command line options

Do you have an unanswered question? Post it in the forum.

Known incompatibilities

Hardware incompatibilities

The following software is known to crash MuseScore on startup:

Samson USB Microphone, driver name "Samson ASIO Driver", samsonasiodriver.dll. More info
Digidesign MME Refresh Service. More info
Windows XP SP3 + Realtek Azalia Audio Driver. More info
Wacom tablet. More info and QTBUG-6127

Software incompatibilities

Maple virtual cable is known to prevent MuseScore from closing properly.
KDE (Linux) window settings can cause the whole window to move when dragging a note.
Changing the window settings of the operating system avoids the problem.
Nitro Pro may prevent MuseScore 2 from starting on Windows 10.
Creative Sound Blaster Z Series ASIO driver may prevent MuseScore 2 from starting on
Windows 10.

AVG Internet Security hangs MuseScore

MuseScore requires access to your internet connection with AVG. MuseScore doesn't need an
internet connection to function, but if AVG blocks it, MuseScore hangs.

If AVG prompts you, Allow MuseScore and check "Save my answer as a permanent rule and do not
ask me next time."

If it doesn't prompt you anymore,

1. Open the AVG user interface (right-click on the AVG icon, close to your clock -> Open AVG User
Interface

2. Click on Firewall
3. Click Advanced Settings
4. Click Applications
5. Find MSCORE.EXE in the list and double click it
6. Change Application Action to Allow for All

Font problem on macOS

MuseScore is known to display notes as square when some fonts are damaged on macOS.
To troubleshoot this issue:

1. Go to Applications -> Font Book
2. Select a font and press ⌘+A to select them all
3. Go to File -> Validate Fonts
4. If any font is reported as damaged or with minor problems, select it and delete it
5. Restart MuseScore if necessary

In this forum article, a user believes to have found the font "Adobe Jenson Pro (ajenson)" to be the
culprit, regardless of not being reported as broken, or problematic as per the above validation, and
solved the problem by deleting that font, so this is worth checking too.

Font problem on Linux
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If the default desktop environment application font is set to bold, MuseScore will not display the notes
properly.
To troubleshoot this issue (gnome 2.*/MATE users):

1. Right-click on your desktop and select Change Desktop background
2. Click on Fonts tab
3. Set Regular style for Application font
4. Restart MuseScore if necessary

For GNOME 3/SHELL users

1. Open the shell and open "Advanced Settings"
2. Click on the Fonts option in the list
3. Set the default font to something non-bold
4. Restart MuseScore if necessary

Save As dialog empty on Linux

Some users reported that the Save As dialog is empty on Debian 6.0 and Lubuntu 10.10.
To troubleshoot this issue:

1. Type the following in a terminal

which mscore

2. The command will answer with the path of mscore. Edit it with your preferred text editor and add
the following line at the beginning

export QT_NO_GLIB=1

Launch MuseScore and the problem should be solved.

Do you have an unanswered question? Post it in the forum.

Appendix
Keyboard shortcuts
Most keyboard shortcuts can be customized via Edit → Preferences... → Shortcuts tab (Mac:
MuseScore → Preferences... → Shortcuts tab). Below is a list of some of the initial shortcut settings.

Navigation

Beginning of score: Home
Last page of score: End
Find (measure number, rehearsal mark, or pXX when XX is a page number): Ctrl+F (Mac: Cmd+F)

Next score: Ctrl+Tab
Previous score: Shift+Ctrl+Tab

Zoom in: Ctrl++ (doesn't work on some systems) (Mac: Cmd++) or Ctrl (Mac: Cmd) + scroll up
Zoom out: Ctrl+- (Mac: Cmd+-) or Ctrl (Mac: Cmd) + scroll down

Next page: Pg Dn or Shift + scroll down
Previous page: Pg Up or Shift + scroll up

Next measure: Ctrl+→ (Mac: Cmd+→)
Previous measure: Ctrl+← (Mac: Cmd+←)

Next note: →
Previous note: ←

Note below (within a chord or on lower staff): Alt+↓
Note above (within a chord or on higher staff): Alt+↑

Top note in chord: Ctrl+Alt+↑ (Ubuntu uses this shortcut for Workspaces instead)
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Bottom note in chord: Ctrl+Alt+↓ (Ubuntu uses this shortcut for Workspaces instead)

Note input

Begin note input mode: N
Leave note input mode: N or Esc

Duration

1 ... 9 selects a duration. See also Note input.

Half duration of previous note: Q
Double duration of previous note: W

Voices

Voice 1: Ctrl+Alt+1 (Mac: Cmd+Option+1)
Voice 2: Ctrl+Alt+2 (Mac: Cmd+Option+2)
Voice 3: Ctrl+Alt+3 (Mac: Cmd+Option+3)
Voice 4: Ctrl+Alt+4 (Mac: Cmd+Option+4)

Pitch

Pitches can be entered by their letter name (A-G), or via MIDI keyboard. See Note input for full details.

Repeat previous note or chord: R (the repeat can be of a different note value by selecting duration
beforehand)

Repeat selection: R (The selection will be repeated from the first note position after the end of the
selection)

Raise pitch by octave: Ctrl+↑ (Mac: Cmd+↑)
Lower pitch by octave: Ctrl+↓ (Mac: Cmd+↓)

Raise pitch by semi-tone (prefer sharp): ↑
Lower pitch by semi-tone (prefer flat): ↓
Raise pitch diatonically: Alt+Shift+↑
Lower pitch diatonically: Alt+Shift+↓

Cycle up through enharmonic spellings: J
Cycle down through enharmonic spellings: Shift+J
Cycle through spellings in concert pitch only or transposed only: Ctrl+J (Mac: Cmd+J)

Rest: 0 (zero)

Interval

Add interval above current note: Alt+[Number]

Layout

Flip direction (stem, slur, tie, tuplet bracket, etc.): X
Mirror note head: Shift+X
Increase stretch of measure(s): }
Decrease stretch of measure(s): {
Line break on barline: Return
Page break on barline: Ctrl+Return (Mac: Cmd+Return)

Articulations

Staccato: Shift+S
Tenuto: Shift+N
Sforzato (accent): Shift+V
Marcato: Shift+O
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Grace note (acciaccatura): /
Crescendo: <
Decrescendo: >

Text entry

Staff text: Ctrl+T (Mac:Cmd+T)
System text: Ctrl+Shift+T (Mac: Cmd+Shift+T)
Tempo text: Alt+T
Rehearsal Mark: Ctrl+M (Mac: Cmd+M)

Lyrics entry

Enter lyrics on a note: Ctrl+L (Mac: Cmd+L)
Previous lyric syllable: Shift+Space
Next lyric syllable: if the current and the next syllables are separated by a '-': -, else Space
Move lyric syllable left by 0.1sp: ←
Move lyric syllable right by 0.1sp: →
Move lyric syllable left by 1sp: Ctrl+← (Mac: Cmd+←)
Move lyric syllable right by 1sp: Ctrl+→ (Mac: Cmd+→)
Move lyric syllable left by 0.01sp: Alt+←
Move lyric syllable right by 0.01sp: Alt+→

Up to previous stanza: Ctrl+↑ (Mac: Cmd+↑)
Down to next stanza: Ctrl+↓ (Mac: Cmd+↓)

For more lyric shortcuts, see Lyrics.

Display

Navigator: F12 (Mac: fn+F12)
Play Panel: F11 (Mac: fn+F11)
Mixer: F10 (Mac: fn+F10)
Palette: F9 (Mac: fn+F9)
Inspector: F8 (Mac: fn+F8)
Piano Keyboard: P

Miscellaneous

Toggle visibility on selected element: V
Show Instruments dialog: I
Toggle multi-measure rests on or off: M

See also

Preferences: Shortcuts

Do you have an unanswered question? Post it in the forum.

Known limitations of MuseScore 2.0
While all members of the development team did their best to make the software easy to use and bug-
free, there are some known issues and limitations in MuseScore 2.0.

Basics

Save Selection

'Save Selection...' is currently pretty limited: If the selection doesn't contain a clef, time or key
signature, the saved score will be in treble clef, 4/4 time signature, and C major key signature,
although all pitches are kept, accidentals added as needed, and even irregular measures are kept.

Local Time Signatures
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The local time signature feature, which allows you to have different time signatures in different staves
at the same time, is very limited. You can only add a local time signature to measures that are empty,
and only if there are no linked parts. When adding notes to measures with local time signatures, you
can enter notes normally via note input mode, but copy and paste does not work correctly and may
lead to corruption or even crashes. The join and split commands are disabled for measures with local
time signatures.

Note input

Tablature staff linked with Standard staff

With linked Standard and Tablature staves, if multiple note chords are entered in the Standard staff,
each chord should be entered from its top note to the bottom, otherwise the fretting automatically
assigned note by note in the Tablature staff may be unexpected (Note: This does not apply to a) note
input directly in the Tablature staff nor to b) note input in a Standard staff not linked to a Tablature: in
both cases entry order is indifferent).

Sound and playback

Instrument change

An instrument change does not change transposition, should any of the instruments involved require
that. If this is needed, it is necessary to use different staves and the 'Hide empty staves' option.
Actually there is no real instrument change, just a change of the sound on playback, so not only
transposition is not taken into account but also the instrument's range, and the part's name is left
unchanged.

Mixer

Changing values in the mixer does not mark the score 'dirty'. That means if you close a score you may
not get the warning "Save changes to the score before closing?". Changing mixer values are also not
undoable.

Layout

Header & Footer

There is no way to edit Header and Footer in a WYSIWYG manner. The fields in Style → General →
Header, Footer, Numbers are plain text. They can contain "HTML like" syntax, but the text style,
layout, etc. can't be edited with a WYSIWYG editor.

Do you have an unanswered question? Post it in the forum.

Command line options
You can launch MuseScore from the command line by typing

mscore [options] [filename] (Mac and Linux)
MuseScore.exe [options] [filename] (Windows)

[options] and [filename] are optional.

See also Revert to factory settings for detailed instructions on how and where to find and execute the
MuseScore executable from the command line on the various supported platforms.

The following options are available

-?, -h, --help
Display help (doesn't work on Windows)

-v, --version
Displays MuseScore's current version in the command line without starting the graphical
interface (doesn't work on Windows)

--long-version
Displays MuseScore's current version and revision in the command line without starting the
graphical interface (doesn't work on Windows)
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-d, --debug
Starts MuseScore in debug mode

-L, --layout-debug
Starts MuseScore in layout debug mode

-s, --no-synthesizer
Disables the integrated software synthesizer

-m, --no-midi
Disables MIDI input

-a, --use-audio <driver>
Use audio driver: jack, alsa, pulse, portaudio

-n, --new-score
Starts with the new score wizard regardless of preference setting for start mode

-I, --dump-midi-in
Displays all MIDI input on the console

-O, --dump-midi-out
Displays all MIDI output on the console

-o, --export-to <filename>
Exports the currently opened file to the specified <filename>. The file type depends on the
filename extension. This option switches to the "converter" mode and avoids any graphical
interface. You can also add a filename before the -o if you want to import and export files from
the command line. For example mscore -o "My Score.pdf" "My Score.mscz"

-r, --image-resolution <dpi>
Determines the output resolution for the output to "*.png" files in the converter mode. The default
resolution is 300 dpi.

-T, --trim-margin <margin>
Trims exported PNG and SVG images to remove surrounding whitespace around the score. The
specified number of pixels of whitespace will be added as a margin; use 0 for a tightly cropped
image. For SVG, this option works only with single-page scores.

-x, --gui-scaling <factor>
Scales the score display and other GUI elements by the specified factor, for use with high
resolution displays.

-S, --style <style>
Loads a style file; useful when you convert with the -o option

-p, --plugin <name>
Execute the named plugin

--template-mode
Save template mode, no page size

-F, --factory-settings
Use only the standard built-in presets or "factory-settings" and delete preferences. For details,
see Revert to factory settings

-R, --revert-settings
Use only the standard built-in presets or "factory-settings", but do not delete preferences

-i, --load-icons
Load icons from the file system. Useful if you want to edit the MuseScore icons and preview the
changes

-e, --experimental
Enable experimental features. See e.g. Layer (experimental)

-c, --config-folder <pathname>
Set config path

-t, --test-mode
Enable Test Mode

-M, --midi-operations <file>
Specify MIDI import operations file

-w, --no-webview
No web view in Start Center

-P, --export-score-parts
Used with -o .pdf, export score and parts

Qt Toolkit Options

-style= <style>
-style <style>

Determines the style of the GUI application. Possible values are "motif", "windows" and
"platinum". Depending on the platform other styles may be available

-stylesheet= <stylesheet>
-stylesheet <stylesheet>

Sets the application stylesheet. The value of "stylesheet" is a path to a file that contains the
stylesheet
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-platform <platformname[:options]>
Specifies the Qt Platform Abstraction (QPA) plugin.
Example: MuseScore.exe -platform windows:fontengine=freetype

See also

Revert to factory settings
Layer (experimental)

External links

http://doc.qt.io/qt-5/qapplication.html#QApplication
http://doc.qt.io/qt-5/qguiapplication.html#QGuiApplication

Do you have an unanswered question? Post it in the forum.

Glossary
The glossary is a work in progress, please help if you can. You can discuss about this page on
the documentation forum
The list below is a glossary of frequently used terms in MuseScore as well as their meaning.
The differences between American English and British English are marked with "(AE)" and "(BE)",
respectively.

Acciaccatura
A short →grace note.

Accidental
A sign appearing in front of a note that raises or lowers its pitch. The commonest accidentals are
→sharps, →flats or →naturals, but double sharps and double flats are also used. Accidentals
affect all notes on the same →staff position only for the remainder of the measure in which they
occur, but they can be canceled by another accidental. In notes tied across a →barline, the
accidental continues across the →barline to the tied note, but not to later untied notes on the
same →staff position in that measure.

Anacrusis (BE)
See →Pickup Measure.

Anchor
The point of attachment to the score of objects such as Text and Lines: When the object is
dragged, the anchor appears as small brown circle connected to the object by a dotted line.
Depending on the object selected, its anchor may be attached to either (a) a note (e.g. fingering),
(b) a staff line (e.g. staff text), or (c) a barline (e.g. repeats).

Appoggiatura
A long →grace note.

Bar (BE)
See →Measure.

Barline
Vertical line through a →staff, staves, or a full →system that separates →measures.

Beam
Notes with a duration of an →eighth or shorter either carry a →flag or a beam. Beams are used
for grouping notes.

BPM
Beats Per Minute is the unit for measuring tempo. See →Metronome mark

Breve
Brevis

A double whole note or breve is a note that has the duration of two whole notes.
Chord

The minimal definition of a chord is a minimum of two different notes played together.
MuseScore however calls even a single note a chord internally, with the note describing the
pitch, the chord decribing the duration. Chords are based on the choices made by a composer
between harmonics of one, two or three (and more) fundamental sounds. E.g. in the chord of C,
G is the second harmonic, E the fourth of the fundamental C. Now in C7, the B flat is the 6th
harmonic of C and in C Maj7 B is the second harmonic of E and the fourth harmonic of G...

Clef
Sign at the beginning of a →staff, used to tell which are the musical notes on the lines and
between the lines.
There are 2 F clefs, 4 C clefs and 2 G clefs: F third, F fourth, C first, C second, C third, C fourth,
G first, G second (known as treble clef too).
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G first and F fourth are equivalent.
Clefs are very useful for →transposition.

Concert Pitch
Enables you to switch between concert pitch and transposing pitch (see Concert pitch and
Transposition).

Crotchet (BE)
A crotchet is the British English term for what is called a quarter note in American English. It's a
quarter of the duration of a whole note (semibreve).

Demisemiquaver (BE)
A thirty-second note.

Duplet
See →Tuplet.

Eighth note
A note whose duration is an eighth of a whole note (semibreve). Same as British →quaver.

Endings
See →Volta.

Enharmonic notes
Notes that sound the same pitch but are written differently. Example: G# and Ab are enharmonic
notes.

Flag
See →Beam.

Flat
Sign that indicates that the pitch of a note has to be lowered one semitone.

Grace note
Grace notes appear as small notes in front of a normal-sized main note. A short grace note
(→acciaccatura) has a stroke through the stem; a long grace note (→appoggiatura) does not.

Grand Staff (AE)
Great Stave (BE)

A system of two or more staves, featuring treble and bass clefs, used to notate music for
keyboard instruments and the harp.

Half Note
A note whose duration is half of a whole note (semibreve). Same as British →minim.

Hemidemisemiquaver (BE)
A sixty-fourth note.

Key Signature
Set of →sharps or →flats at the beginning of the →staves. It gives an idea about the tonality and
avoids repeating those signs all along the →staff.
A key signature with B flat means F major or D minor tonality.

Koron
An Iranian →accidental which means lower in pitch and it lowers a note by a quarter tone (in
comparison to the →flat which lowers a note by a semitone). It is possible to use this accidental
in a →key signature.
See also →Sori.

Longa
A longa is a quadruple whole note.

Ledger Line
Line(s) that are added above or below the staff.

Measure (AE)
A segment of time defined by a given number of beats. Dividing music into bars provides regular
reference points to pinpoint locations within a piece of music.

Metronome mark
Metronome marks are usually given by a note length equaling a certain playback speed in
→BPM. In MuseScore, metronome marks are used in tempo texts.

Minim (BE)
A minim is the British term for a half note. It has half the duration of a whole note
(→semibreve).

Natural
A natural is a sign that cancels a previous alteration on notes of the same pitch.

Operating System
OS

Underlying set of programs which set up a computer, enabling additional programs (such as
MuseScore). Popular OSes are Microsoft Windows, macOS, and GNU/Linux.
Not to be confused with a sheet music →System.

Part
Music to be played or sung by one or a group of musicians using the same instrument. In a
string quartet, 1st part = Violin 1, 2nd part = Violin 2, 3rd part = Viola, 4th part = Cello, in a choir
there might be parts for soprano, alto, tenor and bass. A part has one or more →staves (e.g.
Piano has 2 staves, Organ can have 2 or 3 staves).

Pickup Measure (→Anacrusis)
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Incomplete first measure of a piece or a section of a piece of music.
See also Create new score: Time Signature... and Measure operations: Exclude from measure
count.

Quaver (BE)
The British quaver is what is called an →eighth note in American English. It has an eighth the
duration of a whole note.

Quadruplet
See →Tuplet.

Quarter note
A note whose duration is a quarter of a whole note (semibreve). Same as British →crotchet.

Quintuplet
See →Tuplet.

Respell Pitches
Tries to guess the right accidentals for the whole score (see Accidentals).

Rest
Interval of silence of a specified duration.

Re-pitch Mode
A way in MuseScore to rewrite a passage with note changes but no rhythm change (see Re-
pitch Mode).

Semibreve (BE)
A semibreve is the British term for a whole note. It lasts a whole measure in 4/4 time.

Semiquaver (BE)
A sixteenth note.

Semihemidemisemiquaver (Quasihemidemisemiquaver) (BE)
An hundred and twenty eighth note.

Sextuplet
See →Tuplet.

Sharp
Sign that indicates that the pitch of a note has to be raised one semitone.

Slur
A curved line over or under two or more notes, meaning that the notes will be played smooth
and connected (legato).
See also →Tie.

Sori
An Iranian →accidental which means higher in pitch and it raises a note by a quarter tone (in
comparison to the sharp which raises a note by a semitone). It is possible to use this accidental
in a →key signature.
See also →Koron.

Spatium (plural: Spatia)
Space
Staff Space
sp (abbr./unit)

The distance between two lines of a normal 5-line staff. In MuseScore this unit influences most
size settings. See also Layout and Formatting, Layout / Page Settings.

Staff (AE)
Stave (BE)

Group of one to five horizontal lines used to lay on musical signs. In ancient music notation
(before 11th century) the staff/stave may have any number of lines (the plural of 'staff' is 'staves',
in BE and AE).

System
Set of staves to be read simultaneously in a score.
See also →Operating System (OS).

Tie

A curved line between two or more notes on the same pitch to indicate a single note of
combined duration:

Quarter note + Tie + Quarter note = Half note
Quarter note + Tie + Eighth note = Dotted Quarter note
Quarter note + Tie + Eighth note + Tie + 16th note = Double Dotted Quarter note

See also →Slur.

Transposition

A tune can be played in any tonality. There are many reasons to change the tonality of a score:

1. The tune is too low or too high for a singer.
2. The score is written for a C instrument and has to be played by a B Flat one.
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3. The score is written for an orchestra and you want to imagine what the horn, the flute and
the clarinet are playing.

4. A darker or a more brilliant sound is desired.

In the first case all the orchestra will have to transpose, which is very difficult without
professional musicians. MuseScore can do it very easily for you.
In the second case the musician must play D when a C is written. If the score is written
with a G 2nd Clef, he'll have to think that the staff begins with a C 3rd Clef.
In the third case the conductor has to transpose all the staves which are not written for C
instruments.
In all cases the key signature must be mentally changed.
On some instruments (Horns and Tubas for instance) the musicians transpose using
alternative fingerings.

Triplet
See →Tuplet.

Tuplet
A tuplet divides its next higher note value by a number of notes other than given by the time
signature. For example a →triplet divides the next higher note value into three parts, rather than
two. Tuplets may be: →triplets, →duplets, →quintuplets, and other.

Velocity
The velocity property of a note controls how loudly the note is played. This usage of the term
comes from MIDI synthesizers. On a keyboard instrument, it is the speed with which a key is
pressed that controls its volume. The usual scale for velocity is 0 (silent) to 127 (maximum).

Voice
Polyphonic instruments like Keyboards, Violins, or Drums need to write notes or chords of
different duration at the same time on the same →staff. To write such things each horizontal
succession of notes or chords has to be written on the staff independently. In MuseScore you
can have up to 4 voices per staff. Not to be confused with vocalists, singing voices like soprano,
alto, tenor and bass, which are better viewed as instruments.

Volta
In a repeated section of music, it is common for the last few measures of the section to differ.
Markings called voltas are used to indicate how the section is to be ended each time. These
markings are often referred to simply as →endings.

External links

http://www.robertcarney.net/musical-terms-definitions.htm

Do you have an unanswered question? Post it in the forum.
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https://musescore.org/en/handbook/tuplet
https://musescore.org/en/handbook/voices
https://musescore.org/en/handbook/volta
http://www.robertcarney.net/musical-terms-definitions.htm
https://musescore.org/en/forum
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